Bug 5624 - (int-143598) Zoom in/out in IM chat does not reflow contents
(int-143598)
: Zoom in/out in IM chat does not reflow contents
Status: VERIFIED WONTFIX
Product: Chat & Call & SMS
Messaging
: 5.0/(1.2009.41-10)
: All Linux
: Low minor with 5 votes (vote)
: ---
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-20 13:31 UTC by Attila Csipa
Modified: 2010-02-04 15:19 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Attila Csipa (reporter) nokia 2009-10-20 13:31:47 UTC
SOFTWARE VERSION:
Maemo 5, 1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Start IM chat, press zoom in/out buttons

EXPECTED OUTCOME:
Zoom in/out to see more content or the whole content in bigger letters

ACTUAL OUTCOME:
The letter size changes, but the layout is not reflown, so zooming in results
in text/time getting out of the screen, and zooming out results in unused/empty
space.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.4pre)
Gecko/20090916 Ubuntu/8.04 (hardy) Shiretoko/3.5.4pre
Comment 1 Mikhail Zabaluev nokia 2009-10-20 14:18:48 UTC
This will be made moot by an update release that will remove zoom altogether.
Comment 2 Jeff Moe 2009-12-01 20:32:42 UTC
If zoom is removed, how will font size be increased in IM?

I know someone who wants N900, but can't read the IM's because they are too
small, and zooming them makes one have to scroll left/right which is less than
optimal....
Comment 3 Mikhail Zabaluev nokia 2009-12-01 20:41:34 UTC
Let's give it another go, then.
Comment 4 Uwe Kaminski 2009-12-01 22:07:08 UTC
First there should be a solution for Bug 6347 (Volume vs. Zoom using the
hardware volume keys).

IMHO also in this application the volume keys should work as volume keys. :)
Comment 5 Attila Csipa (reporter) nokia 2009-12-02 13:43:02 UTC
Let's not get bogged down with the button question from the other bug - here,
it's about the ability to change the size of the text, regardless of the
required user input to do this (menu, +/- buttons, UI elements, etc)
Comment 6 Andre Klapper maemo.org 2010-01-13 18:55:18 UTC
This is a WONTFIX for Maemo5 as the fix is not too easy to do and involves
quite some work.
Comment 7 Jeff Moe 2010-02-04 02:05:45 UTC
FYI: In PR1.1 the ability to increase font size has been removed. Hitting the
volume rocker does not increase font size anymore, it changes sound volume.