Bug 5607 - (int-138356) Call forwarding settings not being saved
(int-138356)
: Call forwarding settings not being saved
Status: CLOSED FIXED
Product: Telephony
General
: 5.0/(1.2009.42-11)
: N900 Maemo
: High normal with 2 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: telephony-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-19 21:10 UTC by mike bradshaw
Modified: 2011-01-26 17:55 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description mike bradshaw (reporter) 2009-10-19 21:10:26 UTC
SOFTWARE VERSION:
(Control Panel > General > About product) 1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
insert Sonera FI SIM card
power on, open settings
open Phone
select call forwarding, enter number using +358...
press save, dialog closes
re-open dialog, note settings not saved

EXPECTED OUTCOME:
Forwarding number is saved

ACTUAL OUTCOME:
checkmark and number are removed

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:


OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us)
AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Comment 1 Andre Klapper maemo.org 2009-10-20 13:13:37 UTC
Thanks for reporting this!
Confirming.
Comment 2 Andrea Borgia 2009-10-22 13:41:31 UTC
FWIW, it happens also with an italian "CoopVoce" card.
Comment 3 Andre Klapper maemo.org 2009-11-10 12:24:47 UTC
This has been fixed in package
connui-cellular 2.102+0m5
which is part of the internal build version
2009.46-5
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 4 Venomrush 2009-12-04 17:07:53 UTC
*** Bug 6583 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2010-01-14 12:25:50 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 6 chavalotetomalosplatanos 2010-01-14 19:36:05 UTC
(In reply to comment #5)
> The problem reported here should be fixed in the update released today for
> public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
> Please leave a comment if the problem is not fixed for you in this update
> version.
> 

The problem is still not fixed for me. I select "No" under phone settings ->
call forwarding and after pressing the Save button if I go back to the phone
settings screen the call forwarding setting is back to On (if not answering
after 20 seconds and blah blah blah) . I'm using a Vodafone SIM (Spain) if that
matters at all.
Comment 7 chavalotetomalosplatanos 2010-01-14 19:58:28 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > The problem reported here should be fixed in the update released today for
> > public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
> > Please leave a comment if the problem is not fixed for you in this update
> > version.
> > 
> 
> The problem is still not fixed for me. I select "No" under phone settings ->
> call forwarding and after pressing the Save button if I go back to the phone
> settings screen the call forwarding setting is back to On (if not answering
> after 20 seconds and blah blah blah) . I'm using a Vodafone SIM (Spain) if that
> matters at all.
> 

OK, I did some testing and the thing is: the call forwarding actually turns off
if you disable it and save the settings, but the next time you enter the phone
settings it still shows it enabled even if it is no longer active.

A cosmetic fix to display the real call forwarding status would be nice since
the current behaviour leads to confusion.
Comment 8 eojedaa 2010-01-28 21:37:56 UTC
Same problem for me as well, Maemo5 update version 2.2009.51-1 installed.....
Comment 9 Andre Klapper maemo.org 2010-02-16 16:08:20 UTC
Hmm, at least the checkmark should have been fixed in 2.2009.51-1...

If this is still an issue in 3.2010.02-8, please open a new bug report here.
Thanks a lot.
Comment 10 Venomrush 2010-03-01 22:35:30 UTC
Verifying that it is saving properly in PR1.1.1 3.2010.02-8 and PR1.1
Please close bug.
Comment 11 Johannes Berg 2011-01-26 17:55:38 UTC
I'm seeing the behaviour from comment #7 (saved to network, but shown wrong) on 

# apt-cache show connui-cellular-settings
Package: connui-cellular-settings
Priority: optional
Section: x11
Installed-Size: 104
Maintainer: Mikko Mehtonen <ext-mikko.j.mehtonen@nokia.com>
Architecture: armel
Source: connui-cellular
Version: 2.118+0m5


which is 20.2010.36-2.