Bug 5602 - (int-143528) IP address field in WiFi advanced settings partially hidden ("Recuperar automáticamente direccíon IP" string too long)
(int-143528)
: IP address field in WiFi advanced settings partially hidden ("Recuperar autom...
Status: CLOSED FIXED
Product: Translations
Español (España)
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: es-es-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-19 18:18 UTC by Daniel Martin Yerga
Modified: 2010-03-15 20:56 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Daniel Martin Yerga (reporter) 2009-10-19 18:18:33 UTC
SOFTWARE VERSION:
Maemo 5 1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

1) Change your N900 to Spanish language: Applications Menu->Settings->Language
and Region->Device Language->Choose: "Español (España)"-> Accept the dialog.
The device will reboot.

2) Go to Applications Menu->"Ajustes"->"Conexiones a Internet"->"Conexiones". 

2.a) If you have some defined connection: Select the
connection->"Editar"->"Siguiente" x N times (depending of the kind of
connection)  until the last page.

2.b) If you haven't any connections: "Nueva"->"Siguiente"->"Siguiente"->Press
No in the shown dialog->Write some text in "Nombre de red (SSID)" entry, for
example "yerga rocks"->"Siguiente".

5) In the last page of the wizard->"Avanzado"->Choose the "Direcciones IP" tab
from the dialog.

4) Try to write some IP in any of the available entries.

EXPECTED OUTCOME:

You can see the complete IP number you're writing.


ACTUAL OUTCOME:

You can only see the first 6 numbers, doing impossible to see the real number
you're writing.


REPRODUCIBILITY:
Always


OTHER COMMENTS:

I wrote the bug report in Connectivity-WiFi because the related bug #5544 is
there too (if that bug were fixed this bug wouldn't do sense).
This isn't a bug in the translation, yes, the Spanish sentences are very long
but they're completely perfect.

Feel free to change the product/component to the better one.
Comment 1 Andre Klapper maemo.org 2009-10-19 22:25:37 UTC
Oh yeah.
The problem is that the string "Recuperar automáticamente direccíon IP" is too
long and makes the widget only partially displayed.
Ugly.

This must be solved in the Spanish translation.

Settings > Internet Connections > Connections > Edit > Next... > Advanced > IP
Addresses: Auto-retrieve IP address
Comment 2 Andre Klapper maemo.org 2009-10-30 17:37:48 UTC
This has been fixed in package
osso-connectivity-ui-l10n
which is part of the internal build version
2009.44-5
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.

The IP number field for "Dirección IP" and others is now nearly entirely
displayed. "101.101.101.101" is still not completely readable at once, but it's
like "101.101.101.1" and I think we can live with that.
Comment 3 Andre Klapper maemo.org 2009-12-07 16:53:23 UTC
*** Bug 6665 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Martin Yerga (reporter) 2009-12-23 17:18:58 UTC
Verified in non-public PR 1.1 version.
Comment 5 Andre Klapper maemo.org 2009-12-28 15:57:49 UTC
*** Bug 7324 has been marked as a duplicate of this bug. ***
Comment 6 Andre Klapper maemo.org 2010-03-15 20:56:23 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).