Bug 5601 - (int-143675) libsdl: Task switcher area can be a dead area
(int-143675)
: libsdl: Task switcher area can be a dead area
Status: RESOLVED FIXED
Product: Desktop platform
general
: 5.0/(1.2009.41-10)
: N900 Maemo
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: HAF QA mailing list
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-19 17:58 UTC by Tim Edmonds
Modified: 2010-01-14 12:28 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Edmonds (reporter) 2009-10-19 17:58:16 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Run a fullscreen SDL application - I used numptyphysics development version.
Click in the top left where the task switcher icon usually is.

EXPECTED OUTCOME:
The click should not be passed through to the application and should trigger
the task switcher.

ACTUAL OUTCOME:
The click is not received by the game but no other action occurs either.

REPRODUCIBILITY:
almost always - actually I have only seen the expected outcome work once.

EXTRA SOFTWARE INSTALLED:
numptyphysics v0.3.0.7 or similar

OTHER COMMENTS:
Actually, I am not sure if the system really should grab the clicks from the
fullscreen window - this leaves a dead area for the app.
Comment 1 Mikko Vartiainen 2009-10-20 15:15:04 UTC
For all sdl games in extras-testing (wormux, supertux, solarwolf etc) clicking
in task switcher area triggers task switcher. I don't know how it works but for
all these games it's a good thing imo.

>Actually, I am not sure if the system really should grab the clicks from the
>fullscreen window - this leaves a dead area for the app.

I agree that for some games task switching area can cause major problems. There
should be some documentation if it's possible to control task switching
behaviour somehow.
Comment 2 Andre Klapper maemo.org 2009-10-20 20:06:39 UTC
So it looks like you use different code as you see different results with the
area in the upper left corner.

Hence this makes this a request to improve the Documentation...
Comment 3 Tim Edmonds (reporter) 2009-10-30 00:33:38 UTC
i figured it out.  if we create the sdl window as a fullscreen window then all
is ok.  however if we create a normal window and then toggle to fullscreen it
absorbs the click but does not trigger the switcher.  definitely a bug there
but easily worked around.

ideally the app could control this function itself as the deadspace is
annoying. is this particular to sdl or is it global? maybe this is how the map
app works.
Comment 4 Andre Klapper maemo.org 2009-11-19 16:22:28 UTC
Internal comment:

"tried out numptyphysics_0.3.0.5_armel.deb and forced the window fullscreen by
an external command.  the area of the tasks button behaved just like the rest
of the screen.  it seems to be fixed in the internal week 47 release.
hildon-desktop 1:2.2.116-1+0m5, libsdl1.2 1.2.13-2maemo8+0m5"
Comment 5 Mikko Vartiainen 2009-11-19 20:57:56 UTC
If you need easy test case, try openttd (ctlr+enter switches to fullscreen)
Comment 6 Tim Edmonds (reporter) 2009-11-19 21:47:23 UTC
(In reply to comment #4)
> an external command.  the area of the tasks button behaved just like the rest
> of the screen.  it seems to be fixed in the internal week 47 release.

does "behaved like the rest of the screen" mean that there is no dead area and
the app gets all the clicks or that the area successfully launches the
app-switcher?
Comment 7 Andre Klapper maemo.org 2009-11-24 16:01:15 UTC
This has been fixed in package
libsdl1.2 1:1.2.13-2maemo8+0m5
which is part of the internal build version
2.2009.47-17
(Note that 2009 is the year and the number after is the week.)

Task button is not receiving the tap when a SDL application is in full screen.

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.

If you still think that better documentation is needed, please file a separate
bug report here. Thanks a lot!
Comment 8 Mikko Vartiainen 2009-11-24 16:15:17 UTC
Exactly NOT the solution that I wanted...
Comment 9 Andre Klapper maemo.org 2009-11-24 16:17:59 UTC
Yes, but I think it's more consistent - e.g. also how it's always been in
hex-a-hop.
Comment 10 Mikko Vartiainen 2009-11-24 16:30:51 UTC
Now I'm confused. Hex-a-hop launches task switcher when tapping on upper left
corner (PR 1.0 firmware), bug resolution says that it won't do it after
upgrade, and you say hex-a-hop has worked the same way before and after the
upgrade?
Comment 11 Andre Klapper maemo.org 2009-11-24 16:38:58 UTC
> Hex-a-hop launches task switcher when tapping on upper left
> corner (PR 1.0 firmware)

Uh? I've been definitely playing it for a few weeks and I never managed to get
out of the game by using the upper left corner... Weird.
Comment 12 Mikko Vartiainen 2009-11-24 16:46:19 UTC
(In reply to comment #11)
> Uh? I've been definitely playing it for a few weeks and I never managed to get
> out of the game by using the upper left corner... Weird.

In fullscreen mode? Anyway it's now clear to me how it's going to work. There's
still ctrl+backspace and hopefully the hypotethical keyboardless maemo5 device
has hw task switching button.
Comment 13 Andre Klapper maemo.org 2010-01-14 12:28:40 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.