Bug 5596 - (int-143672) Inform about why an application requests an Internet connection
(int-143672)
: Inform about why an application requests an Internet connection
Status: RESOLVED WONTFIX
Product: Connectivity
ICD
: 5.0/(1.2009.41-10)
: All Linux
: Low normal with 1 vote (vote)
: ---
Assigned To: unassigned
: icd-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-19 15:40 UTC by Murray Cumming
Modified: 2009-10-22 11:19 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Murray Cumming (reporter) 2009-10-19 15:40:53 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
N900 Product Loan from Maemo Summit

STEPS TO REPRODUCE THE PROBLEM:
- Have no packet data connection enabled.
- Be away from any enabled wireless connection.
- Start the camera application.
- Try to take a picture.

EXPECTED OUTCOME:
- I can take a picture without interruption.

ACTUAL OUTCOME:
- The camera asks me to choose a network connection. It doesn't say why it
wants one. I guess it wants to geotag the photo that I will take. Even when I
cancel that by clicking off the window (a very small space for cancelling), it
keeps asking again.

I can't just ignore this because it obscures the camera preview.

REPRODUCIBILITY:
(always/sometimes/once)

Always
Comment 1 Lucas Maneos 2009-10-20 02:59:44 UTC
The "repeatedly requests a network connection" is bug 5368, while the "without
saying why" is most likely a WONTFIX since it's icd that prompts the user and
it doesn't have a way of knowing why the requesting app wants a connection.  I
suppose the camera app could tell the user itself with another prompt, but that
would be even more annoying.

Resolving as duplicate, but of course feel free to reopen if you feel strongly
about the "why".

*** This bug has been marked as a duplicate of bug 5368 ***
Comment 2 Murray Cumming (reporter) 2009-10-20 09:55:06 UTC
> WONTFIX since it's icd that prompts the user and
> it doesn't have a way of knowing why the requesting app wants a connection

So icd could have a way to show why it's needed. Given the high costs of packet
data connections, users want to know why a network connection is needed. Can we
therefore reassign this to somewhere?
Comment 3 Lucas Maneos 2009-10-20 17:22:51 UTC
Redirecting as per last comment.
Comment 4 Andre Klapper maemo.org 2009-10-22 11:19:19 UTC
Forwarding internal comment:

"Sorry, WONTFIX applies here.
It is possible to change the network connectivity behaviour such that the
packet data connection is not considered when connecting automatically. In this
particular case the user is prompted to select a network, which only happens
when an application signals an user event (i.e. the user selected something and
can be expected to be looking at the screen still a few seconds later). The
select connection prompting assumes that the user notices a potential network
bill if he enables packet data. I don't think the camera is even sending
anything big here, is maybe Settings -> Location -> Network positioning
enabled?
The why a connection is needed would also be misleading: maybe the email
application requested a connection, and only later the camera was started. This
would require another prompt asking if it's ok for the camera to connect. Also
all other subsequent apps would need to be confirmed by the user, leading to a
very annoying user experience.
The same reasoning is also applicable to Harmattan."