Bug 5552 - (int-151988) When being called it is not clear what number someone used
(int-151988)
: When being called it is not clear what number someone used
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Call Application UI
: 5.0/(1.2009.41-10)
: All Linux
: Low enhancement with 33 votes (vote)
: Harmattan
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-17 20:37 UTC by Karlo Luiten
Modified: 2010-08-30 14:10 UTC (History)
15 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Karlo Luiten (reporter) 2009-10-17 20:37:07 UTC
SOFTWARE VERSION:
 5.0

STEPS TO REPRODUCE THE PROBLEM:
 Receive a call from someone you have multiple numbers of, e.g. mobile & home
number

EXPECTED OUTCOME:
 I hoped to see: "John Doe is calling you [MOBILE]" or something like that.

ACTUAL OUTCOME:
 I see: "John Doe is calling you"

REPRODUCIBILITY:
 always

EXTRA SOFTWARE INSTALLED:
 Nothing of importance

OTHER COMMENTS:
 Only a small icon what number someone uses would already be quite helpful.



User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.14)
Gecko/2009090216 Ubuntu/9.04 (jaunty) Firefox/3.0.14
Comment 1 Mikhail Zabaluev nokia 2009-10-19 15:26:50 UTC
In our UI concepts overall, we emphasize people and communication events over
the actual medium of communication. But I guess it's still important in some
cases.
Comment 2 John Veness 2009-10-25 01:16:43 UTC
This is important to me, too. If my wife is late coming home then rings me, it
is nice to see in advance whether she is ringing from her work phone number or
her mobile phone number, for example. I could achieve this with separate
address book entries, but then that is messy when initiating outgoing calls.
Comment 3 Mikhail Zabaluev nokia 2009-11-02 13:36:33 UTC
The internal bug got the WONTFIX resolution. We're open for your votes.
Comment 4 Mikhail Zabaluev nokia 2009-12-16 12:49:12 UTC
*** Bug 7024 has been marked as a duplicate of this bug. ***
Comment 5 Amer Saeed 2009-12-28 23:48:01 UTC
This feature is an absolute must have. Please get this bug fixed as most of my
contacts have multiple numbers (some even with local and international numbers)
and its impossible to know what number they called from.
Comment 6 Andre Klapper maemo.org 2009-12-29 13:03:16 UTC
*** Bug 7426 has been marked as a duplicate of this bug. ***
Comment 7 Mikhail Zabaluev nokia 2009-12-29 16:26:10 UTC
There is already a bug we're fixing for the redialing case, where you really
may need to dial exactly the number you were called from. That will also
provide a somewhat kludgy way to distinguish the caller's number after the
call.

Considering that, is this case - knowing _how_ somebody you have in the address
book is calling you, before accepting the call - really that important?
I know one country where there were charges on some incoming calls, but that
was legislated out years ago. Is it still the case people are concerned about?
Comment 8 Mikhail Zabaluev nokia 2009-12-29 16:28:32 UTC
(In reply to comment #7)
> There is already a bug we're fixing for the redialing case, where you really
> may need to dial exactly the number you were called from.

Bug #6651, to be precise.
Comment 9 Stian Jordet 2009-12-29 16:31:01 UTC
I guess it's just a case of "being used to". All cellphones I've had since it
became usual with several numbers per contact (Starting with Nokia 7110 for
me), it has shown an icon resembling a cellphone for cell, house for home and
office for work before the number. Very small ui-changes, and at the same time
very intuitive.

While it's not "necessary" it's quite nice to see. For instance when someone
calls me from their work phone in the evening, I can answer "geez, still at
work?" :)
Comment 10 Mikhail Zabaluev nokia 2009-12-29 16:40:29 UTC
(In reply to comment #9)
> While it's not "necessary" it's quite nice to see. For instance when someone
> calls me from their work phone in the evening, I can answer "geez, still at
> work?" :)

Nice to have, yes, but this is not quite the severity that is asserted in
comment #5. I'd like to hear more voices confirming the latter opinion.
Comment 11 Mikhail Zabaluev nokia 2009-12-29 16:46:56 UTC
Reopening to consider for Harmattan.
Comment 12 gauthamn 2010-01-01 09:24:00 UTC
Also in other phones with Symbian OS you had 1. the number flashing for a
longer time before the contact name flashed and 2. possibility of clicking on
the call log to see the number the call was made from (bug 6651). The above 2
points helped get around this shortcoming.  

Can point 1 mentioned here be implemented by extending the time the number
flashes up before the contact name starts flashing or the number and the name
could flash alternately which would to a large extent take care of this
problem.

It would be great if this was fixed in the present version and not wait for
Maemo 6. 

(In reply to comment #10)
> (In reply to comment #9)
> > While it's not "necessary" it's quite nice to see. For instance when someone
> > calls me from their work phone in the evening, I can answer "geez, still at
> > work?" :)
> 
> Nice to have, yes, but this is not quite the severity that is asserted in
> comment #5. I'd like to hear more voices confirming the latter opinion.
>
Comment 13 7el.3ane 2010-01-06 17:54:38 UTC
ok course it is important, both in the log, and when receiving a call, for
example for me it's important for all the reasons already mentioned, and also
because i can call for free to all landlines and lines from the same company as
mine, so if a family member or a friend is calling me from one of these numbers
i can hang the call and call him back ...
and yes i hope these bugs will be fixed soon , coz it's kind of annoying ...

Thanks
Comment 14 7el.3ane 2010-01-06 18:00:14 UTC
ah and one more thing, why for god's sake the history is deleted ! in the log ?
i mean it always leaves only the last instance in the log, unlike all the
symbian phones where we were able to see all the times when a user called us a
sent and sms or whatever ...
sometimes it's very important to know, for example at what time the caller
called us the first time then the second ... etc

Regards
Comment 15 Andre Klapper maemo.org 2010-01-06 18:07:57 UTC
7el.3ane: maemo.org Bugzilla is not a forum. Please stay on-topic and do not
add unhelpful comments that don't add any value to the technical issue. Thanks.
Comment 16 Oli 2010-01-11 22:24:24 UTC
This shortcoming is really a big deal for me!
I have a luxembourgish sim-card but I study in Germany and I have a flatrate to
call to a luxembourgish landline. I've gotten used to people (girlfriend,
parents) giving me a quick ring from their home-phone to let me know I can call
them back, because it's free for me. Without proper caller ID, I don't know
which number to call. Having to call different numbers in order to reach
somebody is time consuming and costs money.

In addition, i never know which number to call back to, when friends with sim
cards from two different countries are calling me, since one phone might be
switched off when they're abroad, or which number i should send a message to,
when I can't pick up the phone at that very moment. 

This really has to be fixed, or the lack of this function makes having
different numbers stored under one name redundant.

Best regards.
Comment 17 K. Dermitzakis 2010-04-06 05:42:19 UTC
(In reply to comment #7)
> Considering that, is this case - knowing _how_ somebody you have in the address
> book is calling you, before accepting the call - really that important?
> I know one country where there were charges on some incoming calls, but that
> was legislated out years ago. Is it still the case people are concerned about?

With the current behaviour is quite hard to know where contacts that have
numbers in more than one countries are (for me at least 50% of frequent comms)
and whether or not someone is calling from their office or home or mobile.

There is an obvious reason why this is bad: whether you want to hang up and
call them back, or ignore the call depending on where they are, purely due to
call charges - to you or them, doesnt matter.

But the not so obvious (as it seems) but quite important (to me personally at
least) is that the current implementation makes the n900 user lack *situational
awareness*.

I will try to make up some examples:

[*] You arrange with someone to go shopping/drinks/whatever and arrange a time.
Close to that time, you receive a call from them. Having the situational
awareness of where they are located (home/office or cellphone), you can better
deal with the situation (they can either be on the way or late).

[*] Again you arrange (in advance) to pick up someone from home some time after
work. As you drive to their place you receive a call from them. With the
current implementation you are unable to see where they are calling from.
Having known this, you could either (1) hang up (its from their home, and
you're there in a minute, save money), (2) pick up (its from work and they're
still at work, i dont have to rush through the traffic/i have to rearrange
pickup point).

There are countless such examples, and they all provide you with situational
awareness which in most cases saves you from repeating "oh, btw i dont really
know where youre calling me from, where are you?" and at some cases helps
organize your contacts better (having emergency-must-answer numbers as seperate
contacts is troublesome).

I have the personal impression that this situational awareness is engraved to
current mobile phone users (you dont expect a mobile phone user picking up to
ask you where are you when you are calling from home!) so much that not having
it *feels* like something is lost somewhere.

An extreme analogy would be having no caller ID at all and a message "Someone
is calling you". You could then add a second staple sentence like the one
above, "Hey, who are you?" Its not really important to know who is calling you
(unless you have a lot of people you want to avoid being called from), but it
takes away from this awareness, no?
Comment 18 Mikhail Zabaluev nokia 2010-04-06 12:24:25 UTC
(In reply to comment #17)
> But the not so obvious (as it seems) but quite important (to me personally at
> least) is that the current implementation makes the n900 user lack *situational
> awareness*.

Thank you for the insight.
Comment 19 hans.boonen 2010-04-18 00:59:00 UTC
The same applies to SMS messages; I can not see which number was used to send
it (if a contact has multiple numbers).

The number is only showed very short (less than a second) when the SMS is
opened. A menu point to view this would be great.
Comment 20 Andre Klapper maemo.org 2010-04-27 12:59:07 UTC
(In reply to comment #19)
> The same applies to SMS messages

Different issue covered by bug 6016.
Comment 21 Andre Klapper maemo.org 2010-04-27 12:59:17 UTC
*** Bug 10044 has been marked as a duplicate of this bug. ***
Comment 22 ziad karabibar 2010-05-29 09:19:25 UTC
After a long wait to get the new firmware update, I am disappointed to see that
this issue has not been addressed properly.
what's wrong ?? Nokia is not selling there phone in one area of the planet. 
The business users who decided to purchase this N900 are expected to be on the
move and have international contacts. 
We still can't possibly know whether the caller is currently in the same
country we're in (A) so we pick up... or calling from his international country
(B).

can't you add a field to each number that shows that this number is in the USA
or France or ... then when they call, if you insist we don't see the number, we
can at least know the location?!
thanks
Comment 23 Matthew Wronka 2010-06-16 23:12:11 UTC
One additional use case is, how my phonebook is set-up, I have a 1 number->1 or
more people; e.g. 

Father
  Mobile Number +1NXXX2345
  Work Number +1NXXX5432
  Home Number +1NXXX7766

Mother
  Mobile Number +1NXXX3542
  Home Number +1NXXX7766

In this case, knowing that the incoming number is +1NXXX7766 would tell me
that it could be either parent (this is sometimes more important than you might
think ... )

I thought a saw a bug to show multiple contacts if the number matched both
which would work around this particular use case (but not the others
mentioned), but showing just one person is misleading.

The obvious work around is to have a "Mother and Father" contact, but that is
suboptimal in my view, especially as this isn't necessary on other platforms
where my contacts are synched.
Comment 24 Mikhail Zabaluev nokia 2010-06-17 16:11:53 UTC
(In reply to comment #23)
> Father
>   Mobile Number +1NXXX2345
>   Work Number +1NXXX5432
>   Home Number +1NXXX7766
> 
> Mother
>   Mobile Number +1NXXX3542
>   Home Number +1NXXX7766
> 
> In this case, knowing that the incoming number is +1NXXX7766 would tell me
> that it could be either parent (this is sometimes more important than you might
> think ... )

Yes, this is known and should be taken care of. The user should not have to do
anything special for this case. Except when the number of matching contacts is
more than two or three, I think the text could stop listing names...
Comment 25 Andre Klapper maemo.org 2010-07-18 18:26:10 UTC
*** Bug 10957 has been marked as a duplicate of this bug. ***
Comment 26 Andre Klapper maemo.org 2010-08-30 14:10:52 UTC
Fixed for Harmattan (the version after Maemo5).