Bug 5549 - libosso-abook should be open source
: libosso-abook should be open source
Status: RESOLVED WONTFIX
Product: Licensing Change Requests
General
: 5.0/(3.2010.02-8)
: All Linux
: Unspecified enhancement with 18 votes (vote)
: ---
Assigned To: Quim Gil
: licensing-requests
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-17 18:48 UTC by José Dapena Paz
Modified: 2011-04-04 15:18 UTC (History)
8 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description José Dapena Paz (reporter) 2009-10-17 18:48:23 UTC
EXPECTED OUTCOME:

libosso-abook is published with a free software license as the libraries it
enhances.

ACTUAL OUTCOME:

From /usr/share/doc/libosso-abook/copyright:

"Copyright (C) 2005-2008 Nokia Corporation

This is proprietary software owned by Nokia Corporation."

OTHER COMMENTS:

The library and framework of libosso-abook provides all we would love to see in
a gnome desktop, about integration of presence and addressbook information, and
using exactly the stack of technologies that fits better.

You can see some blog posts pointing at this as a thing we would love to see:
* Andre Klapper:
http://blogs.gnome.org/aklapper/2009/08/14/wishlist-evolution-instant-messaging-integration/
* In Gnome roadmap, section "Collaboration". http://www.gnome.org/roadmap/
* Galago is an attempt to do the same.
http://gnomejournal.org/article/4/galago---presence-for-the-linux-desktop

The best thing is that libosso-abook already provides all these things. So just
a wise movement from Nokia publishing this would be really appreciated in Gnome
desktop community.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-es) AppleWebKit/531.2+
(KHTML, like Gecko) Safari/531.2+
Comment 1 Andre Klapper maemo.org 2009-10-18 22:27:39 UTC
Hi José, thanks for reporting this.

For general reasons about closed packages, see
http://wiki.maemo.org/Why_the_closed_packages .
In general: The better the provided reasons are to make this open source, the
easier it is to convince people. But you know that. :-)

Reassigning to Quim as this goes into politics instead of technical issues.
Comment 2 Quim Gil nokia 2009-10-21 13:21:38 UTC
In internal discussion. Don't hold your breath, but it might happen.
Comment 3 arnim sauerbier 2009-12-28 01:30:47 UTC
Open source means users can trust library with their personal contact data. Or
change it if they dont like it.  If its open nobody can complain, really.
Comment 4 Marco Barisione 2009-12-28 01:43:55 UTC
Note that the actual storage of the data is done by the file backend of EDS,
see http://maemo.gitorious.org/eds-fremantle
The backend that talks to the IM services through Telepathy is free too, see
http://maemo.gitorious.org/eds-backend-telepathy

libosso-abook contains the code to make using EDS non-painful, the code for
metacontacts (the integration between the IM contacts and the local ones) and
the widgets. The first two of the lists could be very useful is free.
Comment 5 Andre Klapper maemo.org 2010-02-16 19:56:56 UTC
(Moving all Licensing Change Requests to a separate Product in Bugzilla.
Sorry for the bugmail noise)
Comment 6 Carsten Munk maemo.org 2010-02-18 16:48:45 UTC
Temporarily setting this to priority unspecified while it gets evaluated.
Comment 7 Carsten Munk maemo.org 2010-02-19 10:14:47 UTC
Quim, could you check if there was an update on this? Think I saw some info
regarding that component.
Comment 8 José Dapena Paz (reporter) 2010-07-25 23:04:46 UTC
Any change on this? It would be lovely to have this opensourced in some way.
Comment 9 Quim Gil nokia 2010-08-10 21:26:21 UTC
Resolving this request as WONTFIX. We got an internal discussion and there has
been a business decision not to open this component.

The reasoning is that Nokia wants to concentrate its open development and the
development attention in the components developed for the MeeGo platform.
libosso-abook is not part of the MeeGo architecture and Nokia doesn't have
plans to develop it further.
Comment 10 Gordon Schumacher 2010-10-01 00:07:04 UTC
The trouble is, the QtContacts module in Qt Mobility requires libebook and
libosso-abook.  In effect, this means that any development for a project using
QtContacts must be done on a Maemo or Meego system (and an Atom is a poor
choice for a development machine!), or in one of the various emulation
environments (which IME are quite touchy and difficult to get running).

I wouldn't object if there were another back-end available for QtContacts, but
right now there isn't.

For that matter... doesn't this mean that nobody but Nokia is allowed to use
QtContacts without a commercial license, because of the whole thing about
linking proprietary libraries into an (L)GPL'ed application...?
Comment 11 Marco Barisione 2010-10-01 16:40:04 UTC
(In reply to comment #10)
> The trouble is, the QtContacts module in Qt Mobility requires libebook and
> libosso-abook.

Note that libebook is open source.
QtContacts uses libosso-abook and libebook only on Maemo 5 (Fremantle), not on
Meego or Meego/Harmattan. There are other backends for other systems.
Even if libosso-abook was open it would not work on other systems. It's really
Maemo specific.

> In effect, this means that any development for a project using
> QtContacts must be done on a Maemo or Meego system (and an Atom is a poor
> choice for a development machine!),

I don't understand what you mean.

> or in one of the various emulation
> environments (which IME are quite touchy and difficult to get running).

If you want to develop for Maemo/Meego you need one of those. Or are you trying
to develop for the desktop?

> I wouldn't object if there were another back-end available for QtContacts, but
> right now there isn't.

There are others, for instance the memory one that just keeps everything in
memory or a Symbian one.
I wrote a backend too, using GNOME's libfolks.

> For that matter... doesn't this mean that nobody but Nokia is allowed to use
> QtContacts without a commercial license, because of the whole thing about
> linking proprietary libraries into an (L)GPL'ed application...?

Not at all, you can use libosso-abook in your (L)GPL'ed application.
Comment 12 Gordon Schumacher 2010-10-01 17:36:53 UTC
(In reply to comment #11)

> QtContacts uses libosso-abook and libebook only on Maemo 5 (Fremantle), not on
> Meego or Meego/Harmattan. There are other backends for other systems.

Sorry, I somehow managed to miss that in the documentation.  I have no idea
then why QtContacts hadn't been built on my system, but the issue is solved for
me in a rebuild.

> Even if libosso-abook was open it would not work on other systems. It's really
> Maemo specific.

Ah, I wasn't aware of that.


> I don't understand what you mean.

Well, with my thinking that you *had* to have the osso stuff for QtContacts to
be built, that pretty much meant that it had to be an environment which had it
installed.  Also not applicable with what I've learned now.

> If you want to develop for Maemo/Meego you need one of those. Or are you trying
> to develop for the desktop?

Well, no, I am developing for Meego,  Previously, I've been kinda limited by
lack of correct hardware though, and you have to admit that an Atom is an ugly
choice of machine for running compiles on.

> There are others, for instance the memory one that just keeps everything in
> memory or a Symbian one.
> I wrote a backend too, using GNOME's libfolks.

Yup - I found the QtContacts engine reference shortly *after* hitting "commit"
(of course).

> Not at all, you can use libosso-abook in your (L)GPL'ed application.

Off-topic, but I'm curious - I thought LGPL prohibited closed-source libraries,
unless you provided some way to swap them for an open component...?
Comment 13 Andre Klapper maemo.org 2010-10-01 17:41:47 UTC
(In reply to comment #12)
> I thought LGPL prohibited closed-source libraries

http://en.wikipedia.org/wiki/LGPL#Differences_from_the_GPL ?
Comment 14 Marco Barisione 2010-10-01 19:12:43 UTC
(In reply to comment #12) 
> Well, no, I am developing for Meego,  Previously, I've been kinda limited by
> lack of correct hardware though, and you have to admit that an Atom is an ugly
> choice of machine for running compiles on.

You can use the SDK on any normal computer. It's even better than Maemo as the
N900 is arm, while Atoms are x86s. Anyway, we are really going off-topic so
let's stop discussing this ;)

> Yup - I found the QtContacts engine reference shortly *after* hitting "commit"
> (of course).

Typical :)