Bug 5522 - (int-140202) Plays next radio station when current station cuts out / has playback issues
(int-140202)
: Plays next radio station when current station cuts out / has playback issues
Status: RESOLVED FIXED
Product: Media player
General
: 5.0:(10.2010.19-1)
: All Linux
: Low normal with 6 votes (vote)
: 5.0/(20.2010.36-2)
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-16 20:49 UTC by Tomasz Dominikowski
Modified: 2010-10-25 17:12 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tomasz Dominikowski (reporter) 2009-10-16 20:49:31 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

Go to somafm.com and click on Groove Salad.
Groove Salad should be added automatically and start playing in the Media
Player.
Bookmark it.
Play it for a few hours.

EXPECTED OUTCOME:

Even with connectivity problems, the desired radio station should not switch
automatically to the next one.

(It should also not have intermittent stops in playback and re-buffering for no
reason whatsoever, I have a completely unused and completely stable 3mbit
connection, my N810 is more stable with Internet radio playback on the same
connection, actually a lot more).

ACTUAL OUTCOME:

During some sort of a connectivity issue where Groove Salad stopped playing and
was buffering again (can't be sure, the screen was off, I was doing something
else, but this happens a bit too often to my liking), it suddenly switched to
the next station on the list (in my case it was "ITA - Radio Studio Mix"). I
noticed this immidiately, because the music there is a completely different
genre :)

REPRODUCIBILITY:
(always/sometimes/once)

It happened to me once, but will be monitoring the situation. 

EXTRA SOFTWARE INSTALLED:

None that would interfere and nothing else was running on the phone besides the
Media Player.

OTHER COMMENTS:

Perhaps some failsafe mechanisms should be implemented?

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.0.14)
Gecko/2009090216 Ubuntu/9.04 (jaunty) Firefox/3.0.14
Comment 1 Tomasz Dominikowski (reporter) 2009-10-27 19:10:36 UTC
This has happened to me many times now, so REPRODUCABILITY is "often".
Comment 2 Andre Klapper maemo.org 2009-11-03 12:21:31 UTC
*** Bug 6002 has been marked as a duplicate of this bug. ***
Comment 3 thomas 2009-12-15 12:47:51 UTC
i can confirm the same behavior with swedish radio station p3
(mms://wm-live.sr.se/sr-p3-high). especially when listening to the radio on the
move, it almost always stops at some point (to buffer?), and then changes to
the next radio station.
Comment 4 Andre Klapper maemo.org 2009-12-15 13:16:11 UTC
Alias and Target Milestones are set => somebody's working in fixing this. :)
Comment 5 Tomasz Dominikowski (reporter) 2009-12-24 15:38:53 UTC
Any official word about this wrt to the internal bugtracker? Because it seems
to be fixed in PR1.1 from what little testing I did.
Comment 6 Andre Klapper maemo.org 2009-12-28 13:27:22 UTC
This has been fixed in the internal build version
2009.51-8
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2009-12-28 13:29:29 UTC
Argh, my last comment was misleading.
It definitely works in 2009.51-8, but it has been definitely fixed before.
So if it works in PR1.1: Great, and thanks for retesting this, Tomasz!
Comment 8 Andre Klapper maemo.org 2010-01-14 12:26:59 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 9 Cash Clientel 2010-01-18 14:26:27 UTC
(In reply to comment #8)
> The problem reported here should be fixed in the update released today for
> public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
> Please leave a comment if the problem is not fixed for you in this update
> version.
> 

This is NOT fixed in my 2.2009.51-1; behaviour seems exactly the same.
Comment 10 Andre Klapper maemo.org 2010-01-22 17:18:30 UTC
*** Bug 7943 has been marked as a duplicate of this bug. ***
Comment 11 Frederik Niedernolte 2010-01-23 02:29:54 UTC
I only want to confirm that it is not fixed in PR1.1
Comment 12 Cash Clientel 2010-02-16 14:59:07 UTC
(In reply to comment #10)
> *** Bug 7943 has been marked as a duplicate of this bug. ***
> 

Andre,

This bug is not fixed, please can you reopen it.


Best Regards,
Tim
Comment 13 Andre Klapper maemo.org 2010-02-16 15:04:26 UTC
I was too optimistic it seems, sorry (and the internal ticket is not clear at
all when this was fixed exactly). Fix should definitely be in the next release.
Comment 14 Andre Klapper maemo.org 2010-03-15 20:54:45 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 15 Eduard Hasenleithner 2010-05-30 11:29:03 UTC
I have tested the media player with PR1.2 but it still skips to the next
station after playback problems. IMHO this bug is NOT FIXED.
Comment 16 Andre Klapper maemo.org 2010-06-23 15:15:43 UTC
Tomasz & others that had this problem:
Does this work for you in 10.2010.19-1?

If not, can you provide a testcase (I wonder if the testcase in comment 3 still
works)?
Comment 17 Cash Clientel 2010-06-23 15:28:04 UTC
> If not, can you provide a testcase (I wonder if the testcase in comment 3 still
> works)?

This example in comment 3 is still valid.

Further details:
(While connected to Mobile data, as the signal tends to fluctuate more)
1. Go on to the first radio steam on the list and play it
2. Wait, maybe 2-3 minutes tops, while walking around (so as to affect mobile
reception)
3. Stream will switch to one after it if the signal starts to degrade and it
needs to buffer.
Comment 18 area 2010-06-25 03:43:53 UTC
I can also confirm this has not been fixed in PR1.2.

The steps in comment #17 are easily reproduced for me.
Comment 19 Andre Klapper maemo.org 2010-06-30 17:51:02 UTC
Thanks for retesting.
Reopening.
Comment 20 Andre Klapper maemo.org 2010-07-08 13:49:44 UTC
This has been fixed in package
mediaplayer 1.3-3+0m5
which is part of the internal build version
2010.25-2
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 21 Andre Klapper maemo.org 2010-10-25 17:12:15 UTC
The problem reported here should be fixed in the update that was released today
for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
sometimes). Please leave a comment if the problem is not fixed for you in this
update version.