Bug 5510 - (int-144000) Contact merge of number dialed manually via Skype fails due to internal error
(int-144000)
: Contact merge of number dialed manually via Skype fails due to internal error
Status: RESOLVED FIXED
Product: Contacts
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Low minor with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-16 12:45 UTC by Donn Morrison
Modified: 2010-03-15 20:53 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Donn Morrison (reporter) 2009-10-16 12:45:36 UTC
STEPS TO REPRODUCE THE PROBLEM:

1. Open the Telephone application.
2. Select the dial pad.
3. Change call type to Skype.
4. Enter and dial a number (e.g. +1250XXXXXX)
5. Hang up (or proceed with call, it doesn't matter as long as the number gets
into the recent calls list).
6. Close the dial pad, returning to the list of contacts in the Telephone
application.
7. Find the above dialed number in the list (should be at the top).
8. Tap the number and select Merge.
9. Select desired contact for merge.

EXPECTED OUTCOME:

One expects the merge to succeed.

ACTUAL OUTCOME:

A notification is displayed saying that the merge failed due to an internal
error. (Impossible d'exécuter l'opération. Erreur interne.)

I have also tried the above steps making sure the field (Skype number) does not
already exist in the contact I am merging with, and the error is the same.

REPRODUCIBILITY:
(always/sometimes/once)

always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

This functionality works correctly if the call type is cellular. The merge is
successful.
Comment 1 mike morrison 2009-10-16 13:02:21 UTC
I can confirm that this also happens for me. In English the error message says:

"Unable to preform operation. Internal error."
Comment 2 mike morrison 2009-10-16 13:14:40 UTC
> "Unable to preform operation. Internal error."

sorry, should have been "perform".. i was typing too fast.
Comment 3 Andre Klapper maemo.org 2009-10-16 22:45:22 UTC
Weird. I cannot reproduce it here.

I have queried internally for reports with that error message and "merg" and I
only found one open ticket. Looks similar to int-115085 which does not apply
anymore.

If you are tech-savvy you could try to export OSSO_ABOOK_DEBUG=all before
starting the addressbook, but this probably will not output a lot either. :-/
Comment 4 Andre Klapper maemo.org 2009-10-19 15:21:50 UTC
How reproducible is this? Always? How often did you try? Like "8 out of 8
tries"?

Confirming as per comment 1.
Comment 5 Donn Morrison (reporter) 2009-10-19 15:39:28 UTC
(In reply to comment #4)
> How reproducible is this? Always? How often did you try? Like "8 out of 8
> tries"?

Yes, for me, it happens 100% of the time. I cannot merge any phone number
called using Skype with an existing contact.

Can you please tell me how I can use OSSO_ABOOK_DEBUG=all before starting the
address book? Running:

$ OSSO_ABOOK_DEBUG=all osso-addressbook

doesn't seem to work, since the address book is already running. Killing it and
the e-adressbook-factory doesn't work; they are quickly respawned again.
Comment 6 Jörgen Scheibengruber nokia 2009-10-21 10:48:46 UTC
I can confirm. Andre, I think we don't have this one in the internal bugzilla
yet, could you please copy it there?
Comment 7 Andre Klapper maemo.org 2009-10-22 21:05:26 UTC
Done.
Comment 8 Sivan Greenberg 2010-03-05 01:20:14 UTC
Just wanted to add, this will happen with the same scenario when creating a new
contact out of the dialed phone number in Skype mode. It is always reproducible
(just choose "new contact" instead of merge) and always crashes the contacts
app, slows down the machine a bit until it recovers.
Comment 9 Andre Klapper maemo.org 2010-03-15 15:04:56 UTC
The next public update will include a fix for this.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 10 Andre Klapper maemo.org 2010-03-15 20:53:08 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).