Bug 5509 - Mail for Exchange not working with certificate based authentication
: Mail for Exchange not working with certificate based authentication
Status: RESOLVED DUPLICATE of bug 5597
Product: Synchronization
Mail for Exchange
: 5.0/(1.2009.41-10)
: N900 Maemo
: Medium major (vote)
: ---
Assigned To: unassigned
: activesync-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-16 12:44 UTC by Dart
Modified: 2009-11-03 20:31 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Dart (reporter) 2009-10-16 12:44:16 UTC
SOFTWARE VERSION: 1.2009.41-10
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:
Run Mail for Exchange setup wizard and try to connect to an exchange 2003
server that uses a certificate based authentication over https.

EXPECTED OUTCOME:
Synchronisation should work.

ACTUAL OUTCOME:
Error message: The server requires a secured authentication or the account has
been disabled.

REPRODUCIBILITY: Always.
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
The account is not disable. Synchronisation is working fine on E71, or any
Windows mobile device.
This is the same behavior if the certificate is manually registered in the
certificate manager.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.1.3)
Gecko/20090824 Firefox/3.5.3
Comment 1 Andre Klapper maemo.org 2009-10-16 22:27:00 UTC
Thanks for reporting this.

Exact ACTUAL OUTCOME in english is:
"Exchange server requires secure connection or account is disabled."
(makes it easier for querying).

This should be fixed in the internal week42 release (x.2009.42-x).
Any public update released after this build version will include the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 2 Dart (reporter) 2009-10-27 17:35:18 UTC
Checked with release 2.2009.42-9. Still not working.
Comment 3 Dart (reporter) 2009-11-03 17:12:22 UTC
Still notworking on release 2.2009.44-6
Comment 4 Andre Klapper maemo.org 2009-11-03 20:31:21 UTC
I am very sure that this is the same issue as bug 5597.

*** This bug has been marked as a duplicate of bug 5597 ***