Bug 5503 - (int-152018) Failed outgoing mails when using Nokia Messaging and Exchange
(int-152018)
: Failed outgoing mails when using Nokia Messaging and Exchange
Status: RESOLVED FIXED
Product: Email
Nokia Messaging Service
: 5.0/(3.2010.02-8)
: N900 Maemo
: Medium major with 14 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: nokia-messaging-service-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-16 07:14 UTC by mark guim
Modified: 2010-05-25 14:19 UTC (History)
12 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description mark guim (reporter) 2009-10-16 07:14:56 UTC
SOFTWARE VERSION: 1.2009.41-10
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:
-add a nokia messaging email account
-add exchange account for google sync to synchronize contacts and calendar only
-make nokia messaging as the default account
-create a new message from the nokia messaging account

EXPECTED OUTCOME: mail sent successfully

-ACTUAL OUTCOME: 
-mail stays in outbox with status: failed
-mail form labeled "from" displays the exchange account even though the account
is supposed to be from nokia messaging.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS: if i delete the exchange account, mails are sent successfully
from the nokia messaging account.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Comment 1 Andre Klapper maemo.org 2009-10-16 19:01:43 UTC
Thanks for reporting this.

> STEPS TO REPRODUCE THE PROBLEM:
> -add a nokia messaging email account
> -add exchange account for google sync to synchronize contacts and calendar only
> -make nokia messaging as the default account
> -create a new message from the nokia messaging account

Can you please provide an exact step by step description for this so that
everybody trying to reproduce this just has to follow the steps without
thinking that much?

> -ACTUAL OUTCOME: 
> -mail stays in outbox with status: failed
> -mail form labeled "from" displays the exchange account even though the account
> is supposed to be from nokia messaging.

Sounds like two separate issues to me.
Comment 2 Sergio Villar Senin 2009-11-03 18:56:40 UTC
If it's a NMS bug the assignee should be most likely Ville Vainio as Modest
developers don't provide support about plugins.
Comment 3 Willie Pretorius 2009-11-24 09:15:59 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Andre Klapper maemo.org 2009-11-24 14:20:29 UTC
Thanks everybody for confirmations here, but my questions from comment 1 still
stand...
Comment 5 Vitaly Repin 2009-11-27 11:04:07 UTC
The reason why it is not sending - lack of google sync support in the sales
release.

What is cryptic here is this:

> mail form labeled "from" displays the exchange account even though the account
is supposed to be from nokia messaging.

Why do you expect this?  How have you created a new message?
From accounts view (where all the accounts are displayed) or from Nokia
Messaging folder view (where the folders of the Nokia Messaging account are
displayed)?
Comment 6 Ville M. Vainio 2009-11-27 17:37:17 UTC
Vitaly,

I imagine he expects it because NMS is the "default account".
Comment 7 Vitaly Repin 2009-11-27 18:50:47 UTC
(In reply to comment #6)

> I imagine he expects it because NMS is the "default account".

Is it always default account?  Not necessary.  I want to get the whole use case
for this...
Comment 8 mark guim (reporter) 2009-11-27 19:50:58 UTC
(In reply to comment #7)
> (In reply to comment #6)
> 
> > I imagine he expects it because NMS is the "default account".
> 
> Is it always default account?  Not necessary.  I want to get the whole use case
> for this...
> 

I expect it to send from Nokia Messaging because I selected it as the default
account under settings. I only set mfe for contacts and calendar, NOT email so
it shouldn't try sending the email from mFe.

It doesn't matter if I create new message from accounts view or Nokia Messaging
folder, the result is the same. If I'm still not clear, maybe a video of the
bug will help?
Comment 9 Vitaly Repin 2009-11-27 21:05:19 UTC
(In reply to comment #8)
> If I'm still not clear, maybe a video of the bug will help?

no, thanks.  Now the steps to reproduce seem to be clear.  I will ask our
testers to reproduce this based on the scenario you have described and update
you with the status here.

If they fail to reproduce, I will request the video and logs.  But I am pretty
sure they will be able to do their job :-)

thank you for reporting.
Comment 10 Andre Klapper maemo.org 2009-12-10 15:37:30 UTC
(In reply to comment #9)
> I will ask our
> testers to reproduce this based on the scenario you have described and update
> you with the status here.

Vitaly, any news here? Or do you want me to import this ticket?
Comment 11 Vitaly Repin 2009-12-13 21:18:34 UTC
(In reply to comment #10)

> Vitaly, any news here? Or do you want me to import this ticket?

Looks like, it is not easy to reproduce.

Mark, could you attach the video?  Thank you in advance.
Comment 12 Sterling 2009-12-21 22:00:52 UTC
My problem is identical to Marks initial report on 2009-10-16; however, my
SOFTWARE VERSION is: 1.2009.42-11.002

Another point to note is that the MfE account and the Nokia Messaging accounts
have the same email address. Both are xx@gmail.com (you'll notice that all the
other voters are gmail account holders and this might be why)

After the MfE account is deleted, I noticed that the icon for my Gmail account
is present under the subject in Modest.   When the icon is showing, I can send
email normally.  

I have reconfigured the MfE account with a different google account and this
has corrected the issue.

Perhaps this is an email identification issue
Comment 13 mark guim (reporter) 2009-12-22 00:10:44 UTC
I also suspect an email identification issue because I am using the same google
account email:
- mark@thenokiablog.com for Mfe to sync calendar and Contacts
- mark@thenokiablog.com for Nokia Messaging email

I am also experiencing this on 42-1l

(In reply to comment #12)
> My problem is identical to Marks initial report on 2009-10-16; however, my
> SOFTWARE VERSION is: 1.2009.42-11.002
> 
> Another point to note is that the MfE account and the Nokia Messaging accounts
> have the same email address. Both are xx@gmail.com (you'll notice that all the
> other voters are gmail account holders and this might be why)
> 
> After the MfE account is deleted, I noticed that the icon for my Gmail account
> is present under the subject in Modest.   When the icon is showing, I can send
> email normally.  
> 
> I have reconfigured the MfE account with a different google account and this
> has corrected the issue.
> 
> Perhaps this is an email identification issue
>
Comment 14 Murali 2009-12-22 02:19:12 UTC
I have encountered this bug too. Just bought a new N900. Using MfE to get my
@nokia.com e-mails. Incoming e-mails are fine. But when sending an e-mail from
the device it is sitting there for sometime before reporting an error. Not
using the device for Google or other such POP/IMAP mails. But syncing with
Exchange calendar and contacts.
Comment 15 Sterling 2009-12-22 15:50:43 UTC
@Murali

I'm just curious, are you using the same email address for both Nokia Messaging
and MfE?  If so, it would support our assumption that this error is an email
account identification error.

I was using sterling.s.wu@gmail.com for Nokia Messaging AND Mail for Exchange. 
This seemed to affect both outboxes, but MfE seemed to get priority for
sending.

@Mark
Does your service support email via Mfe?  If so, would it be possible for you
to remove Nokia messaging and test and see if MfE can handle sending your
email.  This would hopefully isolate the source of our problem (MfE problem or
a mix up between NM and MfE)

My hope is that if we can narrow this down this issue for the nice folks at
Nokia, the easier and faster this issue will be resolved.  

@everyone else
A quick work around for everyone else who's using google for syncing calenders
and contacts:

I created a second gmail account and shared my MfE sync'd n900 calender with my
primary account.  I gave my primary account full rights to edit and create
events.  I also set said calender so that the only one that I see on my desktop
and for all intents and purposes is my calender.  
I also exported all my contacts from my primary mail account and imported them
into the second account.

This let me sync my contact and events with a google account while allowing me
to get the benefits of Nokia Messaging with my primary account.

This setup has worked for me and I hope this works for you, but your mileage
may vary.

cheers,
Sterling

(In reply to comment #14)
> I have encountered this bug too. Just bought a new N900. Using MfE to get my
> @nokia.com e-mails. Incoming e-mails are fine. But when sending an e-mail from
> the device it is sitting there for sometime before reporting an error. Not
> using the device for Google or other such POP/IMAP mails. But syncing with
> Exchange calendar and contacts.
>
Comment 16 mark guim (reporter) 2009-12-22 19:37:40 UTC
(In reply to comment #15)
> 
> I was using sterling.s.wu@gmail.com for Nokia Messaging AND Mail for Exchange. 
> This seemed to affect both outboxes, but MfE seemed to get priority for
> sending.
> 
> @Mark
> Does your service support email via Mfe?  If so, would it be possible for you
> to remove Nokia messaging and test and see if MfE can handle sending your
> email.  This would hopefully isolate the source of our problem (MfE problem or
> a mix up between NM and MfE)

Nope. The only reason I use Mfe for contacts/calendar separately and Nokia
Messaging for email is because Mfe on the N900 doesn't currently support email
sync with my google account. Kinda mad about this because it works fine on
Android and iPhone.


> A quick work around for everyone else who's using google for syncing calenders
> and contacts:
> 
> I created a second gmail account and shared my MfE sync'd n900 calender with my
> primary account.  I gave my primary account full rights to edit and create
> events.  I also set said calender so that the only one that I see on my desktop
> and for all intents and purposes is my calender.  
> I also exported all my contacts from my primary mail account and imported them
> into the second account.
> 
> This let me sync my contact and events with a google account while allowing me
> to get the benefits of Nokia Messaging with my primary account.
> 
> This setup has worked for me and I hope this works for you, but your mileage
> may vary.
> 
> cheers,
> Sterling

Thanks for the workaround! It worked! 

I moved my calendar and contacts to a separate Gmail account
(markguim@gmail.com). I can now send outgoing emails from Nokia Messaging using
my primary account (mark@thenokiablog.com).
Comment 17 Murali 2009-12-22 21:48:15 UTC
@Sterling

In response to your comment #15, I take back my comments. My mail was stuck in
Outbox because the local WLAN in the office was buggy. (I had set my N900 to
switch automatically to available WLAN). Outgoing mails are sent fine when I
switch between my home WLAN or the 2.5G AT&T connection. But, to answer your
question, my use case is much simpler. Just using Mfe for my corporate
@nokia.com mails. I have not set up the device to sync my Google or Yahoo mails
or calendars etc.
Comment 18 Sterling 2009-12-23 04:26:15 UTC
It's nice to hear some good news before the holidays.  Glad that your problem
was a self-solvable one.   

(In reply to comment #17)
> @Sterling
> 
> In response to your comment #15, I take back my comments. My mail was stuck in
> Outbox because the local WLAN in the office was buggy. (I had set my N900 to
> switch automatically to available WLAN). Outgoing mails are sent fine when I
> switch between my home WLAN or the 2.5G AT&T connection. But, to answer your
> question, my use case is much simpler. Just using Mfe for my corporate
> @nokia.com mails. I have not set up the device to sync my Google or Yahoo mails
> or calendars etc.
>
Comment 19 Alex Smirnoff 2009-12-24 03:53:52 UTC
Seems to be my problem exactly: i use arkenoi@gmail.com with both MfE to sync
calendar and NM for email. Is there workaround other than creating different
google account?
Comment 20 Alex Smirnoff 2010-01-19 22:58:08 UTC
Still there in PR1.1, please change version.
Comment 21 Vitaly Repin 2010-01-19 23:04:08 UTC
(In reply to comment #19)
> Seems to be my problem exactly: i use arkenoi@gmail.com with both MfE to sync
> calendar and NM for email. Is there workaround other than creating different
> google account?


Could you describe the problem you have in more detail?

With all the steps.

Sorry for asking this but I have to say that none of our testers was able to
reproduce this problem.  And I have pushed them hard to do it :-)
Comment 22 Alex Smirnoff 2010-01-20 14:54:54 UTC
Well, let's explain it all in the screenshots.
I set up calendar-only sync via MfE and email sync via NM, making NM default
email account. Let's meet "the dummy email account bug":

http://media.share.ovi.com/m1/s/1671/4d186eb44fd8418fbf09362d16dfe096.jpg

Making sure NM is the default, so it should not try to use it at any
circumstance:

http://media.share.ovi.com/m1/s/1671/cd7820b281464f9d8bde98981cb2eb05.jpg

Now let's reply to a message:

http://media.share.ovi.com/m1/s/1671/a5ed9a4253b94c53a11dcf80d1db6372.jpg

note the <> angular brackets enclosing address, it is probably the NM/google
(correct one) account.

Let's see it fail:

http://media.share.ovi.com/m1/s/1671/bce84ab3a7984c059630872bfec9a829.jpg

Guess why? Click on it:

http://media.share.ovi.com/m1/s/1671/6e8478e7932349bc8c112bceb84e649f.jpg

Note the *absense* of angular brackets, guess where does it come from:

http://media.share.ovi.com/m1/s/1671/98ecf99bd65c480e96b6076535f7d772.jpg

arkenoi@gmail.com *without* <> is probably MfE account. And even if i force
"from" to correct NM one, it is being reset to MfE again and the email is not
going to be delivered.
Comment 23 mark guim (reporter) 2010-01-20 16:23:01 UTC
Thanks. This is EXACTLY my problem too. I hope these photos are clear enough
for their testers to reproduce this bug

(In reply to comment #22)
Comment 24 Sterling 2010-01-20 16:49:09 UTC
Alex thanks for putting up those screen captures.  


You'll also notice that the name of the email service and letter-like icon,
which are supposed to be under "subject" are missing.  Here's the comparison:

Alex's non-working modest looks like this:
http://media.share.ovi.com/m1/s/1671/a5ed9a4253b94c53a11dcf80d1db6372.jpg

It should look like this
http://farm3.static.flickr.com/2760/4290761254_af01d94857_o.png
Comment 25 Andre Klapper maemo.org 2010-01-25 14:03:13 UTC
*** Bug 7298 has been marked as a duplicate of this bug. ***
Comment 26 Jeremy Gillespie 2010-01-28 20:03:16 UTC
I have exactly the same problem here in 2.2009.51-1.002.  Email errors out 99%
of the time and fails to send.

I have a similar setup too, I am using Mfe to sync up my contacts from
m.google.com and I have nokia messaging setup for email for gmail, yahoo,
hotmail and ovi.

If I open the email client I see both accounts in there, I see that Mfe was
last updated never and nokia messaging is updated per my email schedule (8-6pm
every hour).

However when I go into nokia messaging and enter a new email and click send, I
can see it in my outbox where they every time it will start off in a waiting
state, which will then switch to sending and finally to failed (99% of the
time, I think I've managed to successfully send 2-3 emails in the past 2
months!)

If I open the failed emails all the information is correct, the from and to
look good.  I dont see anything that indicates its using the Mfe versus Nokia
Messaging account however they just do not send!
Comment 27 Jeremy Gillespie 2010-01-28 20:50:37 UTC
When I look at the failed email, the from item is always set to the email
address associated with the Mfe account and not the gmail associated with the
nokia messaging account.  When I go back to my failed messages and make this
change the email still fails to send.  The same gmail account is setup in both
Mfe and Nokia messaging - it is this gmail address that I am trying to send
from.

The default account is also setup as Nokia Messaging.
Comment 28 Nigel Jones 2010-02-09 01:45:06 UTC
I've also had this problem with 1.1 -- with Nokia Messaging + mfE

However I then removed the mFE account and instead setup both NM and IMAP
(again both referred to the same gmail account).

Despite the NM account being set as default, the outbound mail got sent via the
IMAP/SMTP configured account.

I've been able to repeat this consistently.

Simple use a "gmail" account and in turn configure it for mFe, NM & imap

It appears modest is not respecting the "default" account for outbound.
Comment 29 Tim Edmonds 2010-02-10 18:22:12 UTC
I've yet to try this, but as a workaround you might be able to change your
address for one of the accounts by adding some punctuation to the user name,
ie: tim@gmail.com and t.im@gmail.com.  These are usually deemed equivalent by
google but this might help modest discriminate between accounts.
Comment 30 Sergio Villar Senin 2010-02-10 18:37:35 UTC
(In reply to comment #28)
> It appears modest is not respecting the "default" account for outbound.

It's not about respecting the default account. Modest always send each email
with the account the from address belongs to. Default account is not used at
all for sending/receiving things, just for UI
Comment 31 Andre Klapper maemo.org 2010-02-17 21:11:13 UTC
Same as with bug 6703:

This has been fixed in the internal build version
10.2010.05-13
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 32 Andre Klapper maemo.org 2010-03-15 20:56:08 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 33 avalentine1984 2010-05-25 14:02:23 UTC
Can you please confirm that this has been fixed in PR1.2.
I downloaded PR1.2 today and the issue appears to be unresolved.
After sending an email from my gmail account using Nokia messaging the sending
status is suspended.

I suppose suspended is better than failed but I still wouldn't call that a fix.
Comment 34 avalentine1984 2010-05-25 14:19:46 UTC
An addendum to my last post.

You need to delete your exchange account and then add a new one to resolve the
issue.