Bug 5502 - No search for emails available
: No search for emails available
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(1.2009.41-10)
: All Linux
: Low enhancement with 44 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
:
: 4163
  Show dependency tree
 
Reported: 2009-10-16 04:42 UTC by Keywan Najafi Tonekaboni
Modified: 2010-06-15 11:31 UTC (History)
9 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Keywan Najafi Tonekaboni (reporter) 2009-10-16 04:42:27 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
5.0 (1.2009.41-10)

STEPS TO REPRODUCE THE PROBLEM:
1. Open inbox
2. Try to search for an email

EXPECTED OUTCOME:
There is some kind of search:
 - a button with magnifier icon
 - an option in the menu
 - ctrl-f will open a search
 - type ahead search

ACTUAL OUTCOME:

There is no search for emails available (or very good hidden)

REPRODUCIBILITY:
always


OTHER COMMENTS:
At least a simple search in the current folder should be available. I would
suggest a type ahead search for "subject OR sender" resp. "subject OR receiver"
(in Outbox and Drafts) for the current folder. A full bloated search might not
be necessary, but with no search it's a bit hard to navigate
Comment 1 Andre Klapper maemo.org 2009-10-16 17:54:32 UTC
Yeah, was never planned to provide. Might change in future versions. I
personally consider this a bug, by Nokia definitions it's an enhancement
though. :-/

Reference to myself: int-108071.
Comment 2 Mehdi El Gueddari 2009-10-22 21:03:07 UTC
I would see this as a major shortfall for a high-end device aimed (at least
partly) at professionals. I hope that the priority of this is higher than "low"
internally. 

I guess that there are two type of search that could be implemented:

1) Local search. This would only search emails stored locally on the device. In
my opinion, it'd be very important to make that search account-wide and not
limited to the current folder. Search should be quick and simple and should
just work. Something like Spotlight in Apple Mail. Forcing users to remember in
which folder the email they're looking for is would partially defeat the point
of having a search functionality. 

2) Server search. Ideally, Modest should be able to search within all my
emails, including those on the server that I haven't downloaded locally (just
like the Google Mail J2ME app does). That would really be a must-have feature
for me (and for quite a few people I know) but I don't yet know of any mobile
email client that does this right (apart from the Google J2ME app of course but
that's Google-specific). 

Technically, I'm not sure how this could be done though. The iPhone does it
(arguably, very badly and possibly only for Gmail accounts) so there must be a
way. Even if it's Gmail-only, that'd be a very good first step.
Comment 3 Andre Klapper maemo.org 2009-10-22 21:14:12 UTC
Feel free to vote for this issue.
Comment 4 Martti 2010-01-10 09:28:46 UTC
Missing search capability cripples the application.

It is a pain with current version to locate an email by content.
If Nokia feels that search is irrelevant feature in email, why it appears in
Symbian?
Comment 5 Andre Klapper maemo.org 2010-01-18 20:27:30 UTC
(In reply to comment #4)
> It is a pain with current version to locate an email by content.
> If Nokia feels that search is irrelevant feature in email, why it appears in
> Symbian? 

Unrelated to the technical scope of this bug report. Please avoid comments that
don't add additional value, or contact Nokia Customer Care. Thanks!
Comment 6 Tim Watt 2010-01-19 06:32:06 UTC
I consider searching the content available on the device a valuable feature.
Typical computers allow for searching the existing e-mail database. 
I believe this feature should be added.
Comment 7 Andre Klapper maemo.org 2010-01-19 12:53:01 UTC
Tim Watt: We all believe something, but your comment is not helpful. Just vote
please instead of creating bugmail for everybody with "me too" comments.
Thanks.
Comment 8 Christian Sarrasin 2010-04-13 00:27:49 UTC
This bug is now referenced in a new brainstorm entry "Bridge the gap between
Modest and competing smartphone email clients", found here:
http://maemo.org/community/brainstorm/view/turn_modest_into_a_useable_email_client
. If you care about this bug, please vote for and contribute to the Brainstorm.
Comment 9 William 2010-05-27 09:38:40 UTC
(In reply to comment #8)
> This bug is now referenced in a new brainstorm entry "Bridge the gap between
> Modest and competing smartphone email clients", found here:
> http://maemo.org/community/brainstorm/view/turn_modest_into_a_useable_email_client
> . If you care about this bug, please vote for and contribute to the Brainstorm.
> 

This feature enhancement is in PR1.2 isn't it?
Should we close it?
Comment 10 Christian Sarrasin 2010-05-27 10:21:22 UTC
I must be missing smth... I have PR1.2 but can't figure out how to search my
emails.  Could you enlighten me?
Comment 11 Xavier Bestel 2010-05-27 10:42:46 UTC
There's a basic search now: just start typing something when in list view.
However I couldn't find how to search on specific fields (e.g. search in
message, search in recipients), and it seems limited to what's in the list, no
server search.
Comment 12 André SpÄnberg 2010-05-27 12:57:14 UTC
(In reply to comment #9)
> 
> This feature enhancement is in PR1.2 isn't it?
> Should we close it?
> 

Yes!
Comment 13 redex 2010-05-27 14:41:18 UTC
Strange, here it seems the message body is ignored while searching for a
message.

Runnig here: (10.2010.19-1)

Is there a bug in the fix?
Comment 14 Christian Sarrasin 2010-05-27 14:56:40 UTC
I guess the issue is that the scope of this enhancement request has been
reduced to just searchibility of email *headers* as opposed to contents.  For
those that think that, in the 21st century, searching email bodies should be
part of a self-respecting, business oriented smartphone email client, you
should visit the brainstorm (link in comment#8 above, which has this
requirement as one of the "solutions"...
Comment 15 redex 2010-06-15 11:28:16 UTC
Should we reopen this Bug for full search support or create a new one?
Comment 16 Andre Klapper maemo.org 2010-06-15 11:31:12 UTC
(In reply to comment #15)
> Should we reopen this Bug for full search support or create a new one?

New one prefered, though this does not sound like a bug to me.
Please file in http://maemo.org/community/brainstorm/ instead.