Bug 5493 - (int-143398/int147433) When ISO sensitivity is set to automatic, ISO EXIF value in resulting image is 0
(int-143398/int147433)
: When ISO sensitivity is set to automatic, ISO EXIF value in resulting image is 0
Status: VERIFIED FIXED
Product: Images and Camera
Camera
: 5.0/(1.2009.41-10)
: N900 Maemo
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: camera-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-16 02:33 UTC by Lucas Maneos
Modified: 2010-01-18 00:08 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Lucas Maneos (reporter) 2009-10-16 02:33:47 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Slide the lense cover open to start the Camera application.
2. Go to Capture settings and make sure ISO is set to automatic.
3. Take one or more photos.
4. Examine tags with the Photos app, or transfer the images to a PC and examine
them with other software.

EXPECTED OUTCOME:
The ISO setting automatically selected by the software for each particular shot
is recorded in the EXIF tags.

ACTUAL OUTCOME:
0 is recorded.

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
Manual ISO settings work as expected.
Comment 1 Alexander Bokovoy 2009-10-17 07:58:31 UTC
Valid bug, I see the same with 42-7.
Andre, could you please mirror this to internal bugzilla?
Comment 2 Lucas Maneos (reporter) 2009-10-17 08:40:26 UTC
Already done (in general the alias field refers to the internal bug id).
Comment 3 Andrés Gómez 2009-10-21 11:25:49 UTC
From my understanding, this should be moved to the Multimedia component and not
stay in the Camera application.
Comment 4 Andre Klapper maemo.org 2009-10-21 12:11:02 UTC
Currently I see it as an issue in camera-daemon. We'll see :)
Comment 5 Andre Klapper maemo.org 2009-11-20 12:58:51 UTC
This has been fixed in package
libomap3cam 0.25-1+0m5
which is part of the internal build version
2.2009.47-17
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 6 Andre Klapper maemo.org 2010-01-14 12:27:41 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.