Bug 5485 - (int-139649) "restart" button after finishing download not localized (in Finnish)
(int-139649)
: "restart" button after finishing download not localized (in Finnish)
Status: CLOSED FIXED
Product: Browser
User interface
: 5.0/(2.2009.51-1)
: All Linux
: Low minor (vote)
: 5.0/(10.2010.19-1)
Assigned To: Nagineni Sudarsana Babu
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-15 19:37 UTC by Tuomas Kulve
Modified: 2011-09-02 21:45 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tuomas Kulve (reporter) 2009-10-15 19:37:36 UTC
SOFTWARE VERSION:1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Select Finnish as the device language.

Click on a file in the browser, select save to device, follow closely the
"stop" and "continue" buttons when near finishing the download.

EXPECTED OUTCOME:
The top button should show something in Finnish.

ACTUAL OUTCOME:
The top button shows "restart" for a split second.

REPRODUCIBILITY: always.


EXTRA SOFTWARE INSTALLED:
none.
Comment 1 Andre Klapper maemo.org 2009-10-16 19:03:33 UTC
I cannot reproduce this.
Always shows "Keskeytä" for me.

I'd appreciate a second person confirming this, or exact steps... :-/
Comment 2 Tuomas Kulve (reporter) 2009-10-16 19:09:23 UTC
It says "keskeytä" while downloading, but after it just finishes downloading
the text changes. And then the dialog is closed immediately. So it just flashes
there quickly before disappearing.

A small thing, yes. That's why I put the severity as minor :)
Comment 3 Andre Klapper maemo.org 2010-01-14 12:32:32 UTC
Today Nokia released the Maemo5 update version 2.2009.51-1 for public (also
called "PR1.1" sometimes).
If you have some time we kindly ask you to test again if the problem reported
here still happens in this new version - just leave a comment (and feel free to
update the "Version" field to the new version if it's still a problem).
Comment 4 Tuomas Kulve (reporter) 2010-01-14 20:55:23 UTC
(In reply to comment #3)
> If you have some time we kindly ask you to test again if the problem reported
> here still happens in this new version - just leave a comment (and feel free to
> update the "Version" field to the new version if it's still a problem).

Reproduced with 2009.51-1. I had to try it couple of times to get a glimpse of
the "Restart" text but it's still there.

It looks like there could be some use case where the restart button would stay
there but I couldn't find one. I started one long and one short download but
the short download just vanishes from the list after completing.

If there is no use case where you could restart the transfer, I don't know why
there is the restart choice in the first place.

I tried disconnecting the internet connection while dowloading but I just got
"Internal error. Aplication 'web' closed." On a second attempt it didn't
crash(?) but shows "Resume" not "Restart".
Comment 5 timeless 2010-01-15 00:26:53 UTC
$ grep Restart /usr/lib/libtablet-b*.0.0
/usr/lib/libtablet-browser-controls.so.0.0.0:Restart

Seems like it exists. There's no valid reason for that string to be in our
library.

Please don't hesitate to use grep, the device is in your hands ;-)
Comment 6 Tuomas Kulve (reporter) 2010-01-15 08:06:50 UTC
(In reply to comment #5)
> $ grep Restart /usr/lib/libtablet-b*.0.0
> /usr/lib/libtablet-browser-controls.so.0.0.0:Restart
> 
> Seems like it exists. There's no valid reason for that string to be in our
> library.
> 
> Please don't hesitate to use grep, the device is in your hands ;-)

Grepping for a common word from a closed source binary doesn't really tell
anything. There is no way for me to know if that word should or should not be
found in a binary.
Comment 7 timeless 2010-01-15 13:16:19 UTC
in general Maemo 5 is gtk based, which means:
function_calls_are_lower_case_like_this
StructuresShouldBeLikeThis
mozillaFunctionNamesLookLikeThis
qgn_identifiers_should_be_like_this

Roughly: it doesn't hurt for you to do a grep. If a string turns out to be
common, don't mention it. If it only occurs once, then it might be notable and
might save some time.
Comment 8 Andre Klapper maemo.org 2010-01-15 13:17:56 UTC
This has been fixed in package
tablet-browser-controls 1.6.4-1.2+0m5
which is part of the internal build version
2009.52-9
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 9 Andre Klapper maemo.org 2010-03-15 20:51:06 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 10 Tuomas Kulve (reporter) 2011-09-02 21:45:12 UTC
Assuming fixed without verifying and thus closing.