Bug 5482 - missing: system-wide "start typing to eliminate items from list"
: missing: system-wide "start typing to eliminate items from list"
Status: VERIFIED FIXED
Product: Desktop platform
general
: 5.0/(1.2009.41-10)
: N900 Maemo
: Low enhancement with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: HAF QA mailing list
:
: moreinfo
:
: 8201
  Show dependency tree
 
Reported: 2009-10-15 18:33 UTC by thomas
Modified: 2010-05-26 18:34 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description thomas (reporter) 2009-10-15 18:33:18 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. open the media player.
2. choose video or internet radio 
3. start typing

EXPECTED OUTCOME:
items should disappear from the list, unless they start with the typed string.
ie, typing "summ" would leave all items starting with "summ", such as
summervideo2009. just as it works in the audio view. 

ACTUAL OUTCOME:
nothing happens

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
n/a

OTHER COMMENTS:
- this should be a system-wide behaviour. this would be especially useful when
trying to locate a file in an open dialog box (such as choosing an image from a
folder).
- it would also be useful if the search behaviour would be similar to the
'search on page', meaning that the search string can be found anywhere in the
name, not only if it's in the beginning of the file name.
- even better: if a file has tags attached to it, those would be applied as
well in this context. especially useful when choosing images - which, after
some time, there will be plenty of. 

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5pre)
Gecko/20091009 Linux Mint/7 (Gloria) Shiretoko/3.5.2
Comment 1 thomas (reporter) 2009-10-15 18:43:07 UTC
(In reply to comment #0)

> STEPS TO REPRODUCE THE PROBLEM:
> 1. open the media player.
> 2. choose video
> 3. start typing

corrected. (internet radio works just as the audio).
Comment 2 Andre Klapper maemo.org 2009-10-15 19:14:44 UTC
Actually this collides with bug 5431. Wouldn't it be just enough to jump to the
corresponding place?
This request here is way harder to implement than bug 5431, and only one of
them is possible.
Comment 3 thomas (reporter) 2009-10-15 19:22:59 UTC
(In reply to comment #2)
> Actually this collides with bug 5431. Wouldn't it be just enough to jump to the
> corresponding place?
> This request here is way harder to implement than bug 5431, and only one of
> them is possible.
> 

fine by me, jumping to the corresponding place is sufficient in most cases. 

when faced with the task to choose a specific image in an open dialogue window,
a tag search would be useful. because images tend not to have useful names, but
with the excellent tagging options in fremantle, a tag search/sorting could be
useful. even in this case though, a jump-to-text would be better than nothing.
scrolling with finger gets tedious when the list is huge.
Comment 4 Andre Klapper maemo.org 2009-10-16 03:35:11 UTC
*** Bug 5474 has been marked as a duplicate of this bug. ***
Comment 5 Bartosz Taudul 2009-12-29 20:57:30 UTC
(In reply to comment #2)
> Actually this collides with bug 5431. Wouldn't it be just enough to jump to the
> corresponding place?
That solution (jumping to file) would confuse users, as it would be different
from the one in contacts and media player (filtering the list).
Comment 6 Bartosz Taudul 2009-12-29 20:57:57 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Andre Klapper maemo.org 2010-02-12 18:10:13 UTC
This happens on a per-widget basis and is partially already implemented (either
type ahead or eliminate from list), see bug 5388, see bug 7536, see bug 8604
(Modest).
In some cases it does not exist (yet) - see bug 8198 (File manager).

For a generic bug, see bug 8201.

What are the specific usecases that you are missing?
Comment 8 Urho Konttori 2010-03-29 21:49:47 UTC
MOstly this has been implemented indeed for pr1.2. I would suggest closing and
reopening a more detailed one for pr1.3. (e.g. calendar doesn't allow searching
for events by typing).
Comment 9 Urho Konttori 2010-03-29 21:51:49 UTC
It's now automatically filtering all single column lists and the more
complicated lists have now (for the most part), filtering also enabled. Setting
as fixed for pr1.2