Bug 5481 - (int143223/int-156331) Assisted interactive process for merging contacts
(int143223/int-156331)
: Assisted interactive process for merging contacts
Status: RESOLVED FIXED
Product: Contacts
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low enhancement with 3 votes (vote)
: Harmattan
Assigned To: unassigned
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-15 17:31 UTC by thomas
Modified: 2010-04-16 14:44 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description thomas (reporter) 2009-10-15 17:31:25 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. import all your contacts to your sweeeeeeet n900
2. add some IM accounts
3. start the merging process

EXPECTED OUTCOME:
an option to get suggestions for contacts to merge. with several hundreds of
contacts, it quickly gets tedious to do the manual merging. it would be nice to
choose an option 'search for contacts to merge' and then be presented with
suggestions for which one could simply tap 'ok' or 'dismiss' to. after that,
the next suggestion would show up, and so on. tapping outside the dialogue on
the blurred area would of ourse simply abort all the suggestions.

ACTUAL OUTCOME:
nothing.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
n/a
OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5pre)
Gecko/20091009 Linux Mint/7 (Gloria) Shiretoko/3.5.2
Comment 1 Mikhail Zabaluev nokia 2009-10-15 18:09:31 UTC
Good to have our internal ideas confirmed by popular demand :)
Comment 2 Mikhail Zabaluev nokia 2009-10-15 18:42:46 UTC
UI designer's resolution on the internal bug:
"AFAIK, if all existing merging related bugs are fixed there shouldn't be any
need for what is proposed here. --> wontfix"
Comment 3 Keywan Najafi Tonekaboni 2009-10-16 04:45:08 UTC
I don't understand the last comment and why this is a wontfix.
Comment 4 Mathias Hasselmann maemo.org 2009-10-16 11:02:54 UTC
(In reply to comment #3)
> I don't understand the last comment and why this is a wontfix. 
> 

"if all existing merging related bugs are fixed" → Nokia's developers are
working on a solution, but it will look different than the suggested solution.

Actually early versions of Contacts tried automatic merging, but it turned out
that this causes too many problems (race conditions, power consumption, ...) to
be solvable for Maemo 5. The idea now is to provide better assistance for
manual contact merging.
Comment 5 Keywan Najafi Tonekaboni 2009-10-16 12:36:49 UTC
Ah, thank you. I would prefer good tools for manual merging instead bad
automerging, too.
Comment 6 Andre Klapper maemo.org 2009-10-16 14:29:29 UTC
Doing this automatically is definitely WONTFIX. This would have a complexity
that is nearly impossible to solve without losing data - what if your two
contacts have different values for a field that is unique?
I've seen this for years in the development of the GNOME Evolution Addressbook
that even the manual merging is still quite buggy nowadays over there.

What can be considered is to have some kind of assistent for this. But even
this is complicated, as I already wrote.
Comment 7 Andre Klapper maemo.org 2010-02-09 20:12:25 UTC
"Wontfix for Maemo5 as there are no software resources currently to do this
kind of thing"

Keeping this open as I want to check changes for Maemo6.
Comment 8 Andre Klapper maemo.org 2010-04-16 14:44:41 UTC
This has been defined in the specification for Maemo6, hence closing as FIXED
for Harmattan.
WONTFIX for Maemo5 though, because changes are too complex.