Bug 5477 - (int-140207) contacts search should include nicknames
(int-140207)
: contacts search should include nicknames
Status: RESOLVED WONTFIX
Product: Contacts
General
: 5.0/(1.2009.42-11)
: All Maemo
: Medium enhancement with 24 votes (vote)
: ---
Assigned To: unassigned
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-15 16:17 UTC by Keywan Najafi Tonekaboni
Modified: 2012-03-24 11:46 UTC (History)
14 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Keywan Najafi Tonekaboni (reporter) 2009-10-15 16:17:12 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
5.0 (1.2009.41-10)

STEPS TO REPRODUCE THE PROBLEM:
1. Have a contact named "Keywan Tonekaboni" with the nickname "prometoys"
2. Open Contacts and type "prometoys"

EXPECTED OUTCOME:
The type-ahead search will show the contact "Keywan Tonekaboni" with the
nickname prometoys

ACTUAL OUTCOME:
A contact with the name "prometoys" or no contact will be found. But not
"Keywan Tonekaboni"

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
please ask if its important for this bug

OTHER COMMENTS:
- Maybe it makes sense to include IM-UIDs in the search, too.
- This improvement to the type-ahead search would be for the Conversations
interface be nice, too.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en; rv:1.9.0.14)
Gecko/20080528 Epiphany/2.22 Firefox/3.0
Comment 1 thomas 2009-10-15 17:09:50 UTC
i was just about to file this bug/enhancement request too :)
Comment 2 Marcin Juszkiewicz 2009-11-02 14:48:38 UTC
I think that more fields needs to be used for searching. For example I have a
contact (on my phone) which is like "Joe Average, dentist" where 'dentist' is
in 'Work position' field. And I would like to be able to find Joe by typing
'dentist'.
Comment 3 George Waksman 2009-12-03 02:53:36 UTC
Adding a Display name option along the lines of "First Name \'Nickname\' Last
Name" might both accomplish the desired search effect and improve the display
for people with nicknames.
Comment 4 redex 2009-12-03 03:56:51 UTC
I would prefer: "Nickname \' First Name \' Last Name"  :-)

By the way. Nickname Import from Symbian S60 doesn't work. I guess a fault of
Symbian and non Standard vcf Files. The Nicknamefield is at example from a N95
vcf File "X-NICKNAME:" - I guess the N900 needs "NICKNAME:", korrekt? 
But its the fault of symbian. So is no extra bug report needed to open. Am I
right?
Comment 5 Alex Smirnoff 2009-12-03 04:38:22 UTC
(In reply to comment #4)

Confirmed, i've got nicknames lost when importing from e90. Not sure if all of
them (probably some nicknames were stored as, say, first name field renamed to
"nickname", i used this trick sometimes to bypass search limitations that
existed in s60 as well), but, definitely, at least some.
Comment 6 Mikhail Zabaluev nokia 2009-12-03 13:54:39 UTC
(In reply to comment #4)
> By the way. Nickname Import from Symbian S60 doesn't work. I guess a fault of
> Symbian and non Standard vcf Files. The Nicknamefield is at example from a N95
> vcf File "X-NICKNAME:" - I guess the N900 needs "NICKNAME:", korrekt?
> But its the fault of symbian. So is no extra bug report needed to open. Am I
> right?

I beg to differ. We could be more flexible in our import, especially to interop
with S60 gear. And it's not necessarily a fault, IIRC the NICKNAME field did
not exist in earlier vCard specifications.
Comment 7 Andy Dunmore 2009-12-03 16:28:18 UTC
I may be behind the times, but I've just found the option in Contacts that
allows you to search the Nickname field if it's been populated - if not, it
uses the name fields.

Under Contacts -> Settings -> Display Names

Using this you can set the device to search through Nicknames - this doesn't
quite solve the situation, however, since if Nicknames are turned on you can't
search for regular names for contacts with a nickname, but at least we know
that the framework is there already. Hopefully it shouldn't take too much
effort to get it working in the different ways that we all want it.
Comment 8 Peter Kral 2009-12-29 15:02:57 UTC
Agree with all above, I would welcome such enhancement. Search not only via
nicknames, but also other fields (company, etc...) Even, some full text search
engine would be warmly welcomed, like in N95 8GB. If I have a huge amount of
info in my mobile, it makes life much easier when I need to find something
quickly.
Comment 9 Brad Grigor 2010-01-29 19:34:36 UTC
I often need/want to search by Company and by phone number. I have over 3500
contacts in my N900 at the moment. I use this information as much as a
historical database as I do to call my recent business partners and friends. I
was very pleased that the N900 would HOLD all this information. Now I need the
N900 to help me manage and use that information.
Comment 10 jsbigs.mail 2010-02-06 22:21:47 UTC
(In reply to comment #9)
> I often need/want to search by Company and by phone number. I have over 3500
> contacts in my N900 at the moment. I use this information as much as a
> historical database as I do to call my recent business partners and friends. I
> was very pleased that the N900 would HOLD all this information. Now I need the
> N900 to help me manage and use that information.
> 

Absolutely agree with this.  This is crucial support in order to be able to use
the N900 as a business tool.  I can't always remember the name of someone I met
briefly two months ago but I know/remember the name of their business.
Comment 11 jsbigs.mail 2010-02-06 22:25:20 UTC
In fact, I would change the name of this bug to "contacts search should include
nicknames and other fields " so that it receives sufficient attention.
Comment 12 Andre Klapper maemo.org 2010-02-08 16:54:44 UTC
(In reply to comment #11)
> In fact, I would change the name of this bug to "contacts search should include
> nicknames and other fields " so that it receives sufficient attention.

No, as that is covered by bug 6625.
Comment 13 jsbigs.mail 2010-02-08 18:54:11 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > In fact, I would change the name of this bug to "contacts search should include
> > nicknames and other fields " so that it receives sufficient attention.
> 
> No, as that is covered by bug 6625.
> 

Thank you.  I just voted for this brainstorm:  

http://maemo.org/community/brainstorm/view/search_contacts_with_company_name/

Seems like a huge oversight that this feature was left out.
Comment 14 Siim Salonen 2010-04-06 10:01:07 UTC
On old N9500 there is possibility to manually select searchable fields in
settings menu.
Common fields (like name, company) are indexed so search is fast but you can
always search within unindexed fileds if needed (phone number, address, etc.)
and wait a little longer.
So having option to select searchable fields in N900 would be best solution
imho.
Comment 15 Andre Klapper maemo.org 2012-03-24 11:46:26 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )