Bug 5440 - (int-126502) Unclear how to open a contact (sender/receiver) of a conversation
(int-126502)
: Unclear how to open a contact (sender/receiver) of a conversation
Status: CLOSED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0/(1.2009.41-10)
: All Linux
: Low minor (vote)
: 5.0/(2.2009.51-1)
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-14 17:42 UTC by Keywan Najafi Tonekaboni
Modified: 2010-01-14 12:28 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Keywan Najafi Tonekaboni (reporter) 2009-10-14 17:42:37 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
5.0 (1.2009.41-10)

STEPS TO REPRODUCE THE PROBLEM:
1. Open Conversations
2. Open a (SMS/IM) conversation
3. Try to call the contact of the conversation

EXPECTED OUTCOME:
In the menu a option "Open Contact" is available.

ACTUAL OUTCOME:
The only way to open a contact is to click on the user icon. This might be not
clear for all users. From an usability point of view it would be better to have
a clear and recognizable way to open a contact. The user icon is a comfortable,
but somehow "invisible" way to open the contact. Furthermore it's sometime hard
to hit the icon.  

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en; rv:1.9.0.14)
Gecko/20080528 Epiphany/2.22 Firefox/3.0
Comment 1 Mikhail Zabaluev nokia 2009-10-14 18:18:05 UTC
True.
Comment 2 Andre Klapper maemo.org 2009-10-16 03:49:17 UTC
I exactly ran into the same issue today:

1. Receive an SMS from a number/person that is not already in Contacts
2. Try to add it to your Contacts

EXPECTED OUTCOME:
I looked in the mainmenu and expected an "Add contact" option.

ACTUAL OUTCOME:
After trying the mainmenu I remembered this bug report and clicked on the small
icon on the left.
Comment 3 Andre Klapper maemo.org 2009-10-30 15:18:51 UTC
*** Bug 5941 has been marked as a duplicate of this bug. ***
Comment 4 Tim Samoff maemo.org 2009-11-06 16:14:23 UTC
Please see bug #6064 for a related, but different issue in this functionality.
Comment 5 Naba Kumar nokia 2009-11-14 01:39:45 UTC
(In reply to comment #4)
> Please see bug #6064 for a related, but different issue in this functionality.
> 
That seems unrelated to this bug.

For this one, it has been fixed in internal release, so it should be available
in next release update. Menu now contains open contact item.
Comment 6 Andre Klapper maemo.org 2009-11-17 12:26:20 UTC
(In reply to comment #5)
> For this one, it has been fixed in internal release, so it should be available
> in next release update. Menu now contains open contact item.

I don't see this menu option in 46-16.
If it's fixed, please tell the week and patchlevel. Thanks.
Comment 7 Naba Kumar nokia 2009-11-20 12:08:06 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > For this one, it has been fixed in internal release, so it should be available
> > in next release update. Menu now contains open contact item.
> 
> I don't see this menu option in 46-16.
> If it's fixed, please tell the week and patchlevel. Thanks.
> 
Hmm, perhaps it was integrated by then. But I checked 47-10 and it's there. So
resolving fixed again. It's in conversation view menu.
Comment 8 Naba Kumar nokia 2009-11-20 12:08:32 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > For this one, it has been fixed in internal release, so it should be available
> > > in next release update. Menu now contains open contact item.
> > 
> > I don't see this menu option in 46-16.
> > If it's fixed, please tell the week and patchlevel. Thanks.
> > 
> Hmm, perhaps it was ....
... wasn't ... of course.
Comment 9 Andre Klapper maemo.org 2009-11-20 12:30:50 UTC
True, also working in 47-18 here. Thanks! :-)
Comment 10 Andre Klapper maemo.org 2010-01-01 19:22:16 UTC
*** Bug 7535 has been marked as a duplicate of this bug. ***
Comment 11 Andre Klapper maemo.org 2010-01-14 12:28:16 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.