Bug 5438 - Provide Alternate Line Service support
: Provide Alternate Line Service support
Status: RESOLVED WONTFIX
Product: Telephony
General
: 5.0/(1.2009.41-10)
: All All
: Low enhancement with 4 votes (vote)
: ---
Assigned To: unassigned
: telephony-general-bugs
: http://bugs.meego.com/show_bug.cgi?id...
:
:
:
  Show dependency tree
 
Reported: 2009-10-14 15:29 UTC by inte
Modified: 2010-12-17 18:17 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description inte (reporter) 2009-10-14 15:29:26 UTC
The phone app does currently not support the CPHS feature Alternate Line
Service (ALS) (http://en.wikipedia.org/wiki/Alternate_line_service).
This feature is essential for business users, even though it is currently not
available in all, but many GSM/3G networks.
For example at:

Rogers (CA):
http://your.rogers.com/business/wireless/services/secondvoicelineservice.asp

Orange (UK):
http://www2.orange.co.uk/servlet/Satellite?c=OUKPage&cid=1095668469502&ctb=1093478839800&pagename=OUKPersonal&ptb=1096023563451&t=UsingYourPhone

Orange (AT):
http://www.orange.at/Content.Node/business/telefonieren/rufnummernplan/

A1 (AT): http://www.a1.net/business/xtraline

Eplus (DE):
http://www.eplus.de/Geschaeftskunden/Beratung_und_Kauf/Tarife/Flexi_Card___Private_Line/Flexi_Card___Private_Line.asp

And many more GSM networks. I saw this feature in Spain and Singapure as well.
Since most Nokia business phones support ALS, the N900 should do as well!



SOFTWARE VERSION:
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:

EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de;
rv:1.9.1.4) Gecko/20091006 Firefox/3.5.4
Comment 1 Andre Klapper maemo.org 2009-10-14 20:54:50 UTC
Thanks for reporting this.
This is a feature that has not been planned to be supported in the Maemo5
release by Nokia, hence setting severity to enhancement.
Feel also free to vote for this report.
Comment 2 inte (reporter) 2009-12-08 17:43:18 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Chris Pitchford 2009-12-08 18:15:23 UTC
I bought an N900 from the London Flagship store. I have found that I cannot
select an outgoing line to use when making calls, and I cannot tell which line
was called during an incoming call.. However, when I ring my line-2 number, my
N900 receives the incoming call.

This is unlike other Nokia handsets that do not support line-2/ALS (or have the
support disabled) in which an incoming call to the line-2 number receives an
unavailable tone and the handset does not ring.

I test of a pre-release N900 in the flagship store some weeks prior indicated
that the device would not support line-2. A test call to the handset on the
line-2 nunber returned an unavailable tone..

Happily, it seems that the production device changed slightly in that it
partial support for line-2 incoming calls only, even if it is transparent to
the user and interface..
Comment 4 inte (reporter) 2009-12-08 19:12:04 UTC
(In reply to comment #3)
> 
> Happily, it seems that the production device changed slightly in that it
> partial support for line-2 incoming calls only, even if it is transparent to
> the user and interface.. 
> 

These are good news! So, the hardware does obviously support ALS. The
implementation of line selection would only be a minor extension to the phone
app, since for line 2 the calling procedure is absolutly the same like for line
1, only that the phone would send a different beacon. This could be easily
done. I will therefore change the priority of this bug to HIGH.
CPHS-specifications are applicable for download at 3gpp.org and also at scribd!
Comment 5 Andre Klapper maemo.org 2009-12-08 19:26:53 UTC
(Please do not reset Priority. This field is reserved for developers.)
Comment 6 Andre Klapper maemo.org 2010-12-17 18:17:33 UTC
For Maemo5 new features are basically WONTFIX.
I don't expect this to get fixed for Harmattan itself (excluding the MeeGo
stack of it) either, if it all this will be implemented in upstream MeeGo.
Hence closing as WONTFIX here for Maemo, please track
http://bugs.meego.com/show_bug.cgi?id=6092 for progress.