Bug 5431 - HildonTouchSelector: Can't jump to entries with keyboard (type ahead)
: HildonTouchSelector: Can't jump to entries with keyboard (type ahead)
Status: RESOLVED DUPLICATE of bug 5388
Product: Desktop platform
hildon-widgets
: 5.0/(1.2009.41-10)
: All Linux
: Low normal with 7 votes (vote)
: ---
Assigned To: Claudio Saavedra
: hildon-libs-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-14 11:19 UTC by Murray Cumming
Modified: 2009-12-07 14:00 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Murray Cumming (reporter) 2009-10-14 11:19:26 UTC
It's tedious to scroll down long lists in HildonTouchSelector, such as a list
of countries, even with the kinetic scrolling. People expect it to jump to an
entry when they press a key on the keyboard, as they could in a web page's
combo box.

Note that GtkComboBox (HildonTouchSelector's equivalent in the regular GTK+
API) doesn't support this yet either
https://bugzilla.gnome.org/show_bug.cgi?id=567141
though GtkComboBoxEntry and HildonTouchSelectorEntry do via GtkEntryCompletion.

However, I've noticed that the Maemo 5 address book seems to support this
feature somehow.
Comment 1 Marius Gedminas 2009-10-14 19:41:22 UTC
For testing this, enable the extras-devel repository in the application
manager, select 'all categories' (since you will *never* guess the right one
anyway, in my experience) and try to find a package with a name starting with
something like 'p'.
Comment 2 Quim Gil nokia 2009-10-20 06:41:26 UTC
It would be indeed good to know what is the problem and how trivial/complex
would be to implement a solution. It's a functionality really appreciated when
found in Maemo 5.

The 'bug' here would be that from a user point of view jumping after typing is
expected funtionality, working in some applications and parts of the system but
not in others, which is confusing and affects the overall experience.
Comment 3 Urho Konttori 2009-11-07 14:24:54 UTC
We are working on this. The solution is not exactly the proposed one, but close
enough. Will be available in the first update release. Implementation is done,
but not totally verified.
Comment 4 Ryan Abel maemo.org 2009-11-07 16:39:04 UTC
(In reply to comment #3)
> We are working on this. The solution is not exactly the proposed one, but close
> enough. Will be available in the first update release. Implementation is done,
> but not totally verified.  
> 

Care to elaborate on what the solution is? It's nice to know that it's being
worked on, but it's even better to have an idea about what exactly /it/ is.
Comment 5 Claudio Saavedra 2009-12-07 14:00:07 UTC
Shouldn't this be a duplicate? Yes, it should.

*** This bug has been marked as a duplicate of bug 5388 ***