Bug 5421 - (int-146069) keys when long pressed should give the blue symbol/number
(int-146069)
: keys when long pressed should give the blue symbol/number
Status: CLOSED FIXED
Product: Desktop platform
Input method framework
: 5.0/(2.2009.51-1)
: N900 All
: Low normal with 66 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: Joaquim Rocha
: input-method-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-13 23:34 UTC by Alia Merali
Modified: 2010-11-18 22:37 UTC (History)
19 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Alia Merali (reporter) 2009-10-13 23:34:40 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

EXPECTED OUTCOME:
when typing it would be nice if when you hold a key down it gives you the
symbol/number in blue just like other nokia phones.

ACTUAL OUTCOME:
when holding the key down the character repeatedly appears

REPRODUCIBILITY:
(always/sometimes/once)
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Comment 1 Lucas Maneos 2009-10-14 13:02:35 UTC
(In reply to comment #0)
> when typing it would be nice if when you hold a key down it gives you the
> symbol/number in blue

Hm, not sure about that.  How would it interact with auto-repeat?

> just like other nokia phones.

The only Nokia phone I have available here (E61) behaves the same way as the
N900.
Comment 2 Alia Merali (reporter) 2009-10-14 17:50:13 UTC
I don't know how it should interact with auto-repeat. The nokias ive had in the
past such as the n95, e51 and e71 all behaved in the same way - when you long
press it gives you the number/symbol (especially the e71 which had a full
keyboard).
Comment 3 Andre Klapper maemo.org 2009-10-27 22:12:20 UTC
This has also been posted to
http://maemo.org/community/brainstorm/view/long-press_for_numbers_and_symbols/
Comment 4 mark guim 2009-10-28 00:25:22 UTC
the latest Nokia devices with qwerty all have this function (E71 E75, and N97).
holding down a key gives you the number or symbol. I would also like that
function in the N900.
Comment 5 Venomrush 2009-11-13 20:52:57 UTC
The N97 v20 implemented this feature and it turned out to be very successful. 
This feature is now very popular within the N97 community and is a key selling
point of the new firmware.
Comment 6 Joaquim Rocha 2009-11-13 21:11:36 UTC
We're working on that.
Comment 7 Quim Gil nokia 2009-12-07 08:19:24 UTC
(In reply to comment #6)
> We're working on that.

Any internal bug report to track?
Comment 8 crolix 2009-12-07 18:21:09 UTC
If you implement this feature, please make it optional by making it possible to
disable it. I actually like the way it works now where if you hold a key it
auto-repeats it, just like on a real keyboard.
Comment 9 Venomrush 2009-12-07 19:59:15 UTC
(In reply to comment #8)

> disable it. I actually like the way it works now where if you hold a key it
> auto-repeats it, just like on a real keyboard.
> 

In what valid situation would you need to repeated type similar characters more
than once? AND be able to stop after the exact number you want?
Comment 10 Inacurate 2009-12-07 23:11:58 UTC
(In reply to comment #8)
> If you implement this feature, please make it optional by making it possible to
> disable it. I actually like the way it works now where if you hold a key it
> auto-repeats it, just like on a real keyboard.
> 

As with everything mobile, there is a lot of personal preference that goes
around.  However with almost ALL Nokie phones a long press gives the number,
symbol or a space.  Basically, the LAST option you could pick if you went
through them in order.

The idea behind this, has to revolve around the fact that a keypad on a N82 for
example, isn't QWERTY and you are less likely to need to input the same
character repeatedly.  Anyone doing this would have predictive text turned off
anyway, and should easily be able to press the key the required number of
times.

The best solution, should be to have options for long press, repeats, etc. 
Neither mode should disable say the double press of Fn or otherwise hinder
users, give us the options to do as we please, and that pleases everyone!
Comment 11 Andre Klapper maemo.org 2009-12-07 23:17:52 UTC
(In reply to comment #10)
> As with everything mobile, there is a lot of personal preference that goes
> around.  However with almost ALL Nokie phones a long press gives the number

Just for some better understanding:
The N900 is the very first phone based on Maemo, hence there's nothing to
compare with and "all other Nokia phones" is not an argument. Comparing to
Symbian phones is similar to comparing to Windows Mobile, iPhone, Android,
or...
Comment 12 Inacurate 2009-12-08 00:19:38 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > As with everything mobile, there is a lot of personal preference that goes
> > around.  However with almost ALL Nokie phones a long press gives the number
> 
> Just for some better understanding:
> The N900 is the very first phone based on Maemo, hence there's nothing to
> compare with and "all other Nokia phones" is not an argument. Comparing to
> Symbian phones is similar to comparing to Windows Mobile, iPhone, Android,
> or...
> 

Doh, Nokia is with an A...noticed that a bit to late.  Anyway.

It may be the first Maemo phone, however it *is* branded Nokia, so the
comparison is perfectly valid because of certain expectations we have as Nokia
users.  If we were discussing another phone here from a different manufacturer,
you would be correct.

QWERTY or not, unless there are dedicated number keys, a long press on a key
that is used for a number with Fn combination, should result in the number
being input.  That would be my expectation, because that is what I have used on
Nokia phones for a very long time.  So to me, it being the brand new OS Maemo
is no justification to not already be working on this.  It was added to the N97
for a reason, and that has a QWERTY!
Comment 13 Edgardo Calabrese 2009-12-08 03:18:53 UTC
I agree with this request

There are a couple of utilities for Palmos and one for WM that are enabling the
long pres (for a capital), the double click press (for the symbol) or any
combination/variation of the above.

Would be very very nice to have the same functionality on maemo
Comment 14 Andre Klapper maemo.org 2009-12-08 14:10:16 UTC
(In reply to comment #13)
> I agree with this request

No need to trigger bugmail by adding another comment that does not provide much
additional insight though, as comparing to
PalmOS/Symbian/Android/WinMobile/iPhone does not mean much. Silent voting is
welcome of course.
Comment 15 Andre Klapper maemo.org 2009-12-08 14:22:32 UTC
(In reply to comment #12)
> It may be the first Maemo phone, however it *is* branded Nokia, so the
> comparison is perfectly valid because of certain expectations we have as Nokia
> users.  If we were discussing another phone here from a different manufacturer,
> you would be correct.

No, I don't expect the same functionality from Windows Mobile compared to
Windows 7. Anyway, offtopic and just noise for this report.
Comment 16 Lucas Maneos 2009-12-08 14:59:39 UTC
(In reply to comment #9)
> In what valid situation would you need to repeated type similar characters more
> than once?

The arrow keys are the most obvious example (note that Up/Down are
Fn+Left/Fn+Right on most non-english variants).  Then there are games that use
other keys (see also
<http://konttoristhoughts.blogspot.com/2009/11/on-gaming-on-n900-and-newly-found-lack.html>),
and for vi users almost every alphabetic key.

(In reply to comment #14)
> Silent voting is welcome of course.

Except we can't vote *against* enhancements ;-)  Anyway, +1 on it being made
optional if implemented.
Comment 17 Joaquim Rocha 2009-12-09 10:37:30 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > We're working on that.
> 
> Any internal bug report to track?
> 

Hi Quim,

The internal bug number is 146069. We're likely to push it this week.
Comment 18 Quim Gil nokia 2009-12-09 11:13:32 UTC
Turning this into a bug since this is how the Fremantle program is addressing
it.

Thanks for taking the community input!

> Except we can't vote *against* enhancements ;-) 

Yes, you can when they are filed at http://maemo.org/community/brainstorm/  ;)
Comment 19 hex 2009-12-11 04:40:24 UTC
How about taking it a step further to get the device in line with other
mid-to-high end devices and making the phone actually global. I haven't figured
a way out how to properly communicate with associates in Germany, Italy,
France, Spain or Latin America (I'm sure there are plenty others, but that's my
current world).

I suggest long press gives you the other item on key, but longer press provides
a pop-up with variations of that letter in other languages. This world is as
flat as it has ever been and names, words, etc. are less "US English" than they
were even 10-years ago. I often require accents such as over an "i" (both
direction), over "e" - Spanish, Italian, German, etc. spellings. If this exists
on the N900, I haven't found it.

It essentially makes the keyboard much more powerful and globalizes it nicely.

Perhaps make it an option in settings, but this is default on many of the
latest (within the last couple years) devices of different brands. I won't
bother naming here, but can give examples if you need them.

Oddly, Nokia's are the only devices (phones and tablets - I only get N-series)
that I haven't seen this on in the recent past.

Just a suggestion, but one I think should be seriously considered - I'm not the
only one I know who has missed this functionality.

Thanks.
Comment 20 Quim Gil nokia 2009-12-11 08:10:07 UTC
hex, your (good!) proposal is food for http://maemo.org/community/brainstorm/
since it implies more than a platform bugfix. See you there?
Comment 21 hex 2009-12-12 06:10:38 UTC
(In reply to comment #20)
> hex, your (good!) proposal is food for http://maemo.org/community/brainstorm/
> since it implies more than a platform bugfix. See you there?
> 

Why thank you (tell my wife that :-).

I figured it might be a stretch for this. I'll head over to brainstorm.
Comment 22 Tor 2009-12-23 15:54:23 UTC
Whatever you do, *please* don't kill auto-repeat. Please. 

I for one have no problems with the Fn (arrow) key, as soon as I learned that I
don't have to hold it down before I press a number, or Sym, and that I just
press it twice to go to 'lock' mode. It works fine as it is now!
Comment 23 Andre Klapper maemo.org 2009-12-31 15:45:17 UTC
This has been fixed in packages
hildon-input-method-plugins 3.9.51-1+0m5
hildon-input-method-framework 1:2.1.44-1+0m5
hildon-input-method 1:2.1.39-1+0m5
which is part of the internal build version
2009.52-10
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 24 Venomrush 2010-01-15 07:47:10 UTC
(In reply to comment #23)

> A future public update released with the year/week later than this internal
> build version will include the fix. (This is not always already the next public
> update.)

FYI
This is not fixed in PR1.1 which was released yesterday.
Comment 25 Andre Klapper maemo.org 2010-03-15 20:53:40 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 26 Nick Leppänen Larsson 2010-04-17 21:55:40 UTC
For the record, there is a gconf setting to re-enable autorepeat in HIM:

gconftool-2 -s /apps/osso/inputmethod/ext_kb_repeat_enabled --type boolean true
Comment 27 Venomrush 2010-05-25 18:33:48 UTC
Confirm fixed in PR1.2
Comment 28 pawpawyoung 2010-07-22 06:25:31 UTC
How can I utilize long-press for a Qt application as end user & developer. I've
Googled around for long time without luck. Maybe this is not the place to ask
such question. Sorry.
Comment 29 Andre Klapper maemo.org 2010-07-22 11:10:42 UTC
No, it's not. Please ask in talk.maemo.org or on
http://wiki.maemo.org/Community_mailing_lists
Comment 30 aep 2010-11-14 18:03:25 UTC
so, how do you disable it?
Comment 31 luarvique 2010-11-14 18:11:21 UTC
Uffff... Finally found a gconf setting to turn this wonderful feature off.
Wouldn't it be nice if the physical keyboard keys simply auto-repeated, like
they do on any normal modern keyboard in existence? Like they did on the N900
prior to PR1.2, in fact...
Comment 32 Andre Klapper maemo.org 2010-11-18 22:37:35 UTC
(In reply to comment #31)
> Uffff... Finally found a gconf setting to turn this wonderful feature off.
> Wouldn't it be nice

Please post forum-style talk in the forum at talk.maemo.org. Thanks.