Bug 5417 - (int-125155) Delete button greyed out when opening from notification popup
(int-125155)
: Delete button greyed out when opening from notification popup
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(2.2009.51-1)
: N900 Linux
: Low normal with 25 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-13 23:02 UTC by Jeroen Wouters
Modified: 2010-04-02 12:55 UTC (History)
23 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jeroen Wouters (reporter) 2009-10-13 23:02:57 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:
1. Wait for a new mail notification (with mail app closed) 
2. Open the new message using the mail notification wndow

EXPECTED OUTCOME:
The new mail message is opened, with the ppossibility to delete the mail.

ACTUAL OUTCOME:
The new mail message is opened, but the delete button (trash can icon) remains
grey.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; en-GB; rv:1.9.2a1pre)
Gecko/20090928 Firefox/3.5 Maemo Browser 1.4.1.15 RX-51 N900
Comment 1 Andre Klapper maemo.org 2009-10-14 20:27:23 UTC
Confirming. Interesting bug. :-)

Internal ticket is closed as WONTFIX as
"That happens due to technical limitations. Is the same reason why you cannot
move forward/backward in the list of emails."
Comment 2 Jeroen Wouters (reporter) 2009-10-14 20:41:53 UTC
Hmm, I wonder what that 'technical reason' is. Seems a bit strange to me.
Anyway, it's a bit unfortunate, because we all know spam filters aren't perfect
:)
Comment 3 Cornelius Hald 2009-10-19 09:37:09 UTC
"Technical limitations" is IMO not a good reason to close this bug. It's
software, so technical limitations can be removed. Also I think this bug was
there on Diablo as well, so there was enough time to fix it.

The missing delete button is on my personal Top-10 list of annoying N900 bugs,
so it still gets my vote. Please consider reopening.
Comment 4 Sergio Villar Senin 2009-10-19 12:29:46 UTC
(In reply to comment #3)
> "Technical limitations" is IMO not a good reason to close this bug. It's
> software, so technical limitations can be removed. Also I think this bug was
> there on Diablo as well, so there was enough time to fix it.
> 
> The missing delete button is on my personal Top-10 list of annoying N900 bugs,
> so it still gets my vote. Please consider reopening.

Yeah, sorry for the lack of explanation. This is the technical issue. In
tinymail you can easily get a TnyMsg (which represents an email message) from a
TnyHeader (which corresponds to an email header that you can see listed after
clicking on an email folder). 

But when we receive a new email notification, we have the TnyMsg but not the
TnyHeader. There is no current way in tinymail to get the TnyHeader from the
TnyMsg. The problem is that to mark a message as deleted we need the TnyHeader.

Hope that it helps
Comment 5 Jeroen Wouters (reporter) 2009-10-19 17:15:14 UTC
(In reply to comment #4)
> Yeah, sorry for the lack of explanation. This is the technical issue. In
> tinymail you can easily get a TnyMsg (which represents an email message) from a
> TnyHeader (which corresponds to an email header that you can see listed after
> clicking on an email folder). 
> 
> But when we receive a new email notification, we have the TnyMsg but not the
> TnyHeader. There is no current way in tinymail to get the TnyHeader from the
> TnyMsg. The problem is that to mark a message as deleted we need the TnyHeader.

Thank you for your answer. I've noticed there is tny_msg_get_header function in
tinymail. Why does this not work? Does this have to do with the note about
tny_folder_transfer_msgs_async() in the tinymail API reference?
http://tinymail.org/API/libtinymail-1.0/libtinymail-tny-msg.html#tny-msg-get-header

Is there no way around this?
Comment 6 Sergio Villar Senin 2009-10-19 17:31:32 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Yeah, sorry for the lack of explanation. This is the technical issue. In
> > tinymail you can easily get a TnyMsg (which represents an email message) from a
> > TnyHeader (which corresponds to an email header that you can see listed after
> > clicking on an email folder). 
> > 
> > But when we receive a new email notification, we have the TnyMsg but not the
> > TnyHeader. There is no current way in tinymail to get the TnyHeader from the
> > TnyMsg. The problem is that to mark a message as deleted we need the TnyHeader.
> 
> Thank you for your answer. I've noticed there is tny_msg_get_header function in
> tinymail. Why does this not work? Does this have to do with the note about
> tny_folder_transfer_msgs_async() in the tinymail API reference?
> http://tinymail.org/API/libtinymail-1.0/libtinymail-tny-msg.html#tny-msg-get-header
> 
> Is there no way around this?

You cannot use tny_msg_get_header because the instance you'll get is a
TnyCamelMsgHeader. The instance you need is a TnyCamelHeader. You can only get
the later using tny_folder_get_headers().

Both TnyCamelHeader and TnyCamelMsgHeader are implementations of TnyHeader but
they're actually quite different objects. The former is an instance of the
folder summary information for one message while the later is just the
information about the headers of a TnyMsg. That is one of the problems of
Philip's initial design of Tinymail. We'll have to change them to avoid
missunderstandings in people that starts to hack in tinymail as it's a very
common doubt.
Comment 7 Lucas Maneos 2009-10-23 21:26:15 UTC
*** Bug 5754 has been marked as a duplicate of this bug. ***
Comment 8 Andre Klapper maemo.org 2009-10-27 20:49:00 UTC
*** Bug 5854 has been marked as a duplicate of this bug. ***
Comment 9 Keywan Najafi Tonekaboni 2009-10-27 22:09:08 UTC
In Diablo the mail was opened out of context in a singe window. There was some
kind of logic (far far away :D), that you couldn't delete/navigate. But now in
freemantle it only confusing. There isn't a close button anymore. If you click
in the right top corner, there is a arrow which brings you to your inbox. there
you can click on the same mail again and it opens the same view again, but now
with active delete/navigation buttons. I hope you see my point. 

I see the technical problem, but aren't you interested in good UI? I agree with
Cornelius. Why we not try to overcame the technical difficulties? Maybe we need
to fix it in tinymail, so you got your header :D
Comment 10 Andre Klapper maemo.org 2009-11-23 20:58:39 UTC
*** Bug 6299 has been marked as a duplicate of this bug. ***
Comment 11 Janne Kolehmainen 2009-11-28 21:02:21 UTC
*** This bug has been confirmed by popular vote. ***
Comment 12 Andrew Sheekey 2009-12-04 14:08:29 UTC
I also understand the limitations, but for the sake of ease of use, please
please try to find a way enable delete functionality for this.  It's most
annoying having to close the message and then wait for the mail application to
load.
Comment 13 Claudio Mezzasalma 2009-12-04 15:19:53 UTC
This is a top annoyance for me, too. I'm voting this.
Comment 14 leek 2009-12-04 18:26:06 UTC
I'm voting for this too. Either: 1) escalate it to Tinymail; 2) fork Tinymail;
or 3) find another email library from which to build a client.
Comment 15 Andre Klapper maemo.org 2009-12-04 18:29:49 UTC
(In reply to comment #14)
> I'm voting for this too. Either: 1) escalate it to Tinymail; 2) fork Tinymail;
> or 3) find another email library from which to build a client.

Well, we do "escalate" to tinymail (in fact the tinymail maintainer(s) is/are
around in Maemo anyway), forking does not make sense when manpower is missing
to keep up a fork, and finding another library and porting to it also misses
manpower. Hence it's WONTFIX, even if that may suck.
Comment 16 Attila Csipa nokia 2009-12-04 18:53:26 UTC
Can't we at least think about a workaround ? Like for example making the delete
operation asynchronous - the delete button would 'schedule' the deletion
(record a SHA hash of the msg header/body or sorts in a queue) and then when
the mail client is retrieving the 'full' messages it conveniently skips (and
deletes in the background) the message ?
Comment 17 Sergio Villar Senin 2009-12-04 18:59:37 UTC
Guys Modest is the main consumer of tinymail, we're also developers (and
maintainers of tinymail) so no need to scalate anything.

I wouldn't close this as wontfix for the moment, as we're preparing a very nice
improvement using IMAP BODYSTRUCT, that will most likely allow us to fix bugs
like this (I agree is annoying BTW)
Comment 18 Venomrush 2009-12-14 12:56:21 UTC
I only found this happen on Nokia Messaging account.
Is this bug presence for all other accounts?
Comment 19 Claudio Mezzasalma 2009-12-14 13:17:14 UTC
Happens for me with GMail.
Comment 20 Neil MacLeod maemo.org 2009-12-14 13:58:08 UTC
*** Bug 6949 has been marked as a duplicate of this bug. ***
Comment 21 Adam Sj√łgen 2009-12-14 14:56:53 UTC
(In reply to comment #18)
> I only found this happen on Nokia Messaging account.
> Is this bug presence for all other accounts?

I think so - it happens for me using my local IMAP server (dovecot) on a new
N900.
Comment 22 H. Can Celik 2009-12-14 17:47:19 UTC
(In reply to comment #18)
> I only found this happen on Nokia Messaging account.
> Is this bug presence for all other accounts?
> 

I have 3 pop, 1 imap (google) and hotmail account(I think this one pop too). It
happens with all of them.
Comment 23 wilsoncompany 2010-01-06 02:20:09 UTC
Have to agree this is a very annoying bug.  Should be a fix.
Comment 24 Sergio Villar Senin 2010-01-12 15:20:47 UTC
Finally managed to get this long awaited fix ready :-)

Fixed in
modest-3-2 (PR1.2): 72837e1033f6d83756b524fa691dc5ee6b740ebd
master (community): dd3db058530966c0d28def9c3bd1af04fc32ba6f
Comment 25 Andre Klapper maemo.org 2010-01-12 15:25:39 UTC
Congrats! :)
Comment 26 acabaj 2010-01-19 03:07:26 UTC
I'm glad it's fixed. One of the most annoying bugs on the N900 for me.
Comment 27 Andre Klapper maemo.org 2010-01-22 19:51:37 UTC
*** Bug 8137 has been marked as a duplicate of this bug. ***
Comment 28 Fredrik Wendt 2010-01-22 20:43:06 UTC
This has happened a few times for me on 2.2009.51-1, but not as often as
before. I've got screenshots of this, but I guess you need more data to
reproduce this ...
Comment 29 Andre Klapper maemo.org 2010-01-22 20:51:23 UTC
No need to reproduce at all. It's fixed internally already, see the previous
comments and the status of this bug report.
Comment 30 Lucas Maneos 2010-01-29 07:39:11 UTC
*** Bug 8626 has been marked as a duplicate of this bug. ***
Comment 31 Andre Klapper maemo.org 2010-02-02 13:32:58 UTC
Fixed in package
modest 3.2.11-2+0m5
which is part of the internal build version
2010.05-4
Comment 32 Lucas Maneos 2010-02-17 11:34:15 UTC
*** Bug 9095 has been marked as a duplicate of this bug. ***
Comment 33 Lucas Maneos 2010-02-23 02:12:59 UTC
*** Bug 9220 has been marked as a duplicate of this bug. ***
Comment 34 Andre Klapper maemo.org 2010-03-15 12:35:57 UTC
*** Bug 9547 has been marked as a duplicate of this bug. ***
Comment 35 Andre Klapper maemo.org 2010-03-15 20:56:02 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 36 Lucas Maneos 2010-04-02 12:52:02 UTC
*** Bug 9807 has been marked as a duplicate of this bug. ***
Comment 37 Lucas Maneos 2010-04-02 12:55:22 UTC
*** Bug 9804 has been marked as a duplicate of this bug. ***