Bug 5391 - (int-134378) Virtual keyboard doesn't appear in Maps
(int-134378)
: Virtual keyboard doesn't appear in Maps
Status: RESOLVED FIXED
Product: Map
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Low normal with 11 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: map-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-13 17:09 UTC by Lucas Maneos
Modified: 2010-03-15 20:55 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Lucas Maneos (reporter) 2009-10-13 17:09:39 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Enable virtual keyboard in Setting -> Text input.
2. Make sure the slider keyboard is withdrawn.
3. Start Maps.
4. Tap the magnifying glass icon to search.
5. Tap the input field.

EXPECTED OUTCOME:
Virtual keyboard appears so one can enter search terms.

ACTUAL OUTCOME:
Nothing.

REPRODUCIBILITY:
Most of the time.  If I tap the input field multiple times in quick succession
the VKB sometimes comes up, pre-filled with the string "Start typing to
search..." which has to be erased manually.
Comment 1 nivw2008 2010-01-01 12:05:04 UTC
confirmed on 41-11 too
Comment 2 Lucas Maneos (reporter) 2010-01-01 15:52:17 UTC
And 2.2009.51-1, except that if/when it eventually does appear it is not
pre-filled anymore.
Comment 3 Andre Klapper maemo.org 2010-01-01 19:06:32 UTC
*** Bug 7542 has been marked as a duplicate of this bug. ***
Comment 4 Andre Klapper maemo.org 2010-02-01 13:25:31 UTC
*** Bug 8710 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2010-02-06 15:21:19 UTC
*** Bug 8851 has been marked as a duplicate of this bug. ***
Comment 6 Andre Klapper maemo.org 2010-02-23 22:27:17 UTC
This works fine in the latest internal builds that will become the next public
release ("PR1.2"). It takes a second though which confused me at first.

A future public update will include the fix.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-03-15 20:55:08 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).