Bug 5387 - (int-204268) Use Volume hardware key to change Zoom level instead of Volume
(int-204268)
: Use Volume hardware key to change Zoom level instead of Volume
Status: RESOLVED WONTFIX
Product: Map
General
: 5.0:(20.2010.36-2)
: N900 Maemo
: Low enhancement with 9 votes (vote)
: ---
Assigned To: unassigned
: map-bugs
:
:
:
: 6347
  Show dependency tree
 
Reported: 2009-10-13 16:54 UTC by Lucas Maneos
Modified: 2010-11-12 15:16 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Lucas Maneos (reporter) 2009-10-13 16:54:07 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Start Maps.
2. Press the + or - hardware buttons.

EXPECTED OUTCOME:
Displayed map zooms in or out accordingly.

ACTUAL OUTCOME:
Audio volume change.

REPRODUCIBILITY:
Always.

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Since AFAICT Maps doesn't produce any sounds it doesn't make sense to use those
keys for volume.
Comment 1 Andre Klapper maemo.org 2009-10-13 18:54:58 UTC
It's funny as this is actually a design decision by purpose (int-129453).
Now don't ask me for any reasoning here. :-P
Comment 2 AB 2009-11-02 16:25:54 UTC
Possibly because the user could be listening to music in the background and
might want to use the volume keys for that. OTOH, the swirling gesture for zoom
that is used in the browser could as well be extended to maps and other apps.
Comment 3 Lucas Maneos (reporter) 2009-11-02 22:42:11 UTC
(In reply to comment #2)
> Possibly because the user could be listening to music in the background and
> might want to use the volume keys for that.

Well, if you follow that argument to its logical conclusion the +/- buttons
should never be used for zooming in any application.

> OTOH, the swirling gesture for zoom
> that is used in the browser could as well be extended to maps and other apps.

But note that +/- do zoom in the browser, and that's an application that does
produce its own audio output in certain circumstances (eg flash).
Comment 4 Uwe Kaminski 2009-11-17 11:34:55 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Possibly because the user could be listening to music in the background and
> > might want to use the volume keys for that.
> 
> Well, if you follow that argument to its logical conclusion the +/- buttons
> should never be used for zooming in any application.

IMHO this is the way it should be. The volume buttons should work as volume
buttons and it should _never_ play a role which application is open. There are
to many applications ignoring this. Examples are the browser, chat, conboy, ...
application too.

So I am against this feature request or at least against the missing
possibility to switch into a "global volume" mode for the volume keys.
Comment 5 Aniello Del Sorbo 2009-11-26 17:13:40 UTC
I agree with Uwe here.

Even though the "volume keys" have no specific meaning in the N900 (there's
nothing drawn on them), it doesn't mean their meaning should be decided by the
application.

I think they should BE the "VOLUME KEYS" and nothing else.
Like the Camera button.
Comment 6 Lucas Maneos (reporter) 2009-11-26 22:19:28 UTC
I have to disagree with you guys :-)

In all previous versions/devices those keys were primarily used for zooming
(the only pre-installed exception being the media player) and the N900 user
guide (<http://nds1.nokia.com/phones/files/guides/Nokia_N900_UG_en.pdf>) still
calls them "Zoom/Volume".

Dedicating them to one function exclusively seems like a waste to me.  If I'm
reading a document, examining a photo I just took or am just walking down the
street looking for a place zooming is much more useful than volume control.

Now if only they fixed the headset volume buttons to work...
Comment 7 Uwe Kaminski 2009-11-26 22:56:24 UTC
A simple solution could be that the volume keys work as volume keys if there is
volume :) If I play music or video files or looking and listening to a flash
video there comes noise out of the devices speakers or my headphones. In this
case I really prefer to have an easy way to level up or down the volume using
the keys.
It's so annoying that the browser tries to zoom the page if I play a youtube
video...

If there is not sound the keys could do an other job.

But maybe there are other solution too? How about a global setting for the
keys? Or local settings in every application?

Maybe this should be discussed in the maemo brainstorm tool?
Comment 8 Aniello Del Sorbo 2009-11-27 01:29:42 UTC
this is a touchscreen device. As browser provides touch alternatives for
zooming, I see no point in not providing that zooming features at framework
level and leave the keys to a single use.

:)
Comment 9 Lucas Maneos (reporter) 2009-11-27 09:08:06 UTC
(In reply to comment #8)
> this is a touchscreen device.

Well, you can also make that argument in the reverse direction ("as media
player provides touch alternatives for volume control ...").  BTW, if you feel
that strongly about it, how come xournal uses those keys for zooming? ;-)
Comment 10 Aniello Del Sorbo 2009-11-27 23:00:14 UTC
Because Xournal was doing exactly what I am supporting here.
Volume keys for .. volume ! :)

But people complained and I added it.
But now I am making it configurable and later version will ship with zooming
not bound to Volume keys.

:p
Comment 11 Lucas Maneos (reporter) 2009-11-28 03:27:19 UTC
Uhm, I don't see how this blocks bug 6048, removing.
Comment 12 Andre Klapper maemo.org 2010-11-11 18:31:51 UTC
Still valid for Harmattan.
Comment 13 Andre Klapper maemo.org 2010-11-12 15:16:52 UTC
According to Nokia there are no plans to support this either in Fremantle or
Harmattan, "so that HW key functionality is consistent in the platform."