Bug 5384 - (int-143616) Confusing empty window shown after deleting unavailable catalogue
(int-143616)
: Confusing empty window shown after deleting unavailable catalogue
Status: RESOLVED FIXED
Product: Settings and Maintenance
Application manager
: 5.0/(1.2009.42-11)
: N900 Linux
: Low normal (vote)
: 5.0/(1.2009.44-1)
Assigned To: unassigned
: application-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-13 16:43 UTC by Tomasz Dominikowski
Modified: 2010-01-11 14:48 UTC (History)
1 user (show)

See Also:


Attachments
Screenshot application catalouge (65.16 KB, image/png)
2009-10-15 16:51 UTC, Keywan Najafi Tonekaboni
Details
screenshots (355.15 KB, application/x-gzip)
2009-10-15 17:54 UTC, Tomasz Dominikowski
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Tomasz Dominikowski (reporter) 2009-10-13 16:43:42 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

Open App manager and add an invalid repository (ie. devel-extraz instead of
devel-extras).
Update catalogs or wait for automatic update.
A message should show up that some repositories are unvailable. 
Tap "Details".
A screen showing a list of invalid repositories should appear.
Tap at the wrong repository and fix it to make a valid repository. 
Tap "Save"

EXPECTED OUTCOME:

List of repositories should be updated and the user should be kicked back to
the main app manager screen.

ACTUAL OUTCOME:

The dialog windo with a list of "Invalid catalogues" is still there, but it is
completely empty now. This is confusing and requires user interaction to
actually close an empty dialog window.

REPRODUCIBILITY:
(always/sometimes/once)

Always.

EXTRA SOFTWARE INSTALLED:

None that would interfere with the app manager.

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.0.14)
Gecko/2009090216 Ubuntu/9.04 (jaunty) Firefox/3.0.14
Comment 1 Tomasz Dominikowski (reporter) 2009-10-13 16:45:00 UTC
The same thing happens when you delete an invalid app catalog, the empty dialog
window is still there, without any contents.
Comment 2 Andre Klapper maemo.org 2009-10-13 19:36:02 UTC
Hmm, I cannot reproduce this here. Confirmation by another tester is highly
welcome.
Comment 3 Tomasz Dominikowski (reporter) 2009-10-13 20:36:08 UTC
Let me add some visuals to show the issue more clearly.

This is the screen showing invalid catalogs, with my example, invalid catalog:

http://imgur.com/YFhSB.jpg

Tap on the catalog, remove it, confirm, get kicked back to this:

http://imgur.com/0yHut.jpg

Empty window.
Comment 4 Keywan Najafi Tonekaboni 2009-10-15 16:51:36 UTC
Created an attachment (id=1428) [details]
Screenshot application catalouge

I can't reproduce it, too. I added the repository "extras-devil", but I don't
get any error. If I open the Application Catalogues again, there is an error
symbol before the problematic repository (see screenshot). 

By the way. You can produce screenshots with Ctrl-Shift-P 

I wasn't able to understand your screenshots, because the second picture was
too blurry. Also English interface might be helpful for other to reproduce or
to prevent misunderstandings.
Comment 5 Tomasz Dominikowski (reporter) 2009-10-15 17:54:47 UTC
Created an attachment (id=1429) [details]
screenshots

Alright, let me explain again. 

1) Add wrong repo
2) System will update but not complain
3) Hit the UPDATE icon on the main appman screen
4) Now the system will complain about invalid catalogs
5) Hit details
6) List of invalid catalogs shows up
7) Remove them
8) Empty window.

The attached screenshots suggest that two catalogs are invalid, I supposed
extras-devel (the real, valid catalog) is currently down.
Comment 6 Andre Klapper maemo.org 2009-11-06 12:42:16 UTC
This has been fixed in package
hildon-application-manager 1:2.2.39+0m5
which is part of the internal build version
2009.45-14
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 7 Andre Klapper maemo.org 2010-01-11 14:48:56 UTC
This is fixed in the small update that was released today (version
1.2009.44-1).