Bug 5377 - org.microfeed.Provider.Twitter using 99% CPU.
: org.microfeed.Provider.Twitter using 99% CPU.
Status: RESOLVED DUPLICATE of bug 5407
Product: Mauku
Application
: 2.x
: N900 Linux
: High critical (vote)
: ---
Assigned To: Henrik Hedberg (Innologies)
: general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-13 15:32 UTC by mustali
Modified: 2009-10-14 15:31 UTC (History)
1 user (show)

See Also:


Attachments
high-cpu usage (77.27 KB, image/png)
2009-10-13 15:33 UTC, mustali
Details
killing process (59.96 KB, image/png)
2009-10-13 15:33 UTC, mustali
Details
normalcy (77.23 KB, image/png)
2009-10-13 15:33 UTC, mustali
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description mustali (reporter) 2009-10-13 15:32:13 UTC
SOFTWARE VERSION: 2.0beta4update2

STEPS TO REPRODUCE THE PROBLEM: Not certain. This happens after Mauku has been
closed and the device is not online.

EXPECTED OUTCOME:

ACTUAL OUTCOME: 
/usr/lib/microfeed/bin/org.microfeed.Provider.Twitter takes inordinate CPU
resources leading to fast battery drain. see attached screenshots.

REPRODUCIBILITY:
Sometimes

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15
Version/10.00
Comment 1 mustali (reporter) 2009-10-13 15:33:01 UTC
Created an attachment (id=1413) [details]
high-cpu usage
Comment 2 mustali (reporter) 2009-10-13 15:33:26 UTC
Created an attachment (id=1414) [details]
killing process
Comment 3 mustali (reporter) 2009-10-13 15:33:43 UTC
Created an attachment (id=1415) [details]
normalcy
Comment 4 Daniel Martin Yerga 2009-10-14 11:47:39 UTC
Confirming.

This is a critical bug, when you close Mauku it happens, and the only way to
know it, is if you have the load-applet installed and see the high load. An
end-user wouldn't be aware of the problem.

Versions:

libmicrofeed-subscriber-0:
  Installed: 0.5

libmicrofeed-provider-0:
  Installed: 0.5

libmicrofeed-common-0:
  Installed: 0.5

microfeed:
  Installed: 20091010

microfeed-utils:
  Installed: 0.5

microfeed-providers-unstable:
  Installed: 0.5
Comment 5 Henrik Hedberg (Innologies) 2009-10-14 15:31:41 UTC
This is related to the Microfeed backend, so I mark this as a duplicate of a
bug there.

*** This bug has been marked as a duplicate of bug 5407 ***