Bug 5372 - (int-142941) Can't easily align desktop widgets (snap to position) on home screens
(int-142941)
: Can't easily align desktop widgets (snap to position) on home screens
Status: RESOLVED FIXED
Product: Desktop platform
Home
: 5.0/(1.2009.44-1)
: All Maemo
: Low enhancement with 5 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: home-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-13 12:01 UTC by Simon Pickering
Modified: 2010-03-01 23:28 UTC (History)
12 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Simon Pickering (reporter) maemo.org 2009-10-13 12:01:24 UTC
SOFTWARE VERSION:
1.2009.39-3 (also 1.2009.41-10)

STEPS TO REPRODUCE THE PROBLEM:
Place some shortcuts on the desktop, try to get them lined up straight. 

EXPECTED OUTCOME:
Some people don't mind having their icons all around the place, some want them
nicely lined up. There should be a menu option to have icons aligned, or not.

ACTUAL OUTCOME:
It's very hard/impossible to get them to line up.

REPRODUCIBILITY:
always

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3)
Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Comment 1 Michael Hasselmann 2009-10-14 18:49:48 UTC
Agree, a layout grid (with a proper cell size of maybe .25 * icon_width, or
larger) would be nice. Also, a auto-align feature that can be invoked explictly
might help.

Anyway, this bug has my axe ... err vote!
Comment 2 Murray Cumming 2009-10-15 19:36:45 UTC
I don't think it should even be an option. It should just happen that way. I
see no value in allowing things not to align. Alignment makes things pretty.
Comment 3 Simon Pickering (reporter) maemo.org 2009-10-15 19:38:37 UTC
I suppose the only question is then whether the alignment grid spacing should
be user alterable, and if not what it should be.
Comment 4 Murray Cumming 2009-10-15 19:51:14 UTC
I say no, it shouldn't be configurable. This should all be simple.
Comment 5 Andre Klapper maemo.org 2009-10-26 12:43:55 UTC
Fixed in internal week 43 build.
Any public update released with or after this build version (x.2009.43-y) will
include the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 6 Lucas Maneos 2009-12-08 22:01:47 UTC
*** Bug 6710 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2010-01-14 12:28:16 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 8 Kasper Sandberg 2010-01-14 16:21:03 UTC
hmm.. this does not appear to be fixed, i just updated, and tried to move some
stuff  around, it still allows absolute placement, and does not snap
Comment 9 Peter Kral 2010-01-14 16:37:00 UTC
Guys, just to remind you - there are user who likes that the icons are not
snapping to any grid (like me...). So I suggest to implement it as an
selectable option.
Comment 10 Chris 2010-01-14 17:07:57 UTC
doesn't seem to bee fixed after update...
Comment 11 jack b 2010-01-14 19:22:12 UTC
It isnt fixed

Can we have something like this?
http://talk.maemo.org/showthread.php?p=471409#post471409
Comment 12 Andre Klapper maemo.org 2010-01-14 21:06:36 UTC
Reopening as per last comments.
Comment 13 Salvatore Iovene 2010-01-14 22:20:50 UTC
It *is* actually fixed, but the default value is too small so that the grid
effect would be noticed. Change the snap_grid_size value at the end of
/usr/share/hildon-dektop/transitions.ini to something like 48 and you will see
it works.

Little plug: you can use tweakr from extas-devel for a UI that does that.
Comment 14 Jan Arne Petersen 2010-01-14 22:46:22 UTC
It is fixed, but the grid is just 4px by default.
Comment 15 Chris 2010-01-14 23:24:55 UTC
Tried with tweakr, it bricked my phone, had to reflash.
Comment 16 Andrej Krutak 2010-01-15 01:18:39 UTC
I'd suggest moving /usr/share/hildon-desktop/transitions.ini to e.g.
/etc/hildon-desktop/transitions.ini in further releases - the current location
really isn't nice (such configuration files should be all in /etc, esp. when
there is an existing /etc/hildon-desktop directory already)
Comment 17 Salvatore Iovene 2010-01-15 09:40:11 UTC
(In reply to comment #15)
> Tried with tweakr, it bricked my phone, had to reflash.

Sorry to go off-topic, but Chris, could you please let me know what operations
you performed with Tweakr, before finding out that your device got bricked? You
can contact me at: salvatore at iovene dot com. Thanks!
Comment 18 Andre Klapper maemo.org 2010-01-15 13:08:55 UTC
"It does work, it's just that the grid is quite dense. We don't want the
widgets
to move around smoothly still, not in a clunky way."

Closing again.
Comment 19 Andre Klapper maemo.org 2010-01-18 11:45:56 UTC
*** Bug 7906 has been marked as a duplicate of this bug. ***
Comment 20 Venomrush 2010-03-01 22:52:55 UTC
This issue is marking as fixed but auto allignment is still not possible in
PR1.1
Please reopen.
Comment 21 Andre Klapper maemo.org 2010-03-01 22:54:05 UTC
Venomrush: It is, see comment 18.
Comment 22 Venomrush 2010-03-01 23:28:05 UTC
(In reply to comment #21)
> Venomrush: It is, see comment 18.
> 

Thanks Andre, still think we need an option to allign them. The only way right
now to allign them in a straight manner is remove all icons and add them
individually again.

This is mark as fixed but from end user's perspective it's not.
Auto allignment is missing and it's extremely difficult to line them straight
without using my method above.