Bug 5368 - (int-137629) In camera app, if geotagging is enabled but user does not want to connect, continual network selection popups make app nigh-on unusable
(int-137629)
: In camera app, if geotagging is enabled but user does not want to connect, co...
Status: RESOLVED WONTFIX
Product: Images and Camera
Camera
: 5.0/(1.2009.41-10)
: All Maemo
: Medium normal with 18 votes (vote)
: ---
Assigned To: unassigned
: camera-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-13 11:33 UTC by Simon Pickering
Modified: 2010-10-18 18:51 UTC (History)
16 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Simon Pickering (reporter) maemo.org 2009-10-13 11:33:07 UTC
SOFTWARE VERSION:
1.2009.39-3

STEPS TO REPRODUCE THE PROBLEM:
Enable geotagging in the camera app menu.
Move to an area where you either can't or don't want to use a network
connection (e.g. roaming abroad).
Take a picture.

EXPECTED OUTCOME:
Application will ask once for a network connection (to supply data to the GPS)
and if dismissed will assume that the user does not want to use the GPS for
geotagging.

ACTUAL OUTCOME:
If the network connection popup is dismissed, it comes back within a couple of
seconds, making it very difficult to either disable geotagging, or more
importantly, take more photos.


REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
N/A

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3)
Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2009-10-13 13:37:04 UTC
No such issues in Offline mode and without internet connection.
Location says "Searching".
I assume I should remove the SIM card in order to test this?
Comment 2 Simon Pickering (reporter) maemo.org 2009-10-13 14:02:15 UTC
With SIM card, and in Online mode.

But with auto-connect to 3G-data disabled (e.g. if you're roaming) and with no
known internet connections available.

For me it kept asking if I wanted to use my 3G data connection or one of the
available protected web connections. As data wouldn't work for me and I wasn't
near a wifi link that I knew the password for, it wasn't very useful.
Comment 3 Andre Klapper maemo.org 2009-10-13 19:47:09 UTC
Roaming... Looks like I need to leave the country again for this. :-P
Another confirmation would be highly welcome.
Comment 4 Simon Pickering (reporter) maemo.org 2009-10-13 19:53:08 UTC
Should be doable if you change the settings in "Control Panel > Internet
Connections > Connect automatically" to "Always ask", then try using the camera
app with geotagging turned on.

Just dismiss the connection dialog (e.g. as if you don't want to pay roaming,
and don't know any of the passwords for the local APs) and this should then
have the same effect that I saw.
Comment 5 Lucas Maneos 2009-10-13 19:56:08 UTC
I experienced the same thing during the summit.
Comment 6 Daniel Martin Yerga 2009-10-13 20:31:27 UTC
Yeah, same here. 
It happens with all applications using GPS if you enable "Network positioning"
in the Location settings (Settings->Location->Enable network positioning).

The pain here is the "Select connection" dialog is shown, you cancel it (you
don't want use any connection), the dialog is shown again, you cancel it, the
dialog is shown again and you need cancel it a third time. 
After it, you're able to use the application, but you're completely angry and
you want bite this black thing ;-)

So, the solution would be the "select connection" dialog is shown just one
time, if you cancel, it shouldn't reappear.
Comment 7 Simon Pickering (reporter) maemo.org 2009-10-13 20:39:04 UTC
Ah, I didn't realise it was only shown 3 times, I simply assumed that by that
point the anger ;) had made me fast enough to shut geotagging off before it
popped up again :)
Comment 8 Lucas Maneos 2009-10-20 02:59:44 UTC
*** Bug 5596 has been marked as a duplicate of this bug. ***
Comment 9 Andrés Gómez 2009-10-21 11:26:19 UTC
Is this still reproducible in latest images?
Comment 10 Tim Samoff maemo.org 2009-10-21 22:38:42 UTC
> Is this still reproducible in latest images?

Yes. :(
Comment 11 Murray Cumming 2009-10-22 09:45:20 UTC
I guess you are referring to images that are not available publicly, so it
would need someone like Andre to confirm it.
Comment 12 Tim Samoff maemo.org 2009-10-22 16:34:33 UTC
Bergie, this has been occurring for me since 38-something. But, maybe you're
referring to something else?
Comment 13 Tim Samoff maemo.org 2009-10-22 16:35:14 UTC
Arg. I meant Murray! Sorry. :-/
Comment 14 Andre Klapper maemo.org 2009-11-26 21:06:55 UTC
"Actually its location-proxy and only if network positioning is enabled from
settings (by default its enabled). [...] This cannot be fully fixed only in
Camera side."

So I currently expect bug 5368, bug 5905 and bug 5761 to have the same
underlying root issue in location-proxy having a broken passing of the user
decision to click "No". This is just my guess though...
Comment 15 Navid Zamani 2009-12-03 04:49:03 UTC
In Ovi Maps 3.0 (from the betalabs page) for S60v5 (5800 here), i also
constantly get popups about choosing an internet connection. I dismiss the
dialog, but it pops up again. I choose a connection, but it pops up again.
Every 1-2 seconds. Which makes it hard to even exit the thing again. Much less
actually use it.

It’s extremely annoying.

I don’t know if this is the right place. But it’s interesting, that it’s
apparently the same on S60 and Maemo. This should help pinpoint the problem
source.

But I think what is said in comment #14 is the problem. I guess I have to
uninstall Maps 3.0 again…
Comment 16 hex 2009-12-06 10:02:26 UTC
Confirmed in 42-11.002
Comment 17 Javier Fernández 2009-12-11 13:58:36 UTC
There are two different kind of issues related to this bug:

1- The Proxy will ask again for internet connection, so at least two dialogs
will appear always. 

2- The main reason for camera asking for internet connection when geotagging
enabled is because user has selected "Network based positioning" in the
settings preferences. So if use wants to use internet to get the position, i
think its not very strange to be asked to connect. 

It would be possible to change the settings based on the user actions regarding
the connection dialog, but i think is not a very good idea. User preferences
must be kept over the User casual actions.
Comment 18 Flandry 2010-02-06 17:51:38 UTC
This problem had gotten annoying enough that i took time to track down this
report today.

I can confirm that with both geotagging and "use network" enabled and "Always
Ask" selected for network, the photo app will not function as expected, popping
up a series of 2-4 prompts to select a network whenever the shutter is opened,
and then doing it again a short while later. And again. Unchecking the "Use
network" box in location settings reduces the prompts (usually) to 2, and
disabling geotagging (not surprisingly) stops the problem entirely. 

Presumably something can be fixed in the location framework to reduce this to
at most two pop-ups at a time (one for the initial position lookup and one when
trying to find the location name for geotagging.

I have three comments/questions related to this.

First, there is some confusion (to me and to others from the discussions i've
seen) as to what geotagging consists of, and this is not helped at all by the
dialog. In fact, it seems that there are two independent data here: a GPS
position (lat,lon) and a location (Cambridge, MA). I haven't looked into the
exif data yet for photos from the N900 but i know there's a standard of sorts
for GPS coordinates. When i enabled geotagging, it was to request that photos
be given lat,lon metainformation. The geotagging dialog suggests, though, that
witout a network connection, no geotagging at all will happen, which makes
little sense. Lat, lon should be available without a network query unless "Use
network" is enabled for GPS and it fails to lock.

The other aspect of geotagging could also be found without a network connection
by querying a mapping program, unless no map for the area is installed.

However, there seems to be no way to specify just GPS coordinate tagging or
just location tagging, bringing us back to this bug.

So, goihg back to Javier's comment: this understandable request for a network
connection should not interfere with the camera functionality. As it currently
behaves, the frequency and repetition of the popups actually prevents proper
usage of the camera. 

Ideally, this is the way it would behave:
-camera lens opened, app opens
-GPS not active and geotagging (both coordinates and location) enabled, so
request GPS location
-Location framework makes a quick check for ability to fix using cached data
(it seems to get a fix in very little time if it has recently done so, even
without network assist. Yes this should go in as an enhancement request
elsewhere, i'm just describing the ideal scenario). If that fails, it hits the
network (prompt occurs). Dismissing prompt causes location framework to
continue to try to get a fix w/o network assist.
-RADAR dish icon appears to reflect that the GPS is enabled, with a "not"
symbol superimposed and blinking until lock has been achieved.
-Location established, the app requests a location description from Ovi Maps or
whichever app responds to the mime type/dbus service request. If that fails
(e.g. no map installed for the area) it hits the network (possibly second
prompt). If the user declines to connect, a "Loc" icon appears in red, crossed
out, otherwise in white to indicate location tag is available.

And done. There's not really a need to pop up prompts at all, under most
circumstances, if all resources available on the platform are used.

Anyway, i just want to be able to open my camera shutter and snap a photo
without battling the UI.
Comment 19 Lucas Maneos 2010-02-12 21:57:18 UTC
*** Bug 9029 has been marked as a duplicate of this bug. ***
Comment 20 Saturn 2010-07-18 01:54:42 UTC
Seems like in version 10.2010.19-1 selecting "no" to the popups unconfigures
the geotagging option.

IMHO it's a good compromise but the user should be informed of this change.
Comment 21 Andre Klapper maemo.org 2010-08-26 19:42:28 UTC
According to Nokia this is a WONTFIX for Maemo5 as it requires User Interface
changes.
The Maemo 5 User Interface is considered stable by Nokia, hence only major
issues have a chance of being addressed by Nokia.

MeeGo Handset is where the unstable development is taking place. If you are a
developer (not a "normal" end-user) feedback about MeeGo Handset User Interface
issues is specially welcome, e.g. via the MeeGo bugtracker at
https://bugs.meego.com
Comment 22 Tiago Estill de Noronha 2010-10-03 12:41:00 UTC
Is this really an issue in the interface and not in the actual behavior of the
program?
Comment 23 Flandry 2010-10-18 18:07:53 UTC
I was going to raise a new bug, but this is actually a variant of the same bug.
The resolution does not require a change in the UI, it just requires the UI to
work as one would expect.

STEPS TO REPRODUCE THE PROBLEM:
Enable geotagging in the camera app menu with N900 in Offline mode.
Get GPS fix and cancel dialog to exit offline mode
Take a picture.

EXPECTED OUTCOME:
Application will tag photo with the (already available) lattitude and longitude
data (i.e. Geotag it)

ACTUAL OUTCOME:
Geotagging is disabled and no lat/lon tag is added to photo.

REPRODUCIBILITY
Always.

Would you please reopen this so that the wonky offline  behavior can be
addressed? There's no reason to prevent users from attaching their known
location to photos just because the *name* of the location isn't available.
Comment 24 Andre Klapper maemo.org 2010-10-18 18:09:32 UTC
(In reply to comment #23)
> Would you please reopen this

The developers said WONTFIX. That means WONTFIX.
Complaints can be directed via Nokia Care.
Comment 25 Lucas Maneos 2010-10-18 18:51:54 UTC
(In reply to comment #23)
> Enable geotagging in the camera app menu with N900 in Offline mode.
> Get GPS fix and cancel dialog to exit offline mode
> Take a picture.
> 
> ACTUAL OUTCOME:
> Geotagging is disabled and no lat/lon tag is added to photo.

IMHO this is a separate bug: a current GPS fix is readily available but not
used as the device stupidly insists on obtaining a (lower quality) cellular
location instead.  Similar behaviour happens elsewhere too (eg bug 5699 and its
duplicates).