Bug 5354 - Modest UI Hang when large number of mails in a folder
: Modest UI Hang when large number of mails in a folder
Status: RESOLVED DUPLICATE of bug 3762
Product: Email
General
: 5.0/(1.2009.41-10)
: All Linux
: Low normal (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-13 02:32 UTC by Zach Goldberg
Modified: 2009-11-06 12:39 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Zach Goldberg (reporter) 2009-10-13 02:32:19 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Load a mailbox folder with many thousands of mails.

EXPECTED OUTCOME:
Mail loads and allows me to select an email to view.

ACTUAL OUTCOME:
List of emails takes several minutes to appear (often hanging the app and
causing a watchdog to ask me to kill it).  When mails to appear the list is
unresponsive.  *eventually*, *sometimes* it will allow me to browse the list a
little and open mails.

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/532.1
(KHTML, like Gecko) Chrome/4.0.219.4 Safari/532.1
Comment 1 Andre Klapper maemo.org 2009-10-13 20:59:51 UTC
Thanks for reporting!

> STEPS TO REPRODUCE THE PROBLEM:
> Load a mailbox folder with many thousands of mails.

This is a bit vague. For future reference please provide exact steps - I assume
this is about IMAP?
Comment 2 Zach Goldberg (reporter) 2009-10-13 22:28:11 UTC
This is about IMAP.

1. Register an IMAP account with Modest such that there is a folder in the
account with 10,000+ emails.  

2. Load the home screen (account selection) of modest and check "Send &
Recieve" from the menu.  Allow this to run its course.

3. Click on the account with the large folder.  Select the large folder.  You
will now have a very long time to wait before the UI is again responsibe and
you'll be lucky if you ever get an email from that folder.
Comment 3 Tomasz Dominikowski 2009-10-24 16:50:29 UTC
Bug 3762 is very similar to this, in fact it's about the same issue.
Comment 4 Andre Klapper maemo.org 2009-10-26 22:26:28 UTC
*** Bug 5729 has been marked as a duplicate of this bug. ***
Comment 5 Sergio Villar Senin 2009-11-03 19:03:29 UTC
There is already a bug for this.

*** This bug has been marked as a duplicate of bug 3762 ***