Bug 5353 - (int-142537) Phone app crashed as call ending
(int-142537)
: Phone app crashed as call ending
Status: CLOSED FIXED
Product: Chat & Call & SMS
Call Application UI
: 5.0/(1.2009.41-10)
: All Linux
: High critical with 3 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
: crash
:
:
  Show dependency tree
 
Reported: 2009-10-13 02:31 UTC by David Greaves
Modified: 2010-03-01 22:31 UTC (History)
5 users (show)

See Also:


Attachments
Syslog from just before receiving call until shutdown (6.41 KB, application/x-gzip)
2009-12-17 03:35 UTC, Lucas Maneos
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description David Greaves (reporter) 2009-10-13 02:31:40 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Make normal voice call.
Rotate device a few times as "End Call" is pressed.
(This was real-world normal usage and I was just looking at the device to see
the screen - it was only my 2nd or 3rd call)

EXPECTED OUTCOME:
Ended call.

ACTUAL OUTCOME:
As screen rotates and call tries to end the screen goes to black during a
transition. The device becomes unresponsive although the lock button on the
base causes the backlight to toggle on/off (just visible at screen edges)

Needed a long power-press to reboot.

REPRODUCIBILITY:
(always/sometimes/once)
once

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
I have had 3 issues that seemed related to transition (clutter) crashes in the
last 3 days.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.14)
Gecko/2009091010 Iceweasel/3.0.14 (Debian-3.0.14-1)
Comment 1 Andre Klapper maemo.org 2009-10-13 21:17:43 UTC
If this is reproducible I kindly aks you to install crash reporter that will
automatically send a core dump to Nokia. You don't want your personal data here
in public I assume. :-)
Comment 2 thomas 2009-11-02 23:41:38 UTC
this has happened to me as well - once. i ended a phone call, and the phone
froze when the phone app transitioned from horisontal to vertical. i had to
remove the battery, a 15 sec power press was not enough.
Comment 3 thomas 2009-11-03 00:24:39 UTC
just *now* the n900 froze for the second time while using the phone app. this
time i was changing from horisontal to vertical mode during a call, when the UI
froze and only a long power-off could make any difference. 

(i'm having issues with the ear speaker, but that's not a bug but a hardware
fault and should not be reported as a bug, right?)
Comment 4 Lucas Maneos 2009-12-17 03:35:16 UTC
Created an attachment (id=1791) [details]
Syslog from just before receiving call until shutdown

Happened to me earlier today:  received an XMPP call while the N900 was playing
a video (may or may not be relevant but probably worth mentioning), answered,
spoke for a minute or so with the device held to my ear (ie portrait mode) and
hung up.  The phone app died and the screen froze in the middle of the
dashboard transition, displaying a slightly zoomed-in dashboard in portrait(!)
mode.  Rebooted via ssh.

Crash reporter wasn't installed I'm afraid, but syslog shows some interesting
things like an "X error 3" from hildon-desktop and a DSP crash.
Comment 5 Mikhail Zabaluev nokia 2009-12-22 12:36:40 UTC
The fix is on the way.
Comment 6 Andre Klapper maemo.org 2009-12-23 01:46:49 UTC
This has been fixed in the internal build version
2.2009.46-16
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-01-14 12:28:08 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 8 Andre Klapper maemo.org 2010-01-22 17:37:45 UTC
*** Bug 7948 has been marked as a duplicate of this bug. ***
Comment 9 Venomrush 2010-03-01 22:30:42 UTC
I can verify that it no longer crashes since PR1.1
Comment 10 Andre Klapper maemo.org 2010-03-01 22:31:47 UTC
Thanks!