Bug 5351 - AP News Widget causes Excessive CPU wakeups
: AP News Widget causes Excessive CPU wakeups
Status: CLOSED FIXED
Product: Desktop Widgets
AP News Widget
: 5.0/(1.2009.41-10)
: All Linux
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: Andre Klapper
: ap-news-widget-bugs
:
: use-time
:
:
  Show dependency tree
 
Reported: 2009-10-13 02:27 UTC by Zach Goldberg
Modified: 2010-03-16 13:23 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Zach Goldberg (reporter) 2009-10-13 02:27:13 UTC
(This bug is not classified at all correctly because I couldn't find where it
shoudl go.  Any help would be appreciated!)

SOFTWARE VERSION:
(Control Panel > General > About product)
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Add AP News widget to desktop then run powertop.  You'll see 100+
wakeups/second from Hildon Home.  Remove AP News widget and this number goes
down dramatically.

EXPECTED OUTCOME:
AP News Widget should not cause wakeups when not in use

ACTUAL OUTCOME:
AP News Widget drains battery!

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/532.1
(KHTML, like Gecko) Chrome/4.0.219.4 Safari/532.1
Comment 1 Andre Klapper maemo.org 2009-10-13 21:32:56 UTC
It's a good question. I don't know about any feedback channel that I could use
for these ones. I have sent an email to the maintainer and will care about it.
Comment 2 Andre Klapper maemo.org 2009-10-27 11:43:40 UTC
Two weeks and two emails later still no answer by Tapio... :-/
Comment 3 John nokia 2009-10-27 19:00:40 UTC
What version of the AP News Widget to you have installed? Do you see this when
the widget is on the active screen, or when it is in the background?
Comment 4 Zach Goldberg (reporter) 2009-10-27 19:25:06 UTC
ap 1.0 m5

happened whether or not the widget was on the active dashboard
Comment 5 John nokia 2009-10-27 19:46:38 UTC
Zach,
That version is the installer, not the app itself. Look for AP News Desktop
Widget. It should be something like 0.2.19.
Comment 6 Zach Goldberg (reporter) 2009-10-27 21:44:36 UTC
So I just re-tested with version 2.20 (I uninstalled the widget after I
originally reported the bug so I don't know what version that was).

The issue seems to be better for the most part now.  I am no longer seeing
thousands of new wake ups in a 30s period from hildon-desktop when the ap
widget is loaded.  

It does seem like the widget doesn't scroll as much as it used too, perhaps
that was the fix?
Comment 7 Robert nokia 2009-10-27 23:55:45 UTC
Fix verified in AP News Desktop Widget 0.2.20
Comment 8 Andre Klapper maemo.org 2010-01-14 12:27:50 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 9 Venomrush 2010-03-16 13:23:52 UTC
Fix verified as per comment 7