Bug 5349 - (int-143390) Can't organize applications menu
(int-143390)
: Can't organize applications menu
Status: RESOLVED FIXED
Product: Desktop platform
Application Menu
: 5.0/(3.2010.02-8)
: All All
: Low enhancement with 11 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: task-navigator-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-12 23:08 UTC by Ryan Abel
Modified: 2010-06-13 23:14 UTC (History)
9 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ryan Abel (reporter) maemo.org 2009-10-12 23:08:23 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

1. Open the applications menu.
2. Find an application that you'd like to move.
3. Try to organize the menu.

EXPECTED OUTCOME:
Applications menu is organizable.

ACTUAL OUTCOME:
Applications menu is static.

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
This gets rather obnoxious after you've installed a certain amount of software
as you have to scroll a lot to get to it. I also find that he vast majority of
software on the root level of the menu is use only very rarely. It would be
nice to be able to put things in there that I actually use (but may not wish to
put on the desktop).

Big feature regression from Diablo.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_1; en-US)
AppleWebKit/531.9+(KHTML, like Gecko, Safari/528.16) OmniWeb/v622.10.0
Comment 1 Andre Klapper maemo.org 2009-10-13 21:34:20 UTC
As far as I remember this is planned for Harmattan.
Comment 2 Ryan Abel (reporter) maemo.org 2009-10-13 21:41:09 UTC
(In reply to comment #1)
> As far as I remember this is planned for Harmattan.
> 

Yes, I'm waiting 18 months to organize my applications menu. . . .
Comment 3 Andre Klapper maemo.org 2009-10-13 22:17:24 UTC
Yes, or simply don't buy this product.
Aren't we all frustrated sometimes, somehow? :-P
Comment 4 Tomasz Dominikowski 2009-10-16 20:32:23 UTC
So it is totally impossible to re-arrange at least the "More..." menu? By means
of a 3rd party app even?

Surely I don't need all these games at the top, just to scroll down to get to
the apps I really want. We can work around this by using shortcuts on multiple
desktops, but then, what is the point of such a menu if it needs to be worked
around.
Comment 5 Urho Konttori 2010-01-05 21:44:46 UTC
Coming in pr1.2 if nothing odd happens on the way.
Comment 6 Andre Klapper maemo.org 2010-01-05 21:56:38 UTC
*** Bug 6401 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2010-02-17 21:18:58 UTC
This has been fixed in package
hildon-desktop 1:2.2.132-1+0m5
which is part of the internal build version
10.2010.07-3
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Urho Konttori 2010-02-20 20:08:51 UTC
by the way, the new solution breaks jaffas great auto-categorization.
Comment 9 Andre Klapper maemo.org 2010-03-15 20:53:36 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 10 bugs.maemo.org@falkensweb.com 2010-03-31 12:16:13 UTC
What was the nature of the fix ?
Comment 11 Urho Konttori 2010-03-31 12:37:18 UTC
Tap and hold on an icon in launcher grid and then you can select a new location
for it in the grid.
Comment 12 Andre Klapper maemo.org 2010-04-28 11:53:28 UTC
*** Bug 10054 has been marked as a duplicate of this bug. ***
Comment 13 Tomi R. 2010-06-13 02:33:04 UTC
Sorry for the bump but I'll have to reopen this bug (although Bugzilla doesn't
let me to, heh). I have installed PR 1.2 and no, I can't move my applications
to where I want (or if I can they still do not go where I set them to go, e.g.
Phone is not cooperative). When I'm sorting them, they do seem to go to the
right places but after pressing the "Done", the applications are back where
they used to be. I did have Catorise installed earlier on, but got rid of it so
I don't have any other apps confusing the mainmenu, at least I should not have.

I'll post whatever needed via instructions.
Comment 14 Ryan Abel (reporter) maemo.org 2010-06-13 05:21:43 UTC
(In reply to comment #13)
> Sorry for the bump but I'll have to reopen this bug (although Bugzilla doesn't
> let me to, heh). I have installed PR 1.2 and no, I can't move my applications
> to where I want (or if I can they still do not go where I set them to go, e.g.
> Phone is not cooperative). When I'm sorting them, they do seem to go to the
> right places but after pressing the "Done", the applications are back where
> they used to be. I did have Catorise installed earlier on, but got rid of it so
> I don't have any other apps confusing the mainmenu, at least I should not have.
> 
> I'll post whatever needed via instructions.
> 

Go ahead and file a new bug, as this is both clearly a bug (and not just an
enhancement) and a separate issue.
Comment 15 Andre Klapper maemo.org 2010-06-13 19:07:04 UTC
Filed as bug 10664