Bug 5325 - Enable OBEX browsing in the File Manager and elsewhere
: Enable OBEX browsing in the File Manager and elsewhere
Status: RESOLVED MOVED
Product: Connectivity
Bluetooth
: 5.0/(1.2009.41-10)
: All Maemo
: Low enhancement with 28 votes (vote)
: ---
Assigned To: unassigned
: bluetooth-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-12 14:38 UTC by luarvique
Modified: 2009-12-07 13:22 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description luarvique (reporter) 2009-10-12 14:38:47 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Pair two tablets, or a tablet and a phone that supports OBEX.
2. Open File Manager.

EXPECTED OUTCOME:
File Manager should show both the local filesystem and the filesystem from the
paired device, just like it did in Maemo4. Disconnected OBEX-compatible devices
should show up in the file manager at the top level, where the local filesystem
is shown. Clicking on a disconnected device should connect it via OBEX.

ACTUAL OUTCOME:
The Maemo5 device does not know what to do with a paired OBEX BT device and
does not allow browsing.

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2009-10-13 21:46:39 UTC
I wonder if this is BT or gnome-vfs... Anyway, it is not planned to support
this currently. Same with Sending via BT in the File Manager.

Yes, it sucks, but priorities were different....
Comment 2 J N 2009-10-14 17:46:27 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Quim Gil nokia 2009-12-07 08:23:16 UTC
The scope of bugs.maemo.org are bugs and only very specific and no-brainer
enhancement requests. This report contains a feature request that is too
generic for bugs.maemo.org. Please post this problem and propose your
solution in Maemo Brainstorm instead:
  http://maemo.org/community/brainstorm/

More information: http://wiki.maemo.org/Maemo_brainstorm
Comment 4 luarvique (reporter) 2009-12-07 09:15:45 UTC
(In reply to comment #3)
> The scope of bugs.maemo.org are bugs and only very specific and no-brainer
> enhancement requests. This report contains a feature request that is too
> generic for bugs.maemo.org.
This issue has been filed as a bug because the lack of OBEX browsing is a
regression from Maemo4. Maemo4 had this feature all along.
Comment 5 Johan Compagner 2009-12-07 12:46:44 UTC
this is just exactly my point i am trying to make in: 6343

when is it a bug? when is it a feature request.. How do users know that. 
some find it a bug others dont.

Now we have to search on 2 places to see if it is not already there..
Comment 6 Andre Klapper maemo.org 2009-12-07 12:52:16 UTC
(In reply to comment #5)
> when is it a bug? when is it a feature request.. How do users know that. 
> some find it a bug others dont.

It's hard for everybody, not only for community, but also for Nokians, even
internally.
Users do not need to know, that's what the Bugsquad is for. However, searching
for an existing report is of course always welcome.
Other projects like Ubuntu or OpenSuse have also survived having both a
Brainstorm and a Bugtracker. :-)
Comment 7 Johan Compagner 2009-12-07 12:56:16 UTC
i do get brainstormer. 
But the result should be a bug/feature request in bugzilla with a link pointing
to brainstormer. 
Then after wards when the bug is fixed you can have nice things bug/code
integration features that for example SVN has or Eclipse through MyLyn that you
can go back and forward from code to bug report and from bug report to code..
Comment 8 Andre Klapper maemo.org 2009-12-07 13:22:13 UTC
(In reply to comment #7)
> i do get brainstormer. 
> But the result should be a bug/feature request in bugzilla with a link pointing
> to brainstormer. 
> Then after wards when the bug is fixed you can have nice things bug/code
> integration features that for example SVN has or Eclipse through MyLyn that you
> can go back and forward from code to bug report and from bug report to code..

This should be possible next year after migrating maemo.org Bugzilla to version
3.4. Feel free to file a separate request in Bugzilla, against Website >
maemo.org Website > Bugzilla. :-)