Bug 532 - (int-35904) Contacts list skewed by Google Gmail Chat
(int-35904)
: Contacts list skewed by Google Gmail Chat
Status: RESOLVED FIXED
Product: Contacts
General
: 2.0
: All Maemo
: Medium minor (vote)
: 3.0
Assigned To: rtcomm@maemo.org
: contacts-bugs
: http://mail.google.com/mail/
: ITOS2007HE-garage
:
:
  Show dependency tree
 
Reported: 2006-06-11 21:11 UTC by Neil Grogan
Modified: 2008-12-06 15:16 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Neil Grogan (reporter) 2006-06-11 21:11:50 UTC
Contacts list automatically gets populated by Gmail Chat contacts, without the
proper names. Also there is no easy way to mass delete contacts, and if I
introduce my other contact lists (I did it in Vcard format [.vcf]), it does not
pick up that they have the "IM" space filled with a gmail/jabber address,
suitable for use in google talk. Also after some restarts it fills the contact
list with duplicates, as it refreshes contact lists once again.
Comment 1 Neil MacLeod maemo.org 2006-06-29 22:26:46 UTC
> Also after some restarts it fills the contact
> list with duplicates, as it refreshes contact lists once again.

Confirming the above "duplicate" contacts behaviour - the Contacts application
appears to create new contacts that are based on the Google Talk email address
of an existing contact. I've tried deleting these duplicate contacts, but they
always return. On occasion I've had up to 4 or 5 duplicate email addresses for
each "real" contact.
Comment 2 Neil MacLeod maemo.org 2006-07-16 03:06:34 UTC
*** Bug 698 has been marked as a duplicate of this bug. ***
Comment 3 Neil MacLeod maemo.org 2006-07-16 03:07:30 UTC
Although it happens much less frequently, my contact list has become corrupted
on two occasions in the last 3 weeks.
Comment 4 Bill Fenner 2006-07-17 03:40:23 UTC
Note that both my "pure Jabber" contacts and my gtalk contacts were duplicated
in Bug 698 .

Also, a workaround to make the 770's contact list happier: use "Tools -> Merge
Contacts" instead of 
deleting.  That merges the two identical items without apparent harm to the
contact list on the server.
Comment 5 Maemo QA (deprecated) 2006-07-25 20:30:30 UTC
*** Bug 698 has been marked as a duplicate of this bug. ***
Comment 6 Maemo QA (deprecated) 2006-07-25 20:30:59 UTC
Sorry for the delay.
This problem has been reported to upstream maintainer.
Comment 7 Neil MacLeod maemo.org 2007-03-24 14:42:09 UTC
I'm confident this bug has been FIXED long ago and should be marked
accordingly. :)