Bug 5319 - Ugly "now playing" animation
: Ugly "now playing" animation
Status: VERIFIED FIXED
Product: Media player
General
: 5.0/(2.2009.51-1)
: All Maemo
: Low enhancement with 2 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-12 14:14 UTC by luarvique
Modified: 2010-05-26 18:50 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description luarvique (reporter) 2009-10-12 14:14:37 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Place Media Player widget to the desktop.
2. Open Media Player and initiate the playback.

EXPECTED OUTCOME:
There is a small unobtrusive icon in Media Player windows that lets you skip
directly to the playback screen. The Media Player widget shows the current song
name and contains no extra decorations.

ACTUAL OUTCOME:
There is an ugly animated "equalizer" at the bottom right of all Media Player
screens, that blends with the default theme black background. Also, the same
icon is present in the Media Player desktop widget, where it obscures the song
name and unnecessarily eats the battery.

REPRODUCIBILITY:
always
Comment 1 Keywan Najafi Tonekaboni 2009-10-14 21:35:22 UTC
the animation could be seen as an additional feedback, that the music is
running. In the media-player interface itself it seems to be the only way to
get back to the current playing playlist. 

But the animation could be revisited and designed more smooth. It's also might
be not clear for the user, that you must click on the animation to got back to
the current playlist.
Comment 2 luarvique (reporter) 2009-10-14 21:49:20 UTC
(In reply to comment #1)
> the animation could be seen as an additional feedback, that the music is
> running. In the media-player interface itself it seems to be the only way to
> get back to the current playing playlist. 
Correct. Still, it is so incredibly ugly that I would suggest the following:

1. In the player applet, remove the animated icon, as the PLAY/PAUSE icon is a
sufficient indicator of ongoing playback.

2. In the media player itself, replace the animated icon with well looking
non-animated icon inside a semi-transparent tab, the same way it is done with
the edit-desktop tab with the "gear" icon.
Comment 3 Tomasz Dominikowski 2009-11-26 15:27:18 UTC
I think the worst thing is that I've seen more than one person mistake this
simple ugly animation as visualisation, which they describe as jerky and
lagging. 

The fact that it almost blends with the background when music is not playing
and looks like some sort of an image artifact is also terrible.
Comment 4 Andre Klapper maemo.org 2010-02-10 17:37:26 UTC
This has been fixed in the internal build version
2010.06-3
(Note: 2009/2010 is the year, and the number after is the week.)

It now looks like a round, white play button with grey faded background.

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 5 Andre Klapper maemo.org 2010-03-15 20:54:44 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).