Bug 5318 - (int143016/int-147896) Missing "Remove from Playlist" option
(int143016/int-147896)
: Missing "Remove from Playlist" option
Status: RESOLVED FIXED
Product: Media player
General
: 5.0/(2.2009.51-1)
: All Maemo
: Low normal with 5 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-12 14:10 UTC by luarvique
Modified: 2010-03-15 20:54 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description luarvique (reporter) 2009-10-12 14:10:53 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Open Media Player
2. Add several songs to the playlist
3. Go to playback interface
4. Click on the album art to bring up the playlist
5. Hold finger on a song to bring up the context menu

EXPECTED OUTCOME:
There is a "Remove from playlist" option in the context menu.

ACTUAL OUTCOME:
There is no way to remove song from the playlist.

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2009-10-14 22:07:48 UTC
> STEPS TO REPRODUCE THE PROBLEM:
> 1. Open Media Player
> 2. Add several songs to the playlist
> 3. Go to playback interface

For future reference please provide exact steps about when tapping what option
from where. I really had problem to reproduce this.
Editing the default playlists does not make sense as they are automatically
generated, so I assume we talk about Saved playlists here.

> 4. Click on the album art to bring up the playlist
> 5. Hold finger on a song to bring up the context menu

ACTUAL OUTCOME:
Only "Clear current playlist" and "Save playlist".

Must warn that according to Nokia "Mediaplayer isn't primarily for deleting
media" (int-126670) but I agree that this is a UX issue.
Comment 2 luarvique (reporter) 2009-10-14 22:23:48 UTC
(In reply to comment #1)
> Editing the default playlists does not make sense as they are automatically
> generated, so I assume we talk about Saved playlists here.
This issue occurs both with the Saved and the Current playlist.
Comment 3 Andre Klapper maemo.org 2009-11-24 14:26:48 UTC
This has been added to the UI Specification.
Now waiting for the code to be written...
Comment 4 Andre Klapper maemo.org 2010-01-22 17:53:58 UTC
*** Bug 8410 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2010-01-28 13:16:09 UTC
This has been fixed in the internal build version
2010.02-5
(Note: 2009/2010 is the year, and the number after is the week.)

"remove from playlist" in the CSM of playlist view and "remove from now
playing" in the CSM of now playing view are now implemented.

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 6 Andre Klapper maemo.org 2010-02-23 14:59:25 UTC
*** Bug 9216 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2010-03-15 20:54:42 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).