Bug 5315 - (int-138568) 3 Mobile SIM card rejected
(int-138568)
: 3 Mobile SIM card rejected
Status: VERIFIED FIXED
Product: Telephony
General
: 5.0/(1.2009.42-11)
: N900 Maemo
: High critical with 12 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: system-software-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-12 12:13 UTC by Lucas Maneos
Modified: 2010-02-04 14:05 UTC (History)
18 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Lucas Maneos (reporter) 2009-10-12 12:13:56 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Switch off the device.
2. Insert a 3 UK SIM card.
3. Switch on the device.
4. Enter device lock code if prompted.

EXPECTED OUTCOME:
SIM card recognised and used.

ACTUAL OUTCOME:
"SIM card rejected" message immediately after entering the unlock code.  No
cellular functionality is available.

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
Not sure if this is the right component, but I assume that after the move to
"Maemo devices" this is in scope here.

Tested with two different cards, both of which work fine on other devices
including a Nokia E61.  A different operator's card (Orange) works so it's
probably not a faulty N900.

According to http://wiki.maemo.org/Data_plans#United_Kingdom 3 seems like the
most attractive prepaid option for the N900 so it would be really nice if this
could be solved somehow.
Comment 2 Lucas Maneos (reporter) 2009-10-13 16:39:35 UTC
*** Bug 5381 has been marked as a duplicate of this bug. ***
Comment 3 Tony Percy 2009-10-14 19:13:18 UTC
I have this problem too.  I think this is a lack of some 'generic sim'
software.  

Though the Three sim does have a slightly different physical layout to say my
virgin/t mobile sim which reports 3G connectivity.
Comment 4 Aniello Del Sorbo 2009-10-16 12:24:47 UTC
Lucas, I think you've left your IMEI in the log.
I would remove it. It's not usually a good idea?

Aniello
Comment 6 Andre Klapper maemo.org 2009-10-16 12:41:29 UTC
Ahem. Looks like using "Private" in the Attachment Details screen refers to the
commen instead of the Attachment. Trying again as per comment 4. :-P
Comment 7 Lucas Maneos (reporter) 2009-10-16 12:47:57 UTC
I thought it might be relevant, with this being a pre-production device.  Are
there any real risks with revealing an IMEI?  AFAIK it's just an identifier.

It's a bit moot anyway since once an attachment has been posted you can't take
it back.
Comment 8 Aniello Del Sorbo 2009-10-16 12:55:31 UTC
I think Andre removed or marked it as private as I can't see it anymore.

No updates on this? I really would like to use my 3 USIM card.

Do you guys need an Three UK Sim card? ;)
Comment 9 Andre Klapper maemo.org 2009-10-16 13:14:37 UTC
No, the issue is known internally already and it has high priority.
Comment 10 Andrea Borgia 2009-10-24 21:26:53 UTC
Following Aniello's remark (in pvt) that *italian* 3 Mobile SIMs should not be
affected by this bug, today I got one on loan and tried it. Happy to report
that it works fine, in case it matters.
Comment 11 Lucas Maneos (reporter) 2009-10-25 12:59:05 UTC
Setting TM according to <http://talk.maemo.org/showthread.php?p=353767>.
Comment 12 Andre Klapper maemo.org 2009-11-20 11:57:22 UTC
This has been fixed in the internal build version
2.2009.47-20 using Sweden 3 SIM.
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 13 Aniello Del Sorbo 2009-11-20 12:01:28 UTC
If I get a copy of it I can test it straight away :-D
Comment 14 Lucas Maneos (reporter) 2009-11-20 12:02:03 UTC
(In reply to comment #12)
> This has been fixed in the internal build version
> 2.2009.47-20 using Sweden 3 SIM.

I can post a UK 3 SIM for testing if needed (you know, just to be on the safe
side).
Comment 15 Venomrush 2009-11-20 16:41:13 UTC
(In reply to comment #14)
> (In reply to comment #12)
> > This has been fixed in the internal build version
> > 2.2009.47-20 using Sweden 3 SIM.
> 
> I can post a UK 3 SIM for testing if needed (you know, just to be on the safe
> side).
> 

You don't have to if Andre can publish the firmware somewhere private so you
can update the N900 to the newest firmware to test.
Comment 16 Andre Klapper maemo.org 2009-11-20 17:21:03 UTC
(In reply to comment #15)
> You don't have to if Andre can publish the firmware somewhere private

Publishing firmware is definitely something up to Nokia.
I don't have plans to break my contracts / Non-Disclosure agreements. :-)
Comment 17 Venomrush 2009-11-20 17:52:17 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > You don't have to if Andre can publish the firmware somewhere private
> 
> Publishing firmware is definitely something up to Nokia.
> I don't have plans to break my contracts / Non-Disclosure agreements. :-)
> 

That totally destroys the point of having Maemo as an open source OS.

Someone should really need to talk to Nokia about this. 
I'm not saying everyone will gain access to firmware testing, just the trusted
and long time contributing testers, agreement/contract can be signed too if
needed.
Comment 18 Andre Klapper maemo.org 2009-11-20 18:14:42 UTC
(In reply to comment #17)
> That totally destroys the point of having Maemo as an open source OS.

That's not really true as open source does not mean to push images all of the
time but to make source code available of applications that are also publically
available.
And it's also off-topic here. :-)
Comment 19 Geert Steyaert 2009-11-20 18:19:39 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > (In reply to comment #15)
> > > You don't have to if Andre can publish the firmware somewhere private
> > 
> > Publishing firmware is definitely something up to Nokia.
> > I don't have plans to break my contracts / Non-Disclosure agreements. :-)
> > 
> 
> That totally destroys the point of having Maemo as an open source OS.
> 
> Someone should really need to talk to Nokia about this. 
> I'm not saying everyone will gain access to firmware testing, just the trusted
> and long time contributing testers, agreement/contract can be signed too if
> needed.
> 

(In reply to comment #17)
> (In reply to comment #16)
> > (In reply to comment #15)
> > > You don't have to if Andre can publish the firmware somewhere private
> > 
> > Publishing firmware is definitely something up to Nokia.
> > I don't have plans to break my contracts / Non-Disclosure agreements. :-)
> > 
> 
> That totally destroys the point of having Maemo as an open source OS.
> 
> Someone should really need to talk to Nokia about this. 
> I'm not saying everyone will gain access to firmware testing, just the trusted
> and long time contributing testers, agreement/contract can be signed too if
> needed.
> 

I totally agree. People are professional enough, also helped by the proper
agreements/contracts/NDAs etc... to keep a firmware to themselves. I'm very
used to having bleeding edge stuff on pretty much everything I own. And I've
not been involved a lot yet in the Maemo community but Nokia will need all the
support it can get from determined people to make this quest a success.

So please, allow some community input as well, as things can go potentially a
lot faster with the right resources.
Comment 20 Aniello Del Sorbo 2009-11-20 18:22:38 UTC
I think it's really going off-topic.

Would you guys mind creating a Brainstorm idea were the we (the community)
propose Nokia a way of having access to "unstable" FIASCO images for whoever is
willing to test them?

Thanks.
Aniello
Comment 21 Jamie Lokier 2009-11-20 18:35:28 UTC
(In reply to comment #18)
> (In reply to comment #17)
> > That totally destroys the point of having Maemo as an open source OS.
> 
> That's not really true as open source does not mean to push images all of the
> time but to make source code available of applications that are also publically
> available.
> And it's also off-topic here. :-)

It's true that open source doesn't mean "you must publish everything", but
VenomRush is right that it does defeat the _point_ of open source
_development_, which is to do it more openly and involve outside contributors,
and hopefully improve development by doing that.

But this is why people say Maemo is "80% open source", referring not just to
the software, but the development model, which appears to not involve outside
contributers in the core telephony software at this time.  (It can change,
perhaps).

A long discussion would be off topic here, but the short comment is relevant to
this specific bug: The firmware is ready for testing and the bug comment
*specifically* asks people to test, but people subscribed to the bug cannot do
what's asked until it's publically released.  Which misses the point: if
there's a problem, you want that feedback before it's rolled out.

If this were an internal bug tracker that outsiders get to read and respond to,
I'd understand, but it's clear that most of the development to-and-fro
regarding the 3 USIM bug has not happened on the bug tracker either.

I agree with VenomRush, btw, that it would be smart to distributed to trusted
outside contributors who are skilled enough to provide useful testing - perhaps
under NDA or release time limit.
Comment 22 Jamie Lokier 2009-11-20 18:37:04 UTC
Sorry, I wrote my comment at the same time as others said much the same thing. 
Multiple people saying the same thing isn't really needed here, and I agree
that Brainstorm is a good idea.
Comment 23 Andre Klapper maemo.org 2009-11-20 19:55:37 UTC
@Venomrush:  http://twitter.com/Venomrush/status/5894651326 :
"Funny that they asked people to confirm the fixed, but no one has access to
the firmware."

First of all "they" is me and me is not Nokia, and second of all comment 12
here clearly says "after the public update has been released".
You are very welcome to clarify this in a Twitter followup posting. ;-)
Comment 24 Lucas Maneos (reporter) 2009-11-20 22:13:27 UTC
(In reply to comment #15)
> You don't have to if Andre can publish the firmware somewhere private so you
> can update the N900 to the newest firmware to test.

That would be pointless.  If it works it works, and if it doesn't I don't have
the slightest clue how to go about debugging it.  If any of the people getting
outraged over this do, by all means post your findings here.

Getting a UK SIM in the right hands (if they don't already have one) for
testing would be far more useful.  Going by what was stated in comment 12 and
assuming no more or less than SE 3 SIMs working my "offer"[1] still stands. 
Andre, feel free to email me a snail-mail address if you feel like testing and
there's any chance UK SIMs haven't been verified.  Apparently roaming with a 3
UK pre-paid SIM isn't available in FI
(<http://www.three.co.uk/Help_Support/International/Going_abroad_Pay_As_You_Go/Destination_Details?content_aid=1214306357908>)
but is in CZ and DE.

Other than that, please calm down people :-)

[1] motivated entirely by self-interest: if it's not working in the December
release it'll cost me much more to use a different cellco than the cost of a
SIM + postage anyway.
Comment 25 Venomrush 2009-11-25 17:22:55 UTC
A report just came in from UK 3 user with contract sim card that it worked
fine.

"To add, the phone works perfectly fine with the Three sim card. It was
reported before that it wouldn't.. in my case it is working fine. Internet
settings were installed automatically by Three sending a few SMS messages with
the settings.."

See post - http://talk.maemo.org/showpost.php?p=391530&postcount=1153

I have asked for firmware version and it's 1.2009.42

"Firmware is indeed 1.2009.42

My 3 sim card is a contract one."

http://talk.maemo.org/showpost.php?p=391588&postcount=1159
Comment 26 Aniello Del Sorbo 2009-11-25 17:27:07 UTC
That's correct,

Peter (Nokia Marketing) stated that "SOME" 3 UK newer SIM cards needed a few
more love to have them work in the N900.

This guy is just lucky he got a "OLDER" 3 UK SIM card.
Comment 27 Lucas Maneos (reporter) 2009-11-25 17:36:11 UTC
FWIW both cards I tested that didn't work in 1.2009.41-10 were pre-paid, and
still didn't work in 1.2009.42-11 (exact same symptoms).  One of them is
currently on its way to Andre (thanks for volunteering to test).
Comment 28 Aniello Del Sorbo 2009-11-25 17:48:41 UTC
I tried two 3 UK SIM cards and indeed they were PAY AS YOU GO.
Comment 29 Andre Klapper maemo.org 2009-11-26 15:07:14 UTC
(In reply to comment #27)
> One of them is currently on its way to Andre

Thanks.
After putting that SIM card into my N900 which runs the internal software
version 2.2009.48-1 and going to "Phone > Dialing pad", Call type = Cellular is
available.
Also, I received a "Rate Advice" SMS by 3 about tarifs.

So I think it works. If I should test something else, just tell me. :-)
Comment 30 Venomrush 2009-11-26 15:14:58 UTC
Thanks Andre,

Would be helpful if outgoing and incoming calls + text messages are tested.

@Lucas: Is the sim you sent Andre activated and ready for use?

If it is, could you send me the sim's phone number? I can give it a ring +
text.

As for outgoing call, I think just calling 3's customer service should confirm
it's working fine.
As for outgoing text, maybe texting to get network settings or query for
balance?
Comment 31 Lucas Maneos (reporter) 2009-11-26 15:38:00 UTC
(In reply to comment #29)
> After putting that SIM card into my N900 which runs the internal software
> version 2.2009.48-1 and going to "Phone > Dialing pad", Call type = Cellular is
> available.
> Also, I received a "Rate Advice" SMS by 3 about tarifs.

Excellent, looking forward to flashing the next release some day soon :-)

> So I think it works. If I should test something else, just tell me. :-)

A data connection perhaps, but since it boots without the "SIM card rejected"
message and even receives incoming SMS I think the rest should work as with any
other SIM.  Feel free to exhaust the credit on it anyway ;-)

(In reply to comment #30)
> @Lucas: Is the sim you sent Andre activated and ready for use?
> 
> If it is, could you send me the sim's phone number? I can give it a ring +
> text.

It is, but I don't have the number handy (it's a normal SIM that does support
voice/SMS but I was only using it for data on the N810 via an el cheapo 3
handset over bluetooth).  Andre: it may be listed in Contacts -> Menu -> My
information (if the number is present on the SIM), otherwise there's always
caller ID.
Comment 32 Daniel Would 2009-11-26 18:21:43 UTC
Now that this is resolved, can we get a timescale for when the update will be
pushed out? my new n900 is great, but I'd rather like to use it as a phone...
Comment 33 Andre Klapper maemo.org 2009-11-27 13:26:01 UTC
Nokia never announces dates or plans for releases. I wonder if I should always
add this sentence to my answer in Comment 12.
And as Browser Portrait Mode will be available until Christmas, one or more
updates will also be available before Christmas. :-P
Comment 34 Andre Klapper maemo.org 2009-11-27 14:20:32 UTC
(In reply to comment #31)
> A data connection perhaps, but since it boots without the "SIM card rejected"
> message and even receives incoming SMS I think the rest should work as with any
> other SIM.  Feel free to exhaust the credit on it anyway ;-)
> 
> (In reply to comment #30)
> > If it is, could you send me the sim's phone number? I can give it a ring +
> > text.

I tried to call from the UK 3 SIM card in the N900 to my German Vodafone SIM
card in an Nokia 8310, both located here on my desk in Czech Republic.

Currently I get "Cellular network not available". :-/
There is no 3 service here in Czech republic, but yesterday when I tried it
this successfully it automatically used T-Mobile CZ instead.

Hmm, hmm. Might be a different issue with roaming if I continue running into
this.
Comment 35 Andre Klapper maemo.org 2009-11-27 14:34:15 UTC
Garr. Now it all works of course. Just took quite a while after inserting that
SIM card.
Comment 36 Andre Klapper maemo.org 2009-11-27 14:46:02 UTC
I can definitely send/receive messages and also send/receive phone calls with
UK 3 SIM card in N900 and German Vodafone SIM card in Nokia 8310.
Tried both in both directions.

With regard to data connections, I disconnected from my local wifi and chose
the connection "3", and clicked "Yes" to "Allow data roaming?".
Afterwards I started the browser and went to facebook.com.
I immediately received an sms
"From 3: We're about to send you settings so you can access the internet and
use picture messaging. Please accept the settings straightaway."
After reading that (nothing else) I went back to the browser and facebook.com
had loaded already.
Then I received a system popup saying
"Cellular access point settings not updated. Received settings identical to
current ones."
Data connection is still set to "3", ISP in the Desktop title bar still says
"T-Mobile CZ".
Next SMS was:
"From 3: If you accepted the settings we sent to you, you can now use the
internet & picture messaging. Get started free link
http://ghp.three.co.uk/hb/HutchKey"

So I'd say that everything basically works, though the "settings not updated"
dialog still confused me. :-/
Comment 37 Lucas Maneos (reporter) 2009-11-27 14:51:50 UTC
(In reply to comment #36)
> Then I received a system popup saying
> "Cellular access point settings not updated. Received settings identical to
> current ones."

The "current ones" came from the SIM at boot time I guess.  Not replacing
settings with identical ones sounds sensible, but I'm not sure the user really
needs to be alerted of that fact (nothing to do with this bug anyway).

Sounds like all works as expected otherwise, thanks again for testing :-)
Comment 38 Daniel Would 2009-11-27 14:58:27 UTC
(In reply to comment #33)
> Nokia never announces dates or plans for releases. I wonder if I should always
> add this sentence to my answer in Comment 12.
> And as Browser Portrait Mode will be available until Christmas, one or more
> updates will also be available before Christmas. :-P
> 

Whilst I appreciate Nokia would not announce a date for most things, I was
hoping that for such a serious bug, they might at least have a 'tentative'
outlook. an order of magnitude of days/weeks/months would be nice.
That said they didn't officially tell me that this problem existed when I
ordered the phone. and I only knew because I happen to read the right forums,
so I guess I should not be surprised.
I guess I'll just be happy that a fix exists and that is a reasonable sign.
Comment 39 Klen 2009-12-01 11:36:28 UTC
I am also having the same problem with my N900 and a UK 3 SIM card. Hope to be
able to download a new version soon. 

klen
Comment 40 Jamie Lokier 2009-12-07 02:47:42 UTC
Just wondering, is it general policy to mark bugs as resolved+fixed even though
the fix is not available?  That may be the policy in some closed source
commercial environments (not all), but it doesn't reflect the workflow seen by
users reporting bugs on bugs.maemo.org.

Whatever the general policy, perhaps there should be another step in the status
of bugs on bugs.maemo.org, marking the transition from fixed to released?

FIXED (not RESOLVED because it's not the final step)

-> RELEASED + RESOLVED

If someone would be kind enough to say if this is the general policy, I'll
create a new bug suggesting this workflow change.  However, if it's just a
one-off for this particular bug #5315, there's no point doing that.  Thanks.
Comment 41 Andre Klapper maemo.org 2009-12-07 14:44:41 UTC
(In reply to comment #40)
> Just wondering, is it general policy to mark bugs as resolved+fixed even though
> the fix is not available?

Yes. After release the Target Milestone gets reset to a real release version.
Comment 42 Jamie Lokier 2009-12-18 23:04:24 UTC
(In reply to comment #41)
> (In reply to comment #40)
> > Just wondering, is it general policy to mark bugs as resolved+fixed even though
> > the fix is not available?
> 
> Yes. After release the Target Milestone gets reset to a real release version.

I didn't understand your explanation, but Quim explains it very well:

http://talk.maemo.org/showpost.php?p=433546&postcount=11

- RESOLVED FIXED means fixed. Not closed.
- VERIFIED comes after RESOLVED, if the reporter agrees on the resolution
(FIXED, DUPLICATE, etc)
- CLOSED comes only after VERIFIED.

I didn't realise that RESOLVED FIXED is not the same as CLOSED, largely because
RESOLVED means "we're done here" in English :-)
Comment 43 Andre Klapper maemo.org 2009-12-19 22:07:06 UTC
(In reply to comment #42)
> - RESOLVED FIXED means fixed. Not closed.

There is a link directly where Resolution and Status are written on this page.
It goes to https://bugs.maemo.org/page.cgi?id=fields.html and should be totally
clear. If not, please send me a private email instead of commenting here.
Thanks
Comment 44 jmcoulson 2009-12-23 13:15:41 UTC
So, when can we see this fix become available to the general public? I could
really do with it soon - brand new 3 SIM arrived today, doesn't work.
Comment 45 Aniello Del Sorbo 2009-12-26 16:08:28 UTC
I verified this on 2.2009.51-1 and my 3 UK (all of them) worked flawlessly in
the N900.
Comment 46 Graham Cobb maemo.org 2009-12-28 02:02:18 UTC
Works with my 3UK SIM as well (2.2009.51-1), at least in 2G roaming (no 3G
coverage where I live).
Comment 47 Andre Klapper maemo.org 2009-12-28 13:51:31 UTC
(In reply to comment #44)
> So, when can we see this fix become available to the general public?

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/

(Please don't add further discussion about this here in this bug report to
avoid noise.)
Comment 48 christoph@herndler.com 2009-12-30 15:36:09 UTC
Just wanted to mention that the n900 works fine with firmware 2009.41-10
 and my Austrian 3 Sim Card (bought in november 2008).
Comment 49 besh_5989 2010-01-13 17:22:21 UTC
Can you please confirm that the fix has not yet been released to the public? I
ask this as I have just updated my n900 to version 1.2009.44-1 and my 3UK sim
still does not work (SIM card rejected message).

Thanks
Comment 50 Andre Klapper maemo.org 2010-01-13 17:25:18 UTC
(In reply to comment #49)
> Can you please confirm that the fix has not yet been released to the public? I
> ask this as I have just updated my n900 to version 1.2009.44-1 and my 3UK sim
> still does not work (SIM card rejected message).

Please read bug reports before adding new comments.
Comment 12 answers your question.
Comment 51 besh_5989 2010-01-13 17:29:27 UTC
(In reply to comment #50)
> (In reply to comment #49)
> > Can you please confirm that the fix has not yet been released to the public? I
> > ask this as I have just updated my n900 to version 1.2009.44-1 and my 3UK sim
> > still does not work (SIM card rejected message).
> 
> Please read bug reports before adding new comments.
> Comment 12 answers your question.
> 

Sorry I seemed to completely miss that comment. I was worried that the bug had
been closed as some have mentioned 3 sims working on older versions (41-1).

Thanks anyway. I look forward to the release of this update (hopefully soon)
Comment 52 Andre Klapper maemo.org 2010-01-14 12:25:48 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 53 Jamie Lokier 2010-02-02 22:55:37 UTC
I'd just like to confirm that I'm using a 3 SIM in the UK since PR1.1 was
released, and it's been working perfectly for everything so far.

The GPRS data setting worked automatically - which is better than both other
SIMs I used (Vodafone and Giffgaff), both of which got the wrong GPRS setting
after inserting them, and needed to be manually changed before they worked.

On that basis, I'd say the 3 SIM support is better than Vodafone and Giffgaff
now :-)  But they all work in the end.

I say perfect.  There is one issue, I'll mention because I don't know if it has
anything to do with network settings read from the SIM, other network settings
picked up as a result, or neither of those.

There is a tendancy, in poor reception areas, to jump every few minutes between
a 3G signal which is too poor to use (can't maintain voice calls or one end
can't hear anything, can't use data) and a 2G signal which is perfectly good
and can do voice and data well - even when stationary.

That might be 3's network, or it might be the N900 having it's threshold for
acceptable 3G signal set too low.  It is something other Nokia handsets do with
3 UK, I've noticed.  I've not noticed it as severely with other networks, nor
with non-Nokia handsets on 3, so perhaps the algorithm and/or thresholds used
by Nokia for this could be improved.

(Just fyi, this is in an area (Oxford, UK) where 3 themselves say the signal
quality is "very good" but is, in reality, extremely variable (6 to 0 bars 3G)
over distances of a few metres.)

It also suprisingly has problems getting a data connection sometimes ("No
cellular data available") with 5 bars on 3G.  I doubt if that's a SIM issue.