Bug 5309 - (int-143011) Don't show "Update All" if no updates are available
(int-143011)
: Don't show "Update All" if no updates are available
Status: VERIFIED FIXED
Product: Settings and Maintenance
Application manager
: 5.0/(1.2009.42-11)
: All Maemo
: Low minor (vote)
: 5.0/(1.2009.44-1)
Assigned To: unassigned
: application-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-11 17:57 UTC by timeless
Modified: 2010-01-11 14:49 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description timeless (reporter) 2009-10-11 17:57:17 UTC
SOFTWARE VERSION: maemo software from maemo summit :)

STEPS TO REPRODUCE THE PROBLEM:
0. disconnect from network and configure network to ask
1. open app manager
2. tap update/updates
3. tap stop repeatedly
4. when asked for a network tap outside to cancel
5. tap outside the "not all catalogs updated" dialog to dismiss it
6. you should see no updates available
7. tap the title area
8. tap update all

EXPECTED OUTCOME:
update all shouldn't be an available button

ACTUAL OUTCOME:
information dialog "all applications already installed"

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2009-11-06 12:40:54 UTC
This has been fixed in package
hildon-application-manager 1:2.2.39+0m5
which is part of the internal build version
2009.45-14 
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 2 Andre Klapper maemo.org 2009-12-03 11:01:06 UTC
*** Bug 6528 has been marked as a duplicate of this bug. ***
Comment 3 Andre Klapper maemo.org 2010-01-11 14:49:05 UTC
This is fixed in the small update that was released today (version
1.2009.44-1).