Bug 5294 - Support for modifying/deleting a single occurrence of repeating event
: Support for modifying/deleting a single occurrence of repeating event
Status: RESOLVED WONTFIX
Product: Calendar
General
: 5.0/(1.2009.42-11)
: All Maemo
: Low enhancement with 77 votes (vote)
: ---
Assigned To: unassigned
: calendar-general-bugs
:
:
:
: int-152175
  Show dependency tree
 
Reported: 2009-10-08 14:22 UTC by Ville Reijonen
Modified: 2012-03-24 11:46 UTC (History)
16 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ville Reijonen (reporter) 2009-10-08 14:22:18 UTC
SOFTWARE VERSION:
Maemo 5 SDK final release. Should apply therefore also to the product.

STEPS TO REPRODUCE THE PROBLEM:
Open calendar. Create event with title "Meeting" and where "London". Make it
repeat for daily for a month. Select a day from middle of the repeat and edit
the event. Change the where to "Paris". Press save.

EXPECTED OUTCOME:
A question would be prompted asking if the change should be applied to 1) only
to this event or 2) this and all future events or 3) to all events. The user
can then choose for example to change only this event.

ACTUAL OUTCOME:
The "Paris" is changed as where to all event instances. 

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
The same applies to deleting a single event instance from a repeat. Either all
are deleted or none. This is a basic calendar functionality which one expects
to work.
Comment 1 Andre Klapper maemo.org 2009-10-10 14:31:31 UTC
Thanks for the rpeort.
Please don't set priority to critical. Critical is for data loss.

The functionality requested here was never announced and is not part of the
official Fremantle version, hence changing status to enhancement.
Comment 2 Andre Klapper maemo.org 2009-12-01 17:22:02 UTC
*** Bug 6362 has been marked as a duplicate of this bug. ***
Comment 3 John Serafin 2009-12-03 07:03:15 UTC
On the N900, I am not able to figure out how to set a repeating event in the
calendar at all, much less edit one. The clock allows repeating alarms (with
very few options), but these do not show up in the calendar. In addition, the
calendar alarm is a fixed 15 minutes before the event.
Comment 4 Andy Dunmore 2009-12-03 08:53:29 UTC
Emailed John to answer questions and direct him to the forum.
Comment 5 Andre Klapper maemo.org 2009-12-03 11:36:16 UTC
*** Bug 6513 has been marked as a duplicate of this bug. ***
Comment 6 Paul van Tilburg 2009-12-28 14:31:13 UTC
Additionally, next to Change All and Change Single Event it would be very
useful to have the option Change From Now On.
Comment 7 Andre Klapper maemo.org 2010-01-15 18:20:49 UTC
*** Bug 8032 has been marked as a duplicate of this bug. ***
Comment 8 Johannes Twittmann 2010-01-26 13:56:32 UTC
Andre Klapper (maemo.org) wrote at 2009-10-10 14:31:31 GMT+3
> The functionality requested here
> was never announced and is not part
> of the official Fremantle version,
> hence changing status to enhancement.

When you buy the device it sais it has a calendar and not "a calendar that's
unusable". Please keep the consumer in mind and not the techie that read all
the (probably internal) documents from Nokia with a complete application
description and specification.

This issue is even worse when you synchronize with outlook. My calendar then
says something like "complex repetition, unable to edit". (In fact it's german
and it says "Kompl. Wiederh. Bearbeiten unmögl." - why all that abbreviations
on such a huge display?) Come on, Palm showed 1996 how it is done. In my
oppinion there is no better calender than the palm OS's one...
Comment 9 Andre Klapper maemo.org 2010-01-26 14:00:05 UTC
(In reply to comment #8)
> When you buy the device it sais it has a calendar and not "a calendar that's
> unusable".

Contact Nokia Customer Care and complain about the marketing. Offtopic here.

> "Kompl. Wiederh. Bearbeiten unmögl."

Separate issue, unrelated to this report. File a separate issue please.
Comment 10 Loek Engels 2010-01-26 21:26:10 UTC
=(

When I am at home, traveling or on holiday I would like to make changes to my
calendar. However, I do not have access to calendaring tools that allow me to
edit recurring appointments I can sync with as a workaround for e.g. deleting
or editing recurring appointments. Please take this into account.
Comment 11 petibub 2010-03-11 01:01:26 UTC
(In reply to comment #9)

Andre, how are the chances to get this feature? What can we do (beside voting)?
Comment 12 Venomrush 2010-03-26 01:52:10 UTC
*** Bug 9711 has been marked as a duplicate of this bug. ***
Comment 13 Venomrush 2010-03-29 04:03:54 UTC
*** Bug 8550 has been marked as a duplicate of this bug. ***
Comment 14 Alejandro López 2010-04-27 18:31:34 UTC
(In reply to comment #1)
> The functionality requested here was never announced and is not part of the
> official Fremantle version, hence changing status to enhancement.

Please let me disagree with you on this, Andre. 

When you buy a watch, it is never announced in the functionalities that it
shows the time of the day because this is what a watch does. Only
extra/unexpected/differentiating functionalities are announced.

In the case of a calendar, one expects to be able to modify/delete single
occurrences of repeating events, and would actually be astonished if this is
mentioned (in the same way as if a watch spec mentioned that it shows the
time).

Deleting single occurrences of repeating events is something that happens all
the time, just consider a weekly meeting that one week gets canceled.

IMHO this is a bug that needs to be fixed ASAP and not an enhancement that can
wait until the next major release of the OS (MeeGo?).
Comment 15 Andre Klapper maemo.org 2010-04-27 19:14:42 UTC
(Note that most of the time I'm "just" the messenger for Nokia and don't do
these decisions / definitions myself.)
Comment 16 Martin Atkins 2010-05-20 15:26:24 UTC
Well, the Erminig developer points out that the "framework" for
deleting/modifying repeating events exists, but simply doesn't do anything.

(See http://talk.maemo.org/showpost.php?p=661533&postcount=318)

Surely *that* makes it a bug!
Comment 17 aaron mcewan 2010-09-20 10:04:59 UTC
as it seems noika have little/no intention of fixing or making it open source
would it be possible for the source to be disclosed under an NDA ( or
something...) to someone who wants to fix it?
Comment 18 Andre Klapper maemo.org 2010-09-20 12:05:42 UTC
(In reply to comment #17)
> would it be possible for the source to be disclosed under an NDA

A bit offtopic here. Please see bug 7811 and/or contact Nokia. Thanks! :)
Comment 19 Andre Klapper maemo.org 2012-03-24 11:46:11 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )