Bug 5244 - Please package pygame 1.9.1 (current is 1.8.1)
: Please package pygame 1.9.1 (current is 1.8.1)
Status: RESOLVED FIXED
Product: PyMaemo
General
: unspecified
: All Linux
: Low enhancement with 5 votes (vote)
: ---
Assigned To: Anderson Lizardo
: general
:
: upstream
: 10838
:
  Show dependency tree
 
Reported: 2009-09-30 03:52 UTC by Rene Dudfield
Modified: 2010-08-04 21:56 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Rene Dudfield (reporter) 2009-09-30 03:52:57 UTC
hi,

please package the new version of pygame 1.9.1.

cheers!


What's new (heaps of things since 1.8.1): http://www.pygame.org/whatsnew.shtml

Summary of changes:
  - many, many fixes and improvements. The largest amount of changes has gone
into this release than any other pygame release.
  - bug fixes for backwards compatibility issues introduced in pygame 1.8.x
series. old games like solarwolf and libraries like PGU work again.
  - experimental camera webcam module (still in development).
  - experimental midi module based on portmidi and pyportmidi (99% complete).
  - experimental gfxdraw module based on SDL_gfx (including AA circles,
textured polygons and other goodness).
  - python3, and python3.1 support mostly completed. Some modules still remain
to be completed - but mostly it's working.
  - nokia mobile phone s60 support.
  - improved OSX support (dropped pyobjc dependency, improved installer,
sysfont now works on OSX).
  - pygame.examples + pygame.tests included with pygame. This makes testing
easier, and also makes learning pygame more fun and easy.
  - cleanup of examples, and addition of new examples.
  - new tools to aid in development of pygame itself, better compilation
documentation.
  - py2app, and py2exe support improved.
Comment 1 Andre Klapper maemo.org 2009-09-30 12:10:42 UTC
I don't think this is the right place for "Please package requests", but I'll
let the PyMaemo maintainers decide...
For future reference, please set severity to Enhancement. Thanks.
Comment 2 Rene Dudfield (reporter) 2009-09-30 12:45:54 UTC
Hi Andre,

what is the reasoning behind your comment?  Why Enhancement, and why might it
not be the right place?

thanks for any info.

cheers,
Comment 3 Andre Klapper maemo.org 2009-09-30 12:51:19 UTC
Updating packages is by deafult an enhancement to me. Also see
https://bugs.maemo.org/page.cgi?id=fields.html#bug_severity
Comment 4 Anderson Lizardo 2009-10-08 22:15:55 UTC
For PyMaemo, new package requestes can be filled as bug reports just fine (it
also help us sorting out what tasks need to be done).

But any package requests must be marked initially as enhancement, unless they
justify as some critically missing functionality (which is not the case for
this new pygame version).

That said, we plan to keep the pygame version aligned to the latest version in
Debian, so we can share the bug fixes, user testing and packaging from it. For
now, I'll close the bug as WONTFIX (although I prefer the "LATER" resolution,
but there is no such resolution in the Maemo bugzilla), but feel free to reopen
it if you have an actual use case for it (e.g. some application that you want
to write or port to Maemo but requires pygame 1.9.x).
Comment 5 Rene Dudfield (reporter) 2009-10-09 12:20:52 UTC
Hello,

I'm a little disappointed, and confused that it is marked as WONTFIX.  'Please
package' bugs are quite common on other distros.  But hey, it's your bug
tracker, your policies, and you'll be doing the work.  I don't (yet) have a
Maemo device so can't help.

*I feel like one of those people arguing with a bouncer at a night club,
thinking that further drunken arguments will somehow convince the bouncer to
let them in.  However everyone watching knows that those idiots arguing with
the bouncer are never going to be let in.*

Our other nokia pygame port to pys60 is up to date.  So it would be in the
interest of people developing on nokia platforms as a whole to have the same
version.

The whatsnew link I sent you lists many important bug fixes.  There are pygame
programs that do not work with 1.8.1.  There are regressions, memory corruption
fixes, buffer over runs, and memory leaks.  As well as new useful functionality
for maemo devices like camera access.

I know Maemo packages are mostly taken from Debian, however Debian has not yet
updated.  So it definitely makes sense to wait for the ubuntu/debian packagers
to do their thing.  I've kept a link on the pygame download page with other
distributions that are slow in updating - so leaving it as WONTFIX is fine.

Debian, macports and lots of other platforms have 'watches' which let you
specify a url pattern to look out for.  So that when a new releases happens,
that release is automatically put against the package.

Debian and Ubuntu also list each others bug trackers, and link to each others
packages which makes it easier for people on the different projects to
coordinate their packaging efforts.

Bug trackers can also be used as a TODO list for people working on a project. 
If an item is marked as WONTFIX then it's very unlikely that random people
going through the bug list will take an item on.

I'll concentrate on the Ubuntu and Debian packages, since they should hopefully
filter through eventually.


cu.
Comment 6 Anderson Lizardo 2009-10-09 14:07:04 UTC
Hi,

First of all, feel free to move the discussion to a mailing list
(maemo-developers or pymaemo-developers are just fine) if you have further
questions, which is better for this purpose (the bugzilla comment section is
not threaded, and usually confusing to follow up discussions).

As I explained on my comment, I'd mark it as "LATER", but there is no such
resolution type on this scpecific bugzilla installation. (Andre Klapper: feel
free to change the resolution field to the more appropriate value, I just
didn't want to leave it as "UNCONFIRMED").

It is "WONTFIX" *for the final Maemo 5 release*. We are just preparing for the
release candidate, therefore introducing a new major release of a package
(where we don't see any guarantees of backwards compatibility) just a few weeks
from a final release is risky, in my opinion.

I should remind that there are a couple of packages on the Maemo extras
repository that use pymage 1.8.x, and there were no bug reports on it so far.

Having the latest and greatest versions of every package would be great, but
that's usually an integration nightmare to do so, specially if the base system
(the packages provided by the Maemo SDK and Scratchbox) it not as up-to-date as
well. To keep things sane, we decided a long time ago to align with the same
Debian packaging which the Maemo 5 SDK itself is based on, and that reduced a
lot of dependency problems and "hacks" necessary to get "too new" packages
working on a "too old" base system.

I hope this makes things clear to you :)
Comment 7 Andre Klapper maemo.org 2009-10-13 13:19:53 UTC
(In reply to comment #6)
> As I explained on my comment, I'd mark it as "LATER", but there is no such
> resolution type on this scpecific bugzilla installation.

Yes, as LATER is really evil and bugs often tend to get forgotten...
I want to keep it simple. :-)

> (Andre Klapper: feel
> free to change the resolution field to the more appropriate value

Totally fine.
Comment 8 Frederik Niedernolte 2010-01-15 00:07:34 UTC
1.9.1 was released for Ubuntu:
https://bugs.launchpad.net/ubuntu/+source/pygame/+bug/433304
Is it possible to use this package for an update to 1.9.1 for the Maemo
platform?
Comment 9 Anderson Lizardo 2010-01-15 14:15:00 UTC
I'll (In reply to comment #8)
> 1.9.1 was released for Ubuntu:
> https://bugs.launchpad.net/ubuntu/+source/pygame/+bug/433304
> Is it possible to use this package for an update to 1.9.1 for the Maemo
> platform?

I'll reopen the bug, as the reasoning behind marking it as WONTFIX has been
changed.

Thanks for the reminder.
Comment 10 toucan murphy 2010-04-29 17:32:11 UTC
*** This bug has been confirmed by popular vote. ***
Comment 11 mike choy 2010-05-12 00:55:28 UTC
Hi I'm the developer for maesynth and maelophone which depend on PyGame. I
think there may be dependency issues with this older version and numpy in the
dev repos. Can we have 1.9 of pygame please :-)
Comment 12 Bruno Araujo 2010-07-29 23:30:51 UTC
Pygame was just updated to 1.9.1release-0maemo1. Although functional, this new
version of pygame is affected by a bug on one of this dependencies
(python-numpy) described on bug #10838 (which blocks this one, BTW). Until
things are settled, you'll need to install liblapack-dev in order to make
pygame work. 

So, please test it, and feedback is welcome!
Comment 13 Frederik Niedernolte 2010-07-29 23:48:34 UTC
I have tried to update but I get the following error message:

Unpacking libsdl-ttf2.0 (from .../libsdl-ttf2.0_2.0.9-1osso0+0m5_armel.deb) ...
dpkg: error processing
/var/cache/apt/archives/libsdl-ttf2.0_2.0.9-1osso0+0m5_armel.deb (--unpack):
 trying to overwrite `/usr/lib/libSDL_ttf-2.0.so.0.6.3', which is also in
package libsdl-ttf2.0-0
Errors were encountered while processing:
 /var/cache/apt/archives/libsdl-ttf2.0_2.0.9-1osso0+0m5_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Comment 14 Bruno Araujo 2010-08-04 21:56:09 UTC
(In reply to comment #13)
> I have tried to update but I get the following error message:
> 
> Unpacking libsdl-ttf2.0 (from .../libsdl-ttf2.0_2.0.9-1osso0+0m5_armel.deb) ...
> dpkg: error processing
> /var/cache/apt/archives/libsdl-ttf2.0_2.0.9-1osso0+0m5_armel.deb (--unpack):
>  trying to overwrite `/usr/lib/libSDL_ttf-2.0.so.0.6.3', which is also in
> package libsdl-ttf2.0-0
> Errors were encountered while processing:
>  /var/cache/apt/archives/libsdl-ttf2.0_2.0.9-1osso0+0m5_armel.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> 

This problem was already solved, so I think the package is usable now. The
issue with liblapack-dev cited on comment #12 persist, but let's hope it gets
fixed soon. I'll mark this bug as FIXED.