Bug 5218 - Voice/video call N900 to N810 doesn't work at all
: Voice/video call N900 to N810 doesn't work at all
Status: VERIFIED FIXED
Product: Chat & Call & SMS
VoIP
: 5.0/(2.2009.51-1)
: All Linux
: Low normal with 11 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: internet-call-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-09-27 12:56 UTC by Till Harbaum
Modified: 2010-06-13 22:17 UTC (History)
10 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Till Harbaum (reporter) 2009-09-27 12:56:23 UTC
SOFTWARE VERSION:
1.2009.39-9

STEPS TO REPRODUCE THE PROBLEM:
Try to call a jabber acount from n900 to n810 or vice versa

EXPECTED OUTCOME:
The call can be established

ACTUAL OUTCOME:
On the n900 the "incoming call" screen is displayed. After clicking "accept",
the message "connecting" is being displayed and after a few seconds the
connection is terminated. No connection can be established, neither for voice
nor for video

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
Nothing

OTHER COMMENTS:
I once got this working with two devices in the same lan, but the connection
failed several times before it worked and then the link only worked for a few
seconds before the connection was lost


User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4pre)
Gecko/20090831 Ubuntu/9.04 (jaunty) Shiretoko/3.5.4pre
Comment 1 Lucas Maneos 2009-09-27 15:38:24 UTC
Sounds like a codec mismatch, maybe related to bug 2811 (since Fremantle
includes speex by default)? 

Does syslog on either side show anything interesting?
Comment 2 Olivier Crête 2009-09-27 19:17:58 UTC
Calls between fremantle and diablo work just fine for us.
Comment 3 Lucas Maneos 2009-09-27 19:44:29 UTC
Good to know :-)

Till, anything extra & relevant installed on the N810?  I'm thinking of
mogg/ogg support or rtcomm beta in particular.
Comment 4 Olivier Crête 2009-09-27 20:07:12 UTC
If you have the most recent version of diablo, it shouldn't matter. It ignores
speex.
Comment 5 Till Harbaum (reporter) 2009-09-27 21:46:08 UTC
The n810 we just used was the latest diablo with imho neither ogg nor rtcomm
support. Will check that later.

I just tried between my own old n810 (with rtcomm but without ogg) and
fremantle. I am unable to establish any connection there. I am behind a nat
gateway. May this be related to connection problems? We have successfully been
using the same setup for n810-n810 connections plenty of times.
Comment 6 Andre Klapper maemo.org 2009-09-28 13:50:24 UTC
In general filing a bug as "UNCONFIRMED" is prefered. Currently the template
unfortunately defaults to "NEW", I know.
Comment 7 Jason Carter 2009-10-06 23:20:38 UTC
I had no problems calling an N810 from an N900 using voice alone.
Comment 8 Olivier Crête 2009-10-06 23:34:29 UTC
Oh, video calling is not fully supported in the first sales release. It will be
fully supported in a forthcoming release.
Comment 9 Lucas Maneos 2009-10-12 10:33:06 UTC
Audio seems to work fine between N900/1.2009.41-10 & N810/5.2008.43-7.  For
video:

The N900 doesn't seem to detect that the other end supports video and doesn't
offer a camera button.  After switching the camera on on the N810, video is
shown on the N810 and the camera button appears.  Pressing the camera button on
the N900 makes video work in both directions for a fraction of a second but
then video is terminated on both ends.  This happens regardless of which side
initiated the call, and syslog reports:

Oct 12 08:27:37 Nokia-N900-41-10 telepathy-stream-engine[3706]: GLIB DEBUG
tp-fs - stream 2 0xa0208 (video) set_stream_sending: 1
Oct 12 08:27:37 Nokia-N900-41-10 telepathy-stream-engine[3706]: GLIB DEBUG
tp-fs - stream 2 0xa0208 (video) tf_stream_request_resource: Requesting
resource for direction 1
Oct 12 08:27:37 Nokia-N900-41-10 telepathy-stream-engine[3706]: GLIB DEBUG
default - Starting video source
Oct 12 08:27:38 Nokia-N900-41-10 telepathy-stream-engine[3706]: GLIB DEBUG
tp-fs - stream 2 0xa0208 (video) tf_stream_request_resource: Requesting
resource for direction 1 returned 1
Oct 12 08:27:38 Nokia-N900-41-10 telepathy-stream-engine[3706]: GLIB DEBUG
default - made video sink element xvimagesink1
Oct 12 08:27:38 Nokia-N900-41-10 telepathy-stream-engine[3706]: GLIB WARNING **
tp-fs - stream 2 0xa0208 (video) _tf_stream_bus_message: error (construction
(1)): Could not build a new send codec bin : Could not sync the state of the
codec bin for pt 34 with the state of the conference
Oct 12 08:27:38 Nokia-N900-41-10 telepathy-stream-engine[3706]: GLIB MESSAGE
tp-fs - tf_stream_error: stream error errorno=0 error=Could not build a new
send codec bin
Oct 12 08:27:39 Nokia-N900-41-10 telepathy-stream-engine[3706]: GLIB DEBUG
tp-fs - stream 2 0xa0208 (video) set_stream_playing: 0

If it matters, ogg support is installed on the N900 but not on the N810.
Comment 10 Andre Klapper maemo.org 2009-10-20 12:39:16 UTC
I wonder if bug 5614 might be the same technical issue.
Comment 11 Olivier Crête 2009-10-20 13:42:12 UTC
The video sending not working is a known issue on the current software release
for the N900, it should be fixed in the next release. But will only be fully
supported when Video calls are fully supported (soon hopefully).
Comment 12 Lucas Maneos 2010-01-07 06:21:11 UTC
*** Bug 7723 has been marked as a duplicate of this bug. ***
Comment 13 Lucas Maneos 2010-01-07 17:48:26 UTC
*** Bug 7749 has been marked as a duplicate of this bug. ***
Comment 14 Andre Klapper maemo.org 2010-01-14 12:32:19 UTC
Today Nokia released the Maemo5 update version 2.2009.51-1 for public (also
called "PR1.1" sometimes).
If you have some time we kindly ask you to test again if the problem reported
here still happens in this new version - just leave a comment (and feel free to
update the "Version" field to the new version if it's still a problem).
Comment 15 Olivier Crête 2010-01-14 15:50:26 UTC
Video calls aren't fully fixed in PR1.1, but they work great in PR1.2 :-(
Comment 16 Alexandro 2010-01-14 15:53:19 UTC
(In reply to comment #15)
> Video calls aren't fully fixed in PR1.1, but they work great in PR1.2 :-(
> 

Anyone know if the update also fixes the front camera? I used mirror and the
camera looks really bad. An alert mentions that the crappiness could be fixed
through a firmware update. 

Just wonder if this is indeed fixed on the PR1.1/2?
Comment 17 Olivier Crête 2010-01-14 15:57:12 UTC
The front camera software has been tuned in PR1.2 (ie the next one).
Comment 18 Andre Klapper maemo.org 2010-05-28 21:26:15 UTC
This week Nokia released the Maemo5 update version 10.2010.19-1 for public
(also called "PR1.2").
If you have some time we kindly ask you to test again if the problem reported
here still happens in this new version - just leave a comment (and feel free to
update the "Version" field to the new version if it's still a problem).
Comment 19 sconf 2010-06-03 20:15:13 UTC
(In reply to comment #18)
Before PR1.2 I used to be able to video chat between N8x0 and N900, when call
was initiated from N8x0.  That was using OVI account.

After upgrading to PR1.2, N8x0 don't allow "internet call" to N900 anymore (not
video, not voice).  The option for call is grayed in N8x0.  IM to N900 works.

N900 don't have any apparent way to initiate call to N8x0, no change with PR1.2
upgrade.
Comment 20 Olivier Crête 2010-06-03 20:40:56 UTC
Voice/Video calls using Ovi Chat accounts is not supported and is intentionally
disabled.

If it fails with a regular Jabber account (or a gtalk account). Please re-open
with more details.
Comment 21 Lucas Maneos 2010-06-13 22:17:54 UTC
Just had a guest N900 over and tested calls initiated both by the N810 and the
N900.  Video worked fine in both directions using accounts on a local ejabberd.