Bug 5188 - (int-140687) Remove HildonDialog deprecated symbol
(int-140687)
: Remove HildonDialog deprecated symbol
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(1.2009.42-11)
: All Linux
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: modest-bugs
:
: patch
:
:
  Show dependency tree
 
Reported: 2009-09-24 15:27 UTC by Javier Jardón
Modified: 2010-01-14 12:28 UTC (History)
2 users (show)

See Also:


Attachments
Remove HildonDialog deprecated symbol (2.15 KB, patch)
2009-09-24 15:29 UTC, Javier Jardón
Details
Remove HildonDialog deprecated symbol.v2 (2.98 KB, patch)
2009-09-24 16:29 UTC, Javier Jardón
Details
Remove HildonDialog deprecated symbol.v3 (2.97 KB, patch)
2009-09-30 14:49 UTC, Javier Jardón
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Javier Jardón (reporter) 2009-09-24 15:27:59 UTC
HildonDialog is deprecated since version 2.2 (was already introduced in version
2.2) and GtkDialog is the recommended widget

Patch following
Comment 1 Javier Jardón (reporter) 2009-09-24 15:29:54 UTC
Created an attachment (id=1377) [details]
Remove HildonDialog deprecated symbol
Comment 2 Javier Jardón (reporter) 2009-09-24 16:29:42 UTC
Created an attachment (id=1378) [details]
Remove HildonDialog deprecated symbol.v2

More complete patch (removed HILDON_TYPE_DIALOG too)
Comment 3 Andre Klapper maemo.org 2009-09-25 12:38:08 UTC
True - HildonDialog was replaced by GtkDialog.
Comment 4 Sergio Villar Senin 2009-09-30 13:28:01 UTC
the patch does not apply cleanly. Can you reattach it?
Comment 5 Javier Jardón (reporter) 2009-09-30 14:49:45 UTC
Created an attachment (id=1387) [details]
Remove HildonDialog deprecated symbol.v3

Sure, this patch should apply, tell me if not
Comment 6 Sergio Villar Senin 2009-09-30 17:45:06 UTC
Patch looks good to me

As usual, thank you very much for your contributions

Committed in master 1de0b331024e79022e18644acf861cd3983851f8
Comment 7 Andre Klapper maemo.org 2009-10-26 12:54:16 UTC
Fixed in internal week 43 build.
Any public update released with or after this build version (x.2009.43-y) will
include the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 8 Andre Klapper maemo.org 2010-01-14 12:28:09 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.