Bug 5181 - Automatically download new episodes when on 'home' connection
: Automatically download new episodes when on 'home' connection
Status: RESOLVED FIXED
Product: gPodder
General
: unspecified
: All Windows
: Low normal with 14 votes (vote)
: ---
Assigned To: Thomas Perl
: general
:
:
: 7729
:
  Show dependency tree
 
Reported: 2009-09-23 16:33 UTC by Niels Breet
Modified: 2011-02-19 15:38 UTC (History)
4 users (show)

See Also:


Attachments
Check the network connection type (744 bytes, text/x-python)
2010-04-06 21:44 UTC, Rene Castberg
Details
Adds the check to gpodder (231 bytes, patch)
2010-04-06 21:45 UTC, Rene Castberg
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Niels Breet (reporter) maemo.org 2009-09-23 16:33:35 UTC
EXPECTED OUTCOME:
Leave gpodder open and have new podcasts downloaded and ready when I leave the
house.

ACTUAL OUTCOME:
Need to manually check for new episodes and download them.

COMMENTS:
If you have access to a Nokia S60 phone and use the podcasts app there, you can
see how they implemented that. You need to select your default connection and
the check interval.
Comment 1 Thomas Perl 2009-12-12 15:15:30 UTC
Related info for implementation (just a personal note):

https://bugs.maemo.org/show_bug.cgi?id=5399
Comment 2 Markus 2010-01-04 14:41:51 UTC
A related and maybe more general option could be to have gPodder automatically
download new podcasts only when connected to a WLAN. Maybe also at specific
times of the day. Outcome: Fresh podcasts every morning, but not if your WLAN
failed the the phone switched to 3G.
Comment 3 Rene Castberg 2010-04-06 21:43:53 UTC
Here is a quick attempt at trying to solve this problem (as gpodder used half
my monthly bandwidth on the 1st of april) . It prevents a refresh of the
podcast list while on a gsm network, thus preventing it from downloading while
on the GSM network.

I have tested it for 1 day now and it seems to work.

It will require more work to get this into a full solution, but at the moment i
have no time, and its somewhat above my python skills.

Copy check_wlan.py to your /usr/local/lib/python2.5/site-packages/
patch the gui.py file with the attached diff.
Comment 4 Rene Castberg 2010-04-06 21:44:27 UTC
Created an attachment (id=2578) [details]
Check the network connection type
Comment 5 Rene Castberg 2010-04-06 21:45:24 UTC
Created an attachment (id=2579) [details]
Adds the check to gpodder
Comment 6 Thomas Perl 2011-02-19 15:28:46 UTC
*** Bug 10940 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Perl 2011-02-19 15:38:16 UTC
Implemented: http://gpodder.org/commit/c9e725b7