Bug 5142 - SDK: Hildon-desktop crashes when displaying a button on a transparent background
: SDK: Hildon-desktop crashes when displaying a button on a transparent background
Product: Desktop platform
: 5.0/(2.2009.51-1)
: All Ubuntu
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: home-bugs
: crash, moreinfo
  Show dependency tree
Reported: 2009-09-15 18:48 UTC by Andrew Olmsted
Modified: 2010-09-27 11:54 UTC (History)
3 users (show)

See Also:



You need to log in before you can comment on or make changes to this bug.

Description Andrew Olmsted (reporter) 2009-09-15 18:48:42 UTC
FREMANTLE_X86 using the Maemo 5 Beta 2 SDK

Compile and run the "example-label-home-applet" (from
libhildondesktop-2.1.28+0m5) application with the following change:

line 117 was -> label = gtk_label_new ("An example applet");
line 117 becomes -> label = gtk_button_new_with_label ("An example applet");

When added to the desktop, the application shows a GtkButton on a transparent

hildon-desktop displays the text label of the button (but no decoration to
indicate it is a button) then crashes

Always.  Sometimes it crashes on load, usually on mouse over or button press


Changing the GtkLabel to a GtkImage loaded from stock works fine.  I haven't
tested to see if other widget types crash the same way.  Here is the console
text at the time of the crash:

hildon-home[3219]: GLIB ERROR ** Gdk - The program 'hildon-home' received an X
Window System error.                                                            
This probably reflects a bug in the program.                                    
The error was 'BadMatch (invalid parameter attributes)'.                        
  (Details: serial 462 error_code 8 request_code 70 minor_code 0)               
  (Note to programmers: normally, X errors are reported asynchronously;         
   that is, you will receive the error a while after causing it.                
   To debug your program, run it with the --sync command line                   
   option to change this behavior. You can then get a meaningful                
   backtrace from your debugger if you break on the gdk_x_error() function.)    
maemo-launcher: child (pid=3219) terminated due to signal=6

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/ Safari/532.0
Comment 1 Andre Klapper maemo.org 2009-09-16 15:35:54 UTC

The console text isn't helpful. :-(
Comment 2 Andre Klapper maemo.org 2009-09-16 19:49:57 UTC
Any chance of running this in gdb to get a nice stacktrace?
Comment 3 Andrew Olmsted (reporter) 2009-09-16 20:06:17 UTC
Andre, if I understand it correctly I would have to run the entire
hildon-desktop process in gdb, since individual desktop widgets share that
process.  Is there somewhere that describes this procedure?
Comment 4 Andre Klapper maemo.org 2009-09-28 14:34:51 UTC
Hi Andrew, as far as I know:

Install maemo-debug-scripts and valgrind for SDK tools repo, start application
framework normally under Xephyr, kill hildon desktop process, then re-start it
with run-with-valgrind/memcheck script (which comes from maemo-debug-scripts).

Some more info (though these refer to Diablo):
Comment 5 Andre Klapper maemo.org 2009-09-30 02:33:39 UTC
moreinfo as per last comment
Comment 6 Andre Klapper maemo.org 2010-01-11 16:05:24 UTC
Hi Andrew, is this still an issue in the current SDK?
If not, it's probably good to close this as RESOLVED WORKSFORME.
Comment 7 Andrew Olmsted (reporter) 2010-01-16 16:17:49 UTC
After an apt-get dist-upgrade in the SDK to update to the latest packages, this
bugs is still present.  Same error message as before, and a button in a desktop
widget crashes the entire dekstop.
Comment 8 Venomrush 2010-03-23 23:29:07 UTC
Is this still reproducible with PR1.2 SDK (coming Wednesday March 24th, 12:00
Comment 9 Andre Klapper maemo.org 2010-04-26 14:50:50 UTC
Andrew, is this still reproducible with PR1.2 SDK?
Comment 10 Andre Klapper maemo.org 2010-09-27 11:54:17 UTC
Closing this bug report as the issue could not be reproduced. Please feel free
to reopen this report if you can still reproduce this.