Bug 5137 - Add option to disable/enable periodic apt updates
: Add option to disable/enable periodic apt updates
Product: Settings and Maintenance
Application manager
: 5.0-beta2
: All Maemo
: Low enhancement with 19 votes (vote)
: ---
Assigned To: unassigned
: application-manager-bugs
: http://talk.maemo.org/showthread.php?...
  Show dependency tree
Reported: 2009-09-12 23:42 UTC by Saturn
Modified: 2012-03-24 11:39 UTC (History)
6 users (show)

See Also:



You need to log in before you can comment on or make changes to this bug.

Description Saturn (reporter) 2009-09-12 23:42:27 UTC

There is no option to disable the update-notifier in the control panel or

User should be able to enable or disable the regular checks for updates.

Updates are searched when the first connection to the web if the check_interval
has passed.



It quite annoying when slow connections are established or inside the corporate
network. Sometimes also expensive when using a mobile connection.   

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:
Gecko/20090824 Firefox/3.5.3
Comment 1 Lucas Maneos 2009-09-13 01:11:38 UTC
(In reply to comment #0)
> There is no option to disable the update-notifier in the control panel or
> elsewhere.

Strictly speaking there is (Control panel -> Panels -> Status bar -> uncheck
"Software update notifier"), but that doesn't seem to affect the actual
updates, only the notification.  After disabling it,
/var/lib/alarmd/alarm_queue.xml and the
/apps/hildon/update-notifier/check_interval GConf value both remain unchanged.

I'm leaving it off until the next scheduled update (tomorrow morning) to see
what happens.
Comment 2 Saturn (reporter) 2009-09-13 03:17:00 UTC
Maybe the summary description was not that accurate so if someone has a better
idea please change it. 

The requested functionality is to to provide an option to disable the automatic
communication with the repositories to check for updates.
Comment 3 Lucas Maneos 2009-09-13 15:20:19 UTC
With the notifier still off the periodic update did happen (as evidenced by the
timestamps of /var/cache/apt/*) and another update has been scheduled for 24
hours later.

A workaround suggested in <http://talk.maemo.org/showthread.php?t=30251> is to
set the check interval to a sufficiently large value, eg:

gconftool -st int /apps/hildon/update-notifier/check_interval 2147483647

The other suggestion in that thread (application manager settings after
enabling red pill mode) doesn't show any relevant options for me.  There's an
"Always check for updates" checkbox, but that's already disabled and does
something different according to <http://wiki.maemo.org/Red_Pill_mode>.

Also, according to <http://hildon-app-mgr.garage.maemo.org/testing.html>:
> Setting the check-interval to zero means to use the default interval, which
> is 24 hours.

(confirmed also by is_package_cache_updated() in

One suggestion would be to interpret a zero value as "never" and remove any
pending alarmd jobs, and possibly at some point provide a GUI for setting the
check_interval value.
Comment 4 t3st3r 2010-01-03 11:19:53 UTC
Let's agree, good option. It would be quite unpleasant to download quite large
refreshed lists if connected via expensive connection.
Comment 5 Jayford 2010-01-30 18:47:46 UTC
I would also like to suggest adding an option to disable the updates only for
3G connections. Many countries don't have unlimited bandwidth plans and i.e I'm
limited to 30MB a month. Each time(in a 24 hour period) I connect to a 3G
connection I instantly use about 3MB. I'll use the workaround but I'd also like
to get updates when I'm at home with the wifi.
Comment 6 Andre Klapper maemo.org 2010-06-04 12:49:52 UTC
*** Bug 10544 has been marked as a duplicate of this bug. ***
Comment 7 michael.buro 2010-07-25 03:57:20 UTC
I tried 

gconftool -st int /apps/hildon/update-notifier/check_interval 2147483647

and removed the battery, but update checks are still run every day.
How can I remove persistent alarm queue entries?
Comment 8 Andre Klapper maemo.org 2010-10-24 17:35:29 UTC
*** Bug 11441 has been marked as a duplicate of this bug. ***
Comment 9 Andre Klapper maemo.org 2012-03-24 11:39:31 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.

( Tag for mass-deleting bugmail: [cleanup20120324] )