Bug 5133 - Brainstorm solutions should be editable
: Brainstorm solutions should be editable
Status: RESOLVED FIXED
Product: maemo.org Website
Brainstorm
: unspecified
: All Linux
: High major (vote)
: ---
Assigned To: Henri Bergius
: brainstorm-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-09-11 00:23 UTC by Attila Csipa
Modified: 2009-10-02 16:29 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Attila Csipa (reporter) nokia 2009-09-11 00:23:40 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:
Enter a solution in maemo.org brainstorm. Have useful input and decide to
update solution.
EXPECTED OUTCOME:
Click edit.. somewhere :)
ACTUAL OUTCOME:
No edit functionality visible
REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
I put this in general because I wasn't sure about the component... Maybe
brainstorm should have it's own ?

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.13)
Gecko/2009080315 Ubuntu/9.04 (jaunty) Firefox/3.0.13
Comment 1 Quim Gil nokia 2009-09-11 10:35:27 UTC
Indded. However posts an idea should be able to edit it afterwards. 

Not being able to edit your own comments in Brainstorm is probably fine...
although if we can edit Talk posts why not Brainstorm comments.
Comment 2 Lucas Maneos 2009-09-13 15:34:09 UTC
*** Bug 5138 has been marked as a duplicate of this bug. ***
Comment 3 Quim Gil nokia 2009-09-26 18:11:24 UTC
This is a major bug that is stopping the Brainstorm take-off. Please do
something. In principle is a simple matter of permissions, is that right?
Comment 4 Henri Bergius 2009-10-02 14:45:10 UTC
There was an issue with permissions checks that prevented editing from
non-moderators, but this is fixed by
http://trac.midgard-project.org/changeset/23535

I'll try to deploy it with Niels ASAP
Comment 5 Henri Bergius 2009-10-02 16:29:53 UTC
Deployed, may need a cache refresh (Ctrl-Reload with the browser) to take
effect.