Bug 5130 - (int-138281) Use of "yes/no" in JavaScript confirmation dialogues is confusing
(int-138281)
: Use of "yes/no" in JavaScript confirmation dialogues is confusing
Status: RESOLVED WONTFIX
Product: Browser
User interface
: 5.0-beta2
: All Maemo
: Low normal with 5 votes (vote)
: ---
Assigned To: Nagineni Sudarsana Babu
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-09-10 12:27 UTC by Andrew Flegg
Modified: 2009-12-10 16:41 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Andrew Flegg (reporter) maemo.org 2009-09-10 12:27:57 UTC
SOFTWARE VERSION:
1.2009-36-10

STEPS TO REPRODUCE THE PROBLEM:
1) Log in to Gmail's AJAX interface, http://mail.google.com/mail/
2) Perform an action which results in a server call.
3) Whilst the call is being closed, close the browser window.

EXPECTED OUTCOME:
Gmail detects the window close and presents a message along the following
lines:

    "Are you sure you want to navigate away from this page? There is 
     a server request still pending, and this will be discarded.
     Press OK to continue, or Cancel to return."

Since it is unknown how pages will use the JavaScript query dialogue, there
should be "OK" and "Cancel" buttons.

ACTUAL OUTCOME:
There are "Yes" and "No" buttons.

REPRODUCIBILITY:
always

OTHER COMMENTS:
There's no magic fix for this except to have standard buttons for the
JavaScript dialogues, despite this being against the Fremantle HIG.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.2)
Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Comment 1 Andrew Flegg (reporter) maemo.org 2009-10-23 13:19:03 UTC
*** Bug 5704 has been marked as a duplicate of this bug. ***
Comment 2 timeless 2009-11-15 01:36:47 UTC
fwiw, the ui team refuses to let the browser team fix this....
Comment 3 Andre Klapper maemo.org 2009-12-10 16:41:48 UTC
Yes, this is a WONTFIX unfortunately...