Bug 5128 - (int-137179) Stock items show mnemonics but discouraged by HIG
(int-137179)
: Stock items show mnemonics but discouraged by HIG
Status: VERIFIED FIXED
Product: Desktop platform
hildon-theme
: 5.0/(1.2009.42-11)
: All Maemo
: Low normal with 1 vote (vote)
: 5.0/(1.2009.44-1)
Assigned To: unassigned
: hildon-theme-bugs
:
:
:
: 5071 5083 5094 5129
  Show dependency tree
 
Reported: 2009-09-09 15:48 UTC by Cornelius Hald
Modified: 2010-01-11 14:50 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Cornelius Hald (reporter) 2009-09-09 15:48:15 UTC
STEPS TO REPRODUCE THE PROBLEM:
Create a stock item and display it. For example a stock button.
GtkWidget *b = gtk_button_new_from_stock (GTK_STOCK_ABOUT);

EXPECTED OUTCOME:
The button is drawn without mnemonic.

ACTUAL OUTCOME:
The button is drawn with mnemonic.
The problem is, that this is discouraged by the HIG and thus leads to several
separate bug reports for single applications. See for example: #5094 #5071

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2009-10-15 14:22:02 UTC
Fixed in internal week 42 build.

Any public update released with or after this build version (x.2009.42-x) will
include the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 2 Andre Klapper maemo.org 2009-11-16 14:04:02 UTC
Please note that the fix for this issue is NOT included in the final Maemo5
version 1.2009.42-11 that was released today.
The fix will be included in the next update after 1.2009.42-11.
Comment 3 Andre Klapper maemo.org 2009-12-09 21:10:51 UTC
*** Bug 6759 has been marked as a duplicate of this bug. ***
Comment 4 Andre Klapper maemo.org 2010-01-11 14:49:02 UTC
This is fixed in the small update that was released today (version
1.2009.44-1).