Bug 5109 - Deleting email should be more evident...
: Deleting email should be more evident...
Status: RESOLVED FIXED
Product: Email
General
: 5.0-beta2
: other Maemo
: High enhancement with 2 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-09-08 07:55 UTC by Tim Samoff
Modified: 2010-01-14 12:28 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Samoff (reporter) maemo.org 2009-09-08 07:55:15 UTC
STEPS TO REPRODUCE THE PROBLEM:
1. Use IMAP account (haven't tested using POP3, so this could be the same).
2. Delete email (especially with the "bulk" delete feature)

EXPECTED OUTCOME:
It would be more helpful if emails that were deleted (either from the 
email itself, or from the bulk delete operation) could be "marked," 
either by being italicized, grayed-out, or _simply removed from the list_.

ACTUAL OUTCOME:
If, from and email, I click the delete icon and then quickly navigate back to
my inbox, most times I will see the title of the email I just read and then
deleted until the server can actually delete the email. If I do the bulk delete
function (from the main menu), clicking Delete will take me back to my inbox
where I can see all of the emails I just marked for deletion, until the server
instigates the delete.

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
This becomes even more important with a slow connection, since someone 
might try to delete the same email over and over without understanding 
that it has already been marked for deletion.
Comment 1 Quim Gil nokia 2009-12-07 09:56:31 UTC
It would be interesting to know if this is a problem now, and if it's for more
people.

I'm not feeling it myself, and I'm a heavy email user in the N900.
Comment 2 Tim Samoff (reporter) maemo.org 2009-12-07 17:27:33 UTC
(In reply to comment #1)
> It would be interesting to know if this is a problem now, and if it's for more
> people.
> 
> I'm not feeling it myself, and I'm a heavy email user in the N900.
> 

This has been "fixed" by adding a strike-through to email subject titles. This
is good. However, I've seen instances where it doesn't always happen.

Before closing the bug, would there be any way to put the functionality through
any sort of optimization testing?
Comment 3 Quim Gil nokia 2009-12-23 18:39:36 UTC
How it works in the PR1.1 I'm testing and my own nokia.com IMAP account is:

- Select a bulk of emails for deletion.
- Press "Delete" button.
- Screen gets frozen for few seconds while the "wheel" is moving. Clearly the
app is telling you to wait and you can't do much.
- Then the list is refreshed and you can continue with your email reading. The
deleted emails are gone.

Resolving as FIXED. Please reopen this as a bug if you test this and are still
unhappy.
Comment 4 Andre Klapper maemo.org 2010-01-14 12:28:02 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.