Bug 4976 - (int-144914) Add option in modest to add/not add new contact when replying to mail
(int-144914)
: Add option in modest to add/not add new contact when replying to mail
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(3.2010.02-8)
: All Windows
: Low normal with 12 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-08-24 12:01 UTC by Oskar
Modified: 2010-03-15 20:55 UTC (History)
10 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Oskar (reporter) 2009-08-24 12:01:08 UTC
SOFTWARE VERSION:
5.2008.43-7

STEPS TO REPRODUCE THE PROBLEM:
In Modest, select a mail by somebody who is not yet in your address book
(ccontacts). Reply to this mail.

EXPECTED OUTCOME:
Sender of the original mail is added to contacts only if a respective
(currently non-existent) checkbox is selected in Modest. User has the choice to
not have Modest add new entries to the contact list.

ACTUAL OUTCOME:
New entry is always added, Modest doesn't offer a checkbox to influence this
behavior.

REPRODUCIBILITY:
always


OTHER COMMENTS:
"Checkbox" in Modest could well be some other way of tweaking the client's
behavior, like config files or GConf setting.
It's important to control this as soon as you start actually *using* the
contacts as such. You'll want to control what's in there, you'll want to avoid
duplicates,...



User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9)
Gecko/2008052906 Firefox/3.0
Comment 1 pepitoe 2009-09-23 11:15:30 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Tim Edmonds 2009-11-18 00:30:02 UTC
how annoying is this! it even adds all of the cc names so contacts ends up full
of junk.
Comment 3 John Veness 2009-11-30 14:02:10 UTC
Thunderbird has a feature where automatically added addresses can be added to a
separate address book (e.g. called "Collected addresses"), which the user can
periodically prune if they wish, or drag addresses into their main address
book. I don't know if Modest supports multiple address books, or some other
feature that could be used to separate automatically added addresses, e.g.
tagging, though.
Comment 4 Andre Klapper maemo.org 2009-12-14 11:14:29 UTC
This has been fixed in package
modest 3.2.3-1+0m5
which is part of the internal build version
2009.50-7
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Note that Nokia does not announce release dates of public updates in advance.
Comment 5 John Veness 2009-12-14 17:35:14 UTC
Thanks for reporting this as fixed, Andre. I searched git.maemo.org to see if I
could find the changes relevant to this, which appear to be:
https://git.maemo.org/projects/modest/gitweb?p=modest;a=commit;h=0e377cfc61f7e67a47e50096e1ad4a3dead53731
and
https://git.maemo.org/projects/modest/gitweb?p=modest;a=commit;h=1480a316467e5c0ba6dda72b8c7dafe4ba46dbb0
(correct me if I'm wrong), which looks like a new tickbox has been added to
control whether addresses are automatically added to the addressbook or not.
Comment 6 Andre Klapper maemo.org 2009-12-29 13:01:58 UTC
*** Bug 7428 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2010-01-14 13:41:43 UTC
(Fix not included in today's 2.2009.51-1 update => updating Version field)
Comment 8 Andre Klapper maemo.org 2010-01-19 21:18:59 UTC
*** Bug 8259 has been marked as a duplicate of this bug. ***
Comment 9 Lucas Maneos 2010-01-28 18:50:48 UTC
*** Bug 8619 has been marked as a duplicate of this bug. ***
Comment 10 Jon Hedemann 2010-01-28 21:17:47 UTC
If this has been fixed in package
modest 3.2.3-1+0m5
which is part of the internal build version 2009.50-7, why is it still present
in the released build 2.2009.51-1?
Comment 11 tuukka.tolvanen nokia 2010-01-29 03:24:17 UTC
This fix didn't go to the "2." release branch, so not in 2.2009.51-1; it should
appear in a subsequent update.
Comment 12 Lucas Maneos 2010-01-30 13:06:42 UTC
*** Bug 8681 has been marked as a duplicate of this bug. ***
Comment 13 Tomas Walch 2010-03-02 14:57:12 UTC
I still get this behaviour in 3.2010.02-8 and according to comment #11 the fix
should be included in the version after 2.2009-51. If fix still exists inside
Nokia only please consider setting bugs to fixed with the version the fix was
actually included in (like with all other software development), or you will
continue to get comments like this one.
Comment 14 Andre Klapper maemo.org 2010-03-04 13:48:33 UTC
It's not in 3.2010.02-8 as it was a minor update. The PR1.2 update (really the
next one) will include it.
Comment 15 Andre Klapper maemo.org 2010-03-15 20:55:53 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).